problem getting java to work with firefox in linux

I'm trying to get java plugin to work with firefox but it doesn't seem to be working.
I'm running CentOS 5.5 x64 (as root)

I download java 6 update 22 bin and extracted to /opt.

In ~/.mozilla/plugins i created symlink to /opt/jre1.6.0_22/lib/amd64/ and restarted firefox.  the plugins page doesn't show it and going to java site to verify only causes firefox to say plugin is missing and directs to the same java download page.

Just as a test, I deleted the jre folder under /opt, download the 32bit jre and extracted it there, created new symlink in plugins folder for the plugin file and firefox still doesn't show the plugin.

Shouldn't it work?  Am i missing something?
LVL 36
Seth SimmonsSr. Systems AdministratorAsked:
Who is Participating?
Seth SimmonsConnect With a Mentor Sr. Systems AdministratorAuthor Commented:

seems they made some changes as of update 12; created symlink to the other file and it's now working
CEHJConnect With a Mentor Commented:

Doesn't look like the right library
Seth SimmonsSr. Systems AdministratorAuthor Commented:
hmm...that was the only file i could find with plugin in the name
A proven path to a career in data science

At Springboard, we know how to get you a job in data science. With Springboard’s Data Science Career Track, you’ll master data science  with a curriculum built by industry experts. You’ll work on real projects, and get 1-on-1 mentorship from a data scientist.

So it *wasn't* the right file was it...
Duncan RoeSoftware DeveloperCommented:
:medvedd: thanks for your comment. I've been running Firefox 3.5 because I couldn't get java in 3.6 - the link you posted would seem to explain that. The instructions therein look to me as if they should work for x86_64 as well. seth2740: do they work or not?
OK, get it working for Firefox 3.6.12 and Java 6-22.
Start firefox, in about:config make sure that

java.java_plugin_library_name is javaplugin

Then in your plugins directory:

ln -s /usr/java/jre1.6.0_22/lib/i386/

Can't find firefox 3.6.12 64 bit, but it should similar.
Mentioned that the file was wrong
Duncan RoeSoftware DeveloperCommented:
:medvedd: thanks again. It worked a treat, even with Java 6-21.
If I were you, I'd be objecting again - you actually gave an answer and IMHO you deserve the points
Yes, it's quite possible that others are deserving of points too. A split is fine by me
Following an 'Objection' by CEHJ (at to the intended closure of this question, it has been reviewed by at least one Moderator and is being closed by accepting the author's answer and awarding points to an Experts comment as an assisted answer.
At this point I am going to re-start the auto-close procedure.
Thank you,
Community Support Moderator
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.