We help IT Professionals succeed at work.

Why is Outlook 2007 ignoring my command to append a text file to my user's Safe Senders lists?

1,418 Views
Last Modified: 2012-05-10
Greetings -

I have a Group Policy deployed in my environment for Outlook 2007 that does two things related to the Junk E-mail Safe Senders list:

1.  Specifies the path to a text file located on the user's workstation that contains a simple list of domain names.

2.  Flips the registry value JunkMailImportLists to "1" to tell Outlook to import the Safe Senders list each time it launches.  The path to this value is: HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\Options\Mail

This configuration worked fine for a long time.  Sometime in the past few months, I have no idea when, this stopped working.

I have Exchange 2010 and Office 2007 in my environment.  I'm wondering if my upgrade to Exchange 2010 might be causing the Outlook client to behave differently, or if a patch Microsoft released for Outlook broke this functionality but either way: the text file I specify is no longer appended to Outlook's Safe Senders list anymore.  It flat out ignores it.  Regardless of what I put in the Safe Senders text file now, Outlook does not import the values.

The web is loaded with inconsistent information on how to configure a GPO for importing a Safe Senders list throughout an enterprise.  I worked with Microsoft Premier on this configuration and it *did* work for months.  I've set the JunkMailImportLists registry key which was missing from the original Office ADM file - a known bug.  I've configured the proper path to the file, the file exists, and this issue happens on any profile on any workstation.  So I'm at a loss here.

Before I call Premier, I wanted to know if anyone else has seen this behavior.  When upgrading to Exchange 2010, did your import stop working?  Has a patch broken this?  Any other input?
Comment
Watch Question

Rick FeeMessaging Engineer - Disaster Recovery Engineer
CERTIFIED EXPERT

Commented:
Not sure I set this up for my last company, which they had Outlook 2003.   Its not a great change for 2007.   I have attached my proedure how I set it up.    I understand this was already working for you at one time, but I would go over this doc to see if it kicked off a lightbulb.

Is the share for the text file up and accessible?  
GPO---Outlook-SafeSender-Import.doc

Author

Commented:
Yeah I reviewed your Doc and it's nearly identical to what I'm doing.  The only difference is, the safe senders list is a file local each workstation, not up on a share.  I push the file to the workstation using Group Policy Preferences.  It is accessible.

I've tried pointing it to a copy of the file on sysvol as well and it makes no difference so I've taken permissions issues off the list of potential problems at this point.

Frustrating for sure...
Rick FeeMessaging Engineer - Disaster Recovery Engineer
CERTIFIED EXPERT

Commented:
This might be a pain...but what about creating a test GPO...to see if it works?  

Author

Commented:
What do you mean create a test GPO?  I've already got a GPO in place with this functionality.  You mean recreate it entirely?

The GPO's values are definitely getting written to the registry.  I can validate that manually.  The safe senders list path is properly published as well as the JunkMailImportLists value.

I'm confused as to what you're asking.
Rick FeeMessaging Engineer - Disaster Recovery Engineer
CERTIFIED EXPERT

Commented:
Yes recreate it entirely...or create a test GPO and apply it to only one user to see if it works.   There might be something wrong with your orginal GPO.    Do you see the last time to orginal gpo was modified?

Author

Commented:
Well if the registry values are there for the safe senders file and the JunkMailImportLists value is set correctly, regardless of the GPO's health, Outlook should append the list.

But just for troubleshooting sake, I did recreate the entire GPO, applied it only to my computer and user accounts, denied the old GPO via security filtering, ran gpupdate and I get the same result.  The registry entries are proper, Outlook doesn't listen.

Author

Commented:
I have a suspicion that this behavior began when we upgraded our Exchange 2007 environment to 2010.  Tough I have no idea where the settings are that would cause the client to behave this way.  Perhaps Exchange 2010 maintains tight, centralized control over an aggregated safe senders list or something that causes Outlook to ignore what I'm telling it.

Anyway, doesn't seem like there's a solution to the problem.  I'll leave the question open for a few more days and if I end up talking to Microsoft Premier, I'll post what I learned here.
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Author

Commented:
Premier confirmed behavior is by design.

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.