Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

NAT on cisco 1841 router syntax qestion

Posted on 2010-11-16
9
376 Views
Last Modified: 2012-05-10
I  have 1841 cisco router with  ver 12.3
and I am looking detailed syntax on how toadd NAT translation for  local static ip node ip nat
192.168.0.12 so that it can communcation with remote public IP sites.

this is what I have for anohter IP
source static tcp 192.168.0.166 654.55.xxx.xxx extendable
access-list 5 permit 192.168.0.166
access-list 120 permit tcp host 192.168.0.166 any
0
Comment
Question by:leop1212
  • 5
  • 4
9 Comments
 
LVL 15

Expert Comment

by:greg ward
ID: 34152585
this assumes you have another ip address to nat with and the second ip address would be 654.55.xxx.xxx


conf t
source static tcp 192.168.0.12 654.55.xxx.xxx extendable
access-list 5 permit 192.168.0.12
access-list 120 permit tcp host 192.168.0.12 any


Greg
0
 

Author Comment

by:leop1212
ID: 34154821
getting an error
myrouter(config)#source static tcp 192.168.0.12
                                           ^
% Invalid input detected at '^' marker.
0
 
LVL 15

Expert Comment

by:greg ward
ID: 34157368
my bad
inside source static tcp 192.168.0.12 654.55.xxx.xxx extendable
access-list 5 permit 192.168.0.12
access-list 120 permit tcp host 192.168.0.12 any


Greg
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 

Author Comment

by:leop1212
ID: 34157511
(config)#inside source static tcp 192.168.0.12 65.xxx.xxx.xxx extendable
                   ^

now error is on ins
see above
0
 
LVL 15

Expert Comment

by:greg ward
ID: 34157596
does
 ip nat inside source static tcp 192.168.0.12 654.55.xxx.xxx extendable
access-list 5 permit 192.168.0.12
access-list 120 permit tcp host 192.168.0.12 any

work?
0
 

Author Comment

by:leop1212
ID: 34157692
lawrence(config)#ip nat inside source static tcp 192.168.0.12 65.232.xxx.65 etendable
                                                                                                        ^
nope
now it is poing to the dot shoud it be port range in beween?
0
 
LVL 15

Expert Comment

by:greg ward
ID: 34157783
ip nat inside source route-map POLICY-NAT interface Dialer1 overload
ip nat inside source static tcp 172.25.0.2 456 interface Dialer1 456
ip nat inside source static tcp 172.25.0.2 9999 interface Dialer1 9999
!
ip access-list extended NAT
 permit ip 172.25.0.0 0.0.255.255 any

route-map POLICY-NAT permit 10
 match ip address NAT

The above is what i have  on my router
do you have a pool of addresses as you can change the interface command to a pool
do you want to nat an ip or just a port?

Greg
0
 

Author Comment

by:leop1212
ID: 34158559
i do like to map and IP  (acctually I have 3 static iaddresses  to NAT 0.12  0.11 0.13)
0
 
LVL 15

Accepted Solution

by:
greg ward earned 500 total points
ID: 34159125
http://www.experts-exchange.com/Networking/Misc/Q_20650588.html

looks like this has been asked before.


Greg
0

Featured Post

Portable, direct connect server access

The ATEN CV211 connects a laptop directly to any server allowing you instant access to perform data maintenance and local operations, for quick troubleshooting, updating, service and repair.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
How to choose hardware firewall 5 60
iPad Won't Connect 16 94
Add Mac address reservation to Sonicwall TZ 210 router 1 62
snmp-server enable traps gdoi ks-rekey-pushed 3 22
Hello , This is a short article on how would you go about enabling traceoptions on a Juniper router . Traceoptions are similar to Cisco debug commands but these traceoptions are implemented in Juniper networks router . The following demonstr…
The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

856 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question