Solved

Can't Open JPG files with Windows Photo Gallery

Posted on 2010-11-16
9
785 Views
Last Modified: 2012-05-10
About a week ago I had to recreate a domain user account on Windows Vista because a DC had to be completely recreated.  With Windows XP this is pretty simple because you can save off the profile and then copy it back once the user has logged in once.  In Vista I thought this had worked, but I have a lingering issue that is dogging me.

I have  USB drive that has is loaded with MP3s and has a few JPGs.  I think there is some sort of permissions problem that is not allowing me to open JPG files in Windows Photo Gallery.  I get the error "Windows cannot access the specified device, path, or file.  YOu may not have the appropriate permissions to access the item.".  That's strange since I'm only trying to view it.  I can open it with IE just fine.  Thinking it's a permissions problem I tried to change the ownership of the file.  If I try to change the permissions in any way, I get the error "Can't open access control editor. Access is denied.".   I get that for any file on that USB drive that I tried to alter the permissions on.

So, then I logged in as the local administrator and everything is fine.  I was even able to change the ownership to the local administrators group.  My Domain account is in the local administrators group too.  Even though it let me change it, when I log in with the domain account, nothing has changed.

I have some of the same files in my "My Music" folder, and the JPGs behave the same way when trying to open them, however I can change the permissions.

It's almost as if this computer isn't recognizing my domain account as a real administrator on the computer.  Is the ghost of the old domain account haunting me, and if so, how can I get rid of it.

Please help...
0
Comment
Question by:darrylka
9 Comments
 
LVL 5

Expert Comment

by:piji
ID: 34151716
Always as you mentioned there is problem with file sercurity issue. What I suggest is login as local administrator which everything is fine and then move your files to thumb drive and log in with domain user and copy back all the files to where you want it. Otherwise you need to login as loacal admin account and remove all the premission and inheritate from the parent.
0
 
LVL 5

Author Comment

by:darrylka
ID: 34151755
Well I could certainly try that, but there is about 2gb worth of files, so it would take several hours to copy it to another USB hard drive, and then several hours to copy it back.

When I logged in as the local administrator, it let me change the owner on the entire drive to the Local Administrators group, which my domain user is a member.

Also, I can't change the owner of files that are in the My Music folder of the account.  It tells me "Can't open access control editor".

Like I said, it's like it's not recognizing my domain account as a local administrator.
0
 
LVL 5

Expert Comment

by:piji
ID: 34151838
what about if you create new folder and move the files, you can try with one sample to see how it goes
0
The Eight Noble Truths of Backup and Recovery

How can IT departments tackle the challenges of a Big Data world? This white paper provides a roadmap to success and helps companies ensure that all their data is safe and secure, no matter if it resides on-premise with physical or virtual machines or in the cloud.

 
LVL 5

Author Comment

by:darrylka
ID: 34151929
I turned of UAC and everything is fine.
0
 
LVL 5

Expert Comment

by:piji
ID: 34152072
It doesn't really sence but sorry can't help you more.
0
 
LVL 5

Author Comment

by:darrylka
ID: 34153912
Turning off UAC must just ignore all user permissions rules on files?  I'm not sure either, but for some reason I couldn't access files that I should have had full permissions to.  These were only files that the old domain user with the same name had admin rights to.
0
 

Expert Comment

by:thesslstore
ID: 34154371
May you new A/c is not recognize you old a/c or not support permission to open a USB drive.

And some time there is not enough to change permission but also give a proper rights to access if you give manually otherwise it is default.
0
 
LVL 5

Author Comment

by:darrylka
ID: 34225346
I believe what has happened is that it is still using permissions from the older Domain account that has the same name but a different code (whatever that's called), and it refused to recognize the new one.  Turning off the UAC worked, but it seems to me there should be an easier, more straight forward way to accomplish this.  I have since copied all the files off that drive.
0
 
LVL 44

Accepted Solution

by:
Jackie Man earned 500 total points
ID: 34464058
My wild guess is that there is an unknown account (i.e. the older Domain account) holding the permission of the files and folders of the external drive and the music folder.

The information in the link below might be helpful for you.

http://social.answers.microsoft.com/Forums/en-US/vistafiles/thread/3655fea0-7adf-41b7-9c0a-38ec327a6ab8

In short, try the following:-

1. logon as local administrator
2. remove the unknown account (olded Domain account) for the NTFS permission of the external drive and the music folder.
3. Grant Everyone the full control of the NTFS permission of the external drive and the music folder.
4. Logon domain with the domain user and take ownership of the external drive and the music folder and remove Everyone from the full control of the NTFS permission of the external drive and the music folder.
0

Featured Post

Ransomware: The New Cyber Threat & How to Stop It

This infographic explains ransomware, type of malware that blocks access to your files or your systems and holds them hostage until a ransom is paid. It also examines the different types of ransomware and explains what you can do to thwart this sinister online threat.  

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hi All Just a quick one for everybody. I was recently looking into setting the default User Account Picture for all my vista clients within the network but on closer inspection the group policy setting only allows you to set the default pictur…
When you try to extract and to view the contents of a Microsoft Update Standalone Package (MSU) for Windows Vista, you cannot extract the files from the MSU. Here we are going to explain how to extract those hotfix details without using any third pa…
The Task Scheduler is a powerful tool that is built into Windows. It allows you to schedule tasks (actions) on a recurring basis, such as hourly, daily, weekly, monthly, at log on, at startup, on idle, etc. This video Micro Tutorial is a brief intro…
Although Jacob Bernoulli (1654-1705) has been credited as the creator of "Binomial Distribution Table", Gottfried Leibniz (1646-1716) did his dissertation on the subject in 1666; Leibniz you may recall is the co-inventor of "Calculus" and beat Isaac…

756 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question