Resolve AD Server IP Problem

Dear all,

I have four DCs in my environment which is running Windows Server 2003. And each machine have two NICs, the first one for production (ie. 10.52.x.x) the second one is running on a Giga Network for running backup. (ie. 192.168.0.x).

Unfortunately, the DNS record will automatically add 192.168.0.x on it. Therefore, the client will resolve an 192.168.0.x instead of 10.52.x.x . This make an serious problem when the logon script mounting using the UNC path. For example, \\dc1\share.

Is there any method to avoid this happens again? I have tried manually delete the A record in DNS server, but it will automatically generate it later. Thanks.

Best regards,
Wataw
WatawAsked:
Who is Participating?
 
Chris DentConnect With a Mentor PowerShell DeveloperCommented:

You have a few choices.

You can either change DNS so it only listens on the 10.52.x.x interface (Server properties, Interfaces). Or you can prevent the additional interface registering using the method described here:

http://support.microsoft.com/kb/246804

It's the most reliable method I've found.

HTH

Chris
0
 
abhijitmdpConnect With a Mentor Commented:
Hi
As Chris-Dent: suggested You can change DNS so it only listens on the 10.52.x.x interface also you have one more way to stop registering 192.168.0.x ip in DNS for this you can follow below link.
After blocking this ip to register in DNS you'll need to remove the earlier registered ips for this in DNS.
http://support.microsoft.com/kb/305553

0
 
Mark DamenConnect With a Mentor ERP System ManagerCommented:
If they are 2 separate adapters, you should be able to achieve the end result by unticking the following on the 192.168.x.x adapter.

"Register this connection's addresses in DNS"

I might have over looked something, but surely this is simple fix and the way it was designed?
0
 
Chris DentPowerShell DeveloperCommented:

The tick-box doesn't always work in my experience, it should, but... The registry entry achieves the same thing hence the statement about it being the most reliable method I've found :)

Chris
0
 
WatawAuthor Commented:
Yes, Chris-Dent is right, the tick-box is not working and registry works. Thank you all of you, you both are great.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.