Solved

Physical Connection for Cisco 1861 router

Posted on 2010-11-17
33
938 Views
Last Modified: 2012-06-21
Hello All Experts,

I am unable to understand how to plug Internet cable into 1861,  it's strange I never see any VOIP router, But I am always trying to configure, I am doing try to configure from remote location & my partner said the 1861 has a WAN port at the back it doesn't have a built in ADSL modem as a lot of enterprises use connections other than ADSL,so we need the modem to provide the internet connection to the 1861, in Perth there is a router there which was configured for a straight through connection when the UC520 was installed so the router's wifi, dhcp etc is all inactive
it just acts as a modem I figured I would just get a modem and plug it into the 1861,

I can't suggest him for making connection,  can anyone point me for making connection, it will be a great if you can provide me any snap

it's so difficult i think but i hope experts will solve my issue
Please point me in right direction

Regards
0
Comment
Question by:kavinagpur
  • 19
  • 14
33 Comments
 
LVL 15

Expert Comment

by:deepdraw
ID: 34154521
I would suggest buying a hwic1 adsl and install it in the 1861.
This is the easiest solution and gives the router direct access to the internet.
If you want the modem set up please post back with make /model  


Greg
0
 

Author Comment

by:kavinagpur
ID: 34161335
Thanks Deepdraw,

The Linksys is an AM300, there was a letter on the end of AM300 but I can't remeber it, it is a basic ADSL2 modem
Also have a Netgear MBR624GU Router here, but I can't find a way to set it for straight through
no options in the menu..

please suggest



0
 

Author Comment

by:kavinagpur
ID: 34161490
Hello Greg,

Can you please suggest which cable i need for connect ADSL modem to 1861
Straight cable or Cross-over Cable ?
0
 
LVL 15

Expert Comment

by:deepdraw
ID: 34166081
Normally X-over but it you might want to have both...
Make sure you use the no shut command on the fa0/0 interface

Greg
0
 

Author Comment

by:kavinagpur
ID: 34170379
Hello Greg,

Thanks for your reply, I  have done configuration on Linksay's modem, I have configured device in Bridge mode & LLC  encapsulation, but not getting internet through Cisco 1861...

ISP<---> Linksys (192.168.1.1) <---> Cisco 1861 (Dynamic WAN IP from ISP), LAN 192.168.8.1, MASK 255.255.255.0) <---> workstations (192,168.8.2-192.168.8.254, MASK 255.255.255.0, Gateway 192.168.8.1)


Can you suggest me what should i do now ?
0
 
LVL 15

Expert Comment

by:deepdraw
ID: 34170705
What is the cisco config?
Did you set up the default route to fa0/0
ip route 0.0.0.0 0.0.0.0 fa0/0
also set up nat outside interface on the fa0/0
int fa0/0
ip nat outside
no shut
and nat inside on the other interface
int fa0/1
ip nat inside

Greg
0
 

Author Comment

by:kavinagpur
ID: 34170729
Hi Greg,

Thanks for your reply, I set as per below under FE 0/0 but i didn't configure  ip route 0.0.0.0 0.0.0.0 fa0/0, I'll try with this


interface FastEthernet0/0
 description outside
 no ip address
 ip nat outside
 ip virtual-reassembly
 duplex auto
 speed auto
 pppoe enable group global
0
 
LVL 15

Expert Comment

by:deepdraw
ID: 34174595
you will also need
ip nat inside source list 1 interface Fa0/0 overload

access-list 1 permit any

Greg
0
 

Author Comment

by:kavinagpur
ID: 34178330
Hello Greg,

Can you pls suggest why we need ip nat inside source list 1 interface Fa0/0 overload when we are using ip nat inside source list ToNAT interface Dialer1 overload.

Pls suggest i am confuse
0
 

Author Comment

by:kavinagpur
ID: 34178747
Hello Greg,

I used below thing but same issue yet
ip nat inside source list 1 interface Fa0/0 overload
access-list 1 permit any
I found Dialer interface not get ip address From ISP, I am not sure Linksys modem able to provide Internet or not, I configured Linksys in Bridge mode .

Please suggest

Melbourne1861#sh ip int brief

Interface                  IP-Address      OK? Method Status                Prot

ocol

FastEthernet0/0            unassigned      YES NVRAM  up                    down



FastEthernet0/0.50         unassigned      YES unset  up                    down



FastEthernet0/0.100        unassigned      YES unset  up                    down



FastEthernet0/1/0          unassigned      YES unset  up                    down



FastEthernet0/1/1          unassigned      YES unset  up                    down



FastEthernet0/1/2          unassigned      YES unset  up                    down



FastEthernet0/1/3          unassigned      YES unset  up                    down



FastEthernet0/1/4          unassigned      YES unset  down                  down



FastEthernet0/1/5          unassigned      YES unset  up                    up



FastEthernet0/1/6          unassigned      YES unset  up                    down



Vlan1                      unassigned      YES NVRAM  up                    up



Vlan100                    unassigned      YES NVRAM  up                    up



NVI0                       10.1.20.2       YES unset  up                    up



BVI1                       10.10.10.1      YES NVRAM  up                    up



Virtual-Access1            unassigned      YES unset  up                    up



BVI2                       192.168.8.1     YES NVRAM  up                    up



Dialer1                    unassigned      YES NVRAM  up                    up



Loopback0                  10.1.20.2       YES NVRAM  administratively down down



Tunnel2                    unassigned      YES NVRAM  up                    dow

FastEthernet0/1/7          unassigned      YES unset  up

Open in new window

0
 

Author Comment

by:kavinagpur
ID: 34178847
One more thing We don't have Static IP we have Static IP
0
 
LVL 15

Expert Comment

by:deepdraw
ID: 34179841

the outside interface is fa0/0
this is the one that is connected to the internet so its set to ip nat outside.
you need to update nat to
 ip nat inside source list ToNAT interface fa0/0 overload.

the cisco router is not showing as having an ip address on the internet.
without an internet ip address it cant do nat.

Greg
0
 

Author Comment

by:kavinagpur
ID: 34182201
Hello Greg,

I am getting so difficulties to find anything for fix this issue
http://help.optuszoo.com.au/help/dsl/connected/windows/modemwvista/speedstream_eth#pc_settings
Seems my ISP is using PPPoE
And I think Linksys can't be used in bridge mode with PPPoE Connection.
http://www6.nohold.net/Cisco2/ukp.aspx?pid=80&login=1&app=search&vw=1&articleid=17348&donelr=1
0
 
LVL 15

Accepted Solution

by:
deepdraw earned 500 total points
ID: 34182880
Just guessing

interface FastEthernet0/0
no ip address
speed auto
full-duplex
ipv6 enable
pppoe enable group global
pppoe-client dial-pool-number 1
no clns route-cache

interface Dialer1
no ip address
ip mtu 1492
ip pim sparse-mode
encapsulation ppp
dialer pool 1
dialer idle-timeout 0
dialer persistent
no peer neighbor-route
!
access-list 1 permit any


follow the link for more ideas
http://www.groupstudy.com/archives/ccielab/200909/msg02357.html

Greg
0
 

Author Comment

by:kavinagpur
ID: 34185831
Same issue Yet, I think we should concentrate on Linksys, But i couldn't find anything yet
0
 
LVL 15

Expert Comment

by:deepdraw
ID: 34187621
You could look at buying a cisco adsl2+ router 857(w) and 877 (w)
This would solve the internet issue, not sure what other features you require on this site
vpn?
dmvpn?
I am guessing that the routers you have would need rebooting every so often....

Greg
0
What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

 

Author Comment

by:kavinagpur
ID: 34196798
I have Cisco 877 W router, I did use Cisco 877 W  router for Access Internet & was working smooth before buying 1861, What we need from that, I Have Configuration of 877 If you need i can post it
0
 
LVL 15

Expert Comment

by:deepdraw
ID: 34198537
can you post a quick config of both routers.
It should be just a case of putting both router on the same network.

Greg
0
 

Author Comment

by:kavinagpur
ID: 34202309
Hi greg,

Please look on Both config
Final-1861.txt
Cisco-877.txt
0
 
LVL 15

Expert Comment

by:deepdraw
ID: 34208365
The 877 looks ok
I would add
line vty 5 15
login
no ip route 192.168.4.0 255.255.254.0 Dialer0
no ip access-list extended ToNAT
ip access-list extended ToNAT
 deny   ip any 10.0.0.0 0.255.255.255
 permit ip 192.168.0.0 0.0.255.255 any

The 1861 looks a bit scary and i would copy the config into a text file and start again.
Then use this part of the config

ip dhcp pool LAN-POOL
   import all
   network 192.168.8.0 255.255.255.0
   default-router 192.168.8.1
   dns-server 192.168.8.1
   lease 0 2
!
ip dhcp pool phone
   import all
   network 10.10.10.0 255.255.255.0
   default-router 10.10.10.1
   option 150 ip 10.10.10.1
!
!
no ip domain lookup
ip name-server 198.142.0.51
ip name-server 203.2.75.132
ip name-server 211.31.138.11
no ipv6 cef
interface FastEthernet0/0
 description outside
 ip address dhcp
 duplex auto
 speed auto
 
!
interface FastEthernet0/1/0
 switchport voice vlan 100
 macro description cisco-phone
!
interface FastEthernet0/1/1
 switchport voice vlan 100
 macro description cisco-phone
!
interface FastEthernet0/1/2
 switchport voice vlan 100
 macro description cisco-phone
!
interface FastEthernet0/1/3
 switchport voice vlan 100
 macro description cisco-phone
!
interface FastEthernet0/1/4
 switchport voice vlan 100
 macro description cisco-phone
!
interface FastEthernet0/1/5
 switchport voice vlan 100
 macro description cisco-phone
!
interface FastEthernet0/1/6
 switchport voice vlan 100
 macro description cisco-phone
!
interface FastEthernet0/1/7
 switchport voice vlan 100
 macro description cisco-phone
!
interface FastEthernet0/1/8
 switchport mode trunk
 macro description cisco-switch

ip route 0.0.0.0 0.0.0.0 fa0/0
ip dns server
voice-port 0/4/0
 auto-cut-through
 signal immediate
 input gain auto-control
 description Music On Hold Port
!
!
mgcp fax t38 ecm
mgcp behavior g729-variants static-pt
!
!
!
dial-peer voice 2000 voip
 description ** cue voicemail pilot number **
 destination-pattern 600
 session protocol sipv2
 session target ipv4:10.1.20.1
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
!
!
!
telephony-service
 max-ephones 12
 max-dn 30
 ip source-address 10.10.10.1 port 2000
 url services http://10.1.20.1/voiceview/common/login.do
 url authentication http://10.1.20.1/voiceview/authentication/authenticate.do  
 cnf-file location flash:
 user-locale U2 EN
 load 7931 SCCP31.8-2-2SR2S
 time-zone 44
 date-format dd-mm-yy
 voicemail 600
 max-conferences 8 gain -6
 call-forward pattern .T
 call-forward system redirecting-expanded
 moh music-on-hold.au
 web admin system name XXXXXXXXXXXXXX secret 5 XXXXXXXXXXXXXX
 dn-webedit
 transfer-system full-consult
 transfer-pattern .T
 transfer-pattern 0.T
 secondary-dialtone 0
 create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
line con 0
 exec-timeout 0 0
 password 7 04760A1E0622404F1E395D44465E
 login
 no modem enable
line aux 0
 password 7 143A13130507262A33086B667646
 login local
line vty 0 4
 password 7 04760A1E0622404F1E395D44465E
 login local
line vty 5 15
 password 7 04760A1E0622404F1E395D44465E
 login local

this will have the 877 doing the nat vpn and wireless.
the 1861 will do the voice
Greg
0
 

Author Comment

by:kavinagpur
ID: 34210384
Hello,

I have only one question on below config
interface FastEthernet0/0
 description outside
 ip address dhcp
 duplex auto
 speed auto
fa0/0 is connect to Linksys Modem & DHCP is disable on Linksys modem because we are using 1861 as DHCP server so pls let me know why we are using IP address DHCP on fa0/0..

also pls suggest which protocol should connect on Linksys modem, there is many option like PPPoe, PPPoa, Bridge,
0
 
LVL 15

Expert Comment

by:deepdraw
ID: 34211023
This is the interface I would connect to the 877 router and the ip address could be static or dynamic.
ie.
interface FastEthernet0/0
 description outside
 ip address 192.168.4.254 255.255.254.0


Greg
0
 

Author Comment

by:kavinagpur
ID: 34216110
Hello Greg,

Thanks for your help, I have attached my Present running configuration also Screen Shot of modem,
Can you please look on this, & I request to you please let me know if I'm wrong anywhere ?

I got two otion in Interface while configuring Static router on ADSL modem, LAN & WAN_Main, I selected LAN also I put 1 in cost option


ADSL-port.jpg
Lan-Port.jpg
Static-Route.jpg
6th.txt
0
 

Author Comment

by:kavinagpur
ID: 34216622
Hello Greg,

Please Look on My Network design
Topology-Melbourne.jpg
0
 
LVL 15

Expert Comment

by:deepdraw
ID: 34218086
There is nothing wrong with the config, however as the router does not have an address on the internet, it is unable to nat this address so the other users can access the internet.
Also i doubt the adsl router is a good solution, this is why i suggest that you use the cisco 877 you have.

Greg
0
 

Author Comment

by:kavinagpur
ID: 34236675
Still Having same issue

Melbourne1861#ping ip X.X.X.X  source fastEthernet 0/0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos toX.X.X.X timeout is 2 seconds:
Packet sent with a source address of 192.168.1.2
.....
Success rate is 0 percent (0/5)
0
 
LVL 15

Expert Comment

by:deepdraw
ID: 34236818
What is plugged into where ?
can you paste the output of
 show cdp ne de

Greg
0
 

Author Comment

by:kavinagpur
ID: 34236947
Thanks

Melbourne1861#sh cdp ne de
-------------------------
Device ID: CiscoAPWiFI
Entry address(es):
  IP address: 192.168.8.254
Platform: cisco AIR-AP1231G-A-K9    ,  Capabilities: Trans-Bridge
Interface: FastEthernet0/1/5,  Port ID (outgoing port): FastEthernet0.1
Holdtime : 158 sec

Version :
Cisco IOS Software, C1200 Software (C1200-K9W7-M), Version 12.3(8)JA2, RELEASE S
OFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2006 by Cisco Systems, Inc.
Compiled Tue 30-May-06 18:07 by pwade

advertisement version: 2
Duplex: full
Power drawn: 4.420 Watts

Melbourne1861#
Topology-Melbourne.jpg
0
 

Author Comment

by:kavinagpur
ID: 34236969
FastEthernet0/0            192.168.1.2     YES NVRAM  up                    up

FastEthernet0/0.50         unassigned      YES unset  up                    up

FastEthernet0/0.100        unassigned      YES unset  up                    up

FastEthernet0/1/0          unassigned      YES unset  up                    down

FastEthernet0/1/1          unassigned      YES unset  up                    down

FastEthernet0/1/2          unassigned      YES unset  up                    down

FastEthernet0/1/3          unassigned      YES unset  up                    down

FastEthernet0/1/4          unassigned      YES unset  up                    down

FastEthernet0/1/5          unassigned      YES unset  up                    up

FastEthernet0/1/6          unassigned      YES unset  up                    down

FastEthernet0/1/7          unassigned      YES unset  up                    down



Evaen i am Unable to ping Modem
Melbourne1861#ping ip 192.168.1.254 source fastEthernet 0/0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.254, timeout is 2 seconds:
Packet sent with a source address of 192.168.1.2
.....
Success rate is 0 percent (0/5)
Melbourne1861#
0
 
LVL 15

Expert Comment

by:deepdraw
ID: 34239849
I dont think that device (linksys) is capable of giving your router an external ip address.

Greg
0
 

Author Comment

by:kavinagpur
ID: 34245001
Ok I will change My Linksys Modem I have another Billion 5200 SRC Series modem, Please let me know which protocol shuld use on new modem, Means should i use bridge, PPPoe, PPPoa with Half bridge or without halfbridge, or any other please let me know..


Regards

Vikrant
0
 
LVL 15

Expert Comment

by:deepdraw
ID: 34247736
These are just for the adsl conenction. Does it have the option of  giving full access to the internet to the cisco router. If the answer is no then its not possible.

Greg
0
 

Author Comment

by:kavinagpur
ID: 34248157
How to confirm whether it has full option or not ?
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

It happens many times that access list (ACL) have to be applied to outgoing router interface in order to limit some traffic.This article is about how to test ACL from the router which is not very intuitive for everyone. Below scenario shows simple s…
Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now