Solved

SBS 2008 Restore companyweb page

Posted on 2010-11-17
10
1,167 Views
Last Modified: 2012-05-10
Hi Experts

We recently changed the IP of our server which stopped our company webpage from working, I tried to fix this by running the sharepoint products and technologies wizard to disconnect and reconnect the database. Doing this unfortunately has just setup a blank website which can only be accessed by typing in the server name instead of "companyweb", also the only account which can see the page is the domain admin account.

Can anyone help restore the old database and user permissions, thanks.
0
Comment
Question by:corecc
  • 6
  • 4
10 Comments
 
LVL 8

Expert Comment

by:jfletchster
ID: 34153919
1st thing to check is that 'companyweb' still resolves to the server.
Do a ping companyweb, check that the IP is the same as the server IP. If it doesnt resolve then you need to add a DNS A Record on the server for 'companyweb' to the server IP.
As regards it connecting to the wrong site, you need to open IIS and find the corrent WebSite, in the sites list, right click, select 'Edit Bindings' check that you have a entry in there for hostname 'companyweb' for port 80 or 443 if you are using SSL
0
 
LVL 1

Author Comment

by:corecc
ID: 34154075
Companyweb does resolve to the server IP

How do I find the correct site in IIS and can see default website this is stopped if I try to start it it says another site is already using the port, I'm guessing this would be my old site im trying to restore.

Thanks
0
 
LVL 8

Expert Comment

by:jfletchster
ID: 34154083
Usually default site is the one with the default original install, you need to look at the bindings of the other running sites and turn the one off port 80 and then you will be able to start the old defualt site.
0
 
LVL 1

Author Comment

by:corecc
ID: 34154152
I Have the following websites listed

default website
sbs client deployment app
sbs sharepoint
sbs web apps
sharepoint 80
sharepoint central
wsus

companyweb wasnt setup under bindings for the default website but was for sbs sharepoint so I removed it and added it to the default website. This didnt work, I think the issue is by running the sharepoint products and technologies wizard it looks like it has just recreated new blank sites, I think i need to find the old one and repoint it some how.
0
 
LVL 8

Expert Comment

by:jfletchster
ID: 34154240
the simplest way to get find the one that is correct is stop all the websites and start only one with a port 80 binding and a blank hostname, (so will except any)
then on the server go to the address 127.0.0.1 or localhost and see If the correct site is show, when you have identified the corrent site then you can set the correct bindings for that site
0
Free Gift Card with Acronis Backup Purchase!

Backup any data in any location: local and remote systems, physical and virtual servers, private and public clouds, Macs and PCs, tablets and mobile devices, & more! For limited time only, buy any Acronis backup products and get a FREE Amazon/Best Buy gift card worth up to $200!

 
LVL 1

Author Comment

by:corecc
ID: 34154327
Ive tried all the sites

default website - has an error about missing dependices

sharepoint 80 - is the default companyweb page not the one we created

All other sites dont load anything

I think we need to try to fix the errors on the default website
0
 
LVL 8

Expert Comment

by:jfletchster
ID: 34154679
It looks that way, what despendances are missing ?
0
 
LVL 1

Author Comment

by:corecc
ID: 34154709
It dosent say, not sure how I find out?
0
 
LVL 1

Accepted Solution

by:
corecc earned 0 total points
ID: 34258321
solved by reinstalling the server
0
 
LVL 1

Author Closing Comment

by:corecc
ID: 34289828
no solutions found
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

I used to be SharePoint evangelist in our company, so my Outlook always full of questions about how to do this, or where I can find that. One day I found such an email with the following question: "how to attach 3-State workflow (one of the workflow…
A quick step-by-step overview of installing and configuring Carbonite Server Backup.
In this seventh video of the Xpdf series, we discuss and demonstrate the PDFfonts utility, which lists all the fonts used in a PDF file. It does this via a command line interface, making it suitable for use in programs, scripts, batch files — any pl…
This tutorial demonstrates a quick way of adding group price to multiple Magento products.

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now