Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 634
  • Last Modified:

Confusion with using /etc/auto.home

hello. Im reading a book on using auto.master and auto.home to set up user directories. It makes sense - but this book says that it will not work if there is already a home directory on the server (the one where the user is logged in - not the one where the home directory actually is).
But I cannot see how to delete the home directory- do I need to do this for auto fs to work ?
Astin
0
astincrawford
Asked:
astincrawford
  • 3
  • 3
1 Solution
 
savoneCommented:
I am not sure I understand your question... Why would you want to delete a home directory?

autofs is usually used to mount a second filesystem, instead of usiong /etc/fstab.

For example a CDROM, A USB drive, share on another server, or even a second hard drive.

You might want to change the users home directory for deleting it:

usermod -d /new/home/dir

then you should be able to safely delete the old one.
0
 
astincrawfordAuthor Commented:
thanks for the reply. this is just to configure a users home directory, which is currently located on a windows server.
I've set up the /etc/auto.master to point to /etc/auto.home and set up the auto.home file - but it doesn't seem to mount - no errors are given, but I'd expect to see some files in the (remote) home directory and there's nothing there.
0
 
astincrawfordAuthor Commented:
is there a place where I can see messages telling me if the client linux box cannot attach to the server with the home directory - /var/log/messages does not show anything ?
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 
savoneCommented:
Can you post the contents of your auto.master and auto.home files?

0
 
savoneCommented:
/etc/auto.master should have something like this:

/home /etc/auto.home


and /etc/auto.home should have something like this:
home -fstype=cifs,credentials=/etc/samba/user1,uid=99,gid=99,rw ://servername/sharename

then make a file called /etc/samba/user1 (replace user1 with whatever you want just make sure its the same as the link in /etc/auto.home). Inside that file should be the following:
username=windows_username
password=windows_password

The make sure nobody but root can see that file:
chmod 600 /etc/samba/user1
0
 
astincrawfordAuthor Commented:
thanks. thats ideal.
0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now