• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 895
  • Last Modified:

Toshiba Equium A300 13X powering on, but nothing happening!

Hi Guys,

I have a really annoying problem with this Toshiba.

It was dropped in recently to our repair shop as not booting.

The machine was not turning on at all, after detailed diagnosis, the motherboard appeared to be faulty.

I replaced it with a second hand one and the power light comes on when I press the power button, and the fan spins for about 10 secs, but nothing on screen or any sign of activity.. then I purchased a brand new one from toshiba directly and the same!

I have reseated EVERYTHING, replaced ram, replaced RTC battery connected external monitor, cpu, e.t.c, tested power from charger to motherboard (all ok).. STILL NOTHING!

Any ideas guys? im totally out of them and at my wits end!

 - Thanks

Aaron Whooley
0
evandoc
Asked:
evandoc
  • 3
  • 2
1 Solution
 
asiduCommented:
You have changed the mother board and still having the same issue.
Suggest remove all the extra peripherals and do the basic checks.
Remove the ram also and see if you hear the beeps. it will confirm
the CPU is working.

Have you tried changing the power supply?
A faulty power supply, could supply the voltage but not enough current
when the load is applied.
0
 
evandocAuthor Commented:
Hi Asidu, thanks for the reply..

I have tried what you suggested and unfortunately, still no luck...

I removed the ram, no beeping, removed the cpu, still no beeping.. I have already tried two different processors and many different ram chips..

I have used 3 different toshiba power supplies and no luck..

Any more ideas?
0
 
asiduCommented:
Since you have changed the mother board and there is no beeping on power up. Looks like the problem is with the CPU. Do you have another CPU to test the system?

You can read the detailed steps on how to trouble shoot from the service manual. http://tim.id.au/laptops/toshiba/equium%20a300%20satego%20a300%20satellite%20a300%20pro%20a300.pdf 

Read chapter 2 in particular section 2.3

0
On-Demand: Securing Your Wi-Fi for Summer Travel

Traveling this summer?Check out our on-demand webinar to learn about the importance of Wi-Fi security and 3 easy measures you can start taking immediately to protect your private data while using public Wi-Fi. Follow us today to learn more!

 
viki2000Commented:
Do you hear the POST (BEEPS during the boot time) ?
In case not read this
http://www.experts-exchange.com/Hardware/Components/Motherboards/A_1945-Short-overview-of-how-to-troubleshoot-bad-hardware-when-a-pc-does-not-post.html 
In case yes, describe them.
0
 
evandocAuthor Commented:
Hi all - turns out that the the processor was faulty. Replaced it and all is good now!
0
 
asiduCommented:
Thanks for the feedback.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now