Expiring Today—Celebrate National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Cisco 1921 point-to-point communication issues

Posted on 2010-11-17
9
Medium Priority
?
1,397 Views
Last Modified: 2012-05-10
I have set up two Cisco 1921 routers. One is setup at our main branch and the second one is set up at sister branch a few buildings down the road. Lets call main branch Router 1 and sister branch Router 2.

I can communicate and ping computers at the sister branch from the main branch, but I cannot communicate and ping computers at the main branch from the sister branch.

When I set up the routers the first time. I set them up side by side. I could ping router to router. I hooked up a laptop to each router and could ping each computer as well.

Is there anything I am missing? What could be causing this?

Other config is pretty much the same except service-module is set to Line.

Here is the config:

Using 1448 out of 262136 bytes
!
! Last configuration change at 19:23:45 UTC Mon Nov 15 2010
!
version 15.0
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname ************
!
boot-start-marker
boot-end-marker
!
enable secret *********************
enable password ***************
!
no aaa new-model
!
!
!
!
no ipv6 cef
ip source-route
ip cef
!
!
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
license udi pid CISCO1921/K9 sn *********!
!
!
redundancy
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
 ip address 192.168.6.251 255.255.255.0
 duplex auto
 speed auto
 no mop enabled
 !
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
interface Serial0/0/0
 ip address 192.168.101.253 255.255.255.0
 no fair-queue
 no clock rate 2000000
 service-module t1 clock source internal
 service-module t1 timeslots 1-24
 service-module t1 remote-alarm-enable
 !
!
router rip
 version 2
 network 192.168.6.0
 network 192.168.7.0
 network 192.168.100.0
 network 192.168.101.0
 no auto-summary
!
ip default-gateway 192.168.6.250
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 192.168.6.2
ip route 0.0.0.0 0.0.0.0 192.168.6.250
!
!
!
!
!
!
snmp-server community public RO
snmp-server enable traps tty
!
control-plane
 !
!
!
line con 0
line aux 0
line vty 0 4
 password *********
 login
!
scheduler allocate 20000 1000
end

0
Comment
Question by:MightyMikey
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
9 Comments
 
LVL 18

Expert Comment

by:jmeggers
ID: 34157524
What subnet is on the LAN side at the other?  Is that the 192.168.7.0?  If so, there's no reason to list it in the RIP configuration on this router, you generally only list subnets you are actually advertising from a given router.  

Are you receiving RIP updates from the other side? You can do a debug RIP and find out. You're also not advertising a default route over the serial link, are you using a static default at the other end?  I take it there are no ACLs in the way on the other side.
0
 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 34158154
Hi,

why did you configured two default routes?

ip route 0.0.0.0 0.0.0.0 192.168.6.2
ip route 0.0.0.0 0.0.0.0 192.168.6.250

you need the following
router rip
 redist static
0
 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 34158157
what shows the following on booth sides?

sh ip int brief
sh ip route
0
Introducing the WatchGuard 420 Access Point

WatchGuard's newest access point includes an 802.11ac Wave 2 chipset, providing the fastest speeds for VoIP, video and music streaming, and large data file transfers. Additionally, enjoy the benefits of strong security as the 3rd radio delivers dedicated WIPS protection!

 

Author Comment

by:MightyMikey
ID: 34159208
@ikalmar (second repsonse)

Router 1 at main branch:
sh ip int brief shows:

Interface                  IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0         192.168.6.251   YES NVRAM  up                    up

GigabitEthernet0/1         unassigned      YES NVRAM  administratively down down

Serial0/0/0                192.168.101.253 YES NVRAM  up                    up

sh ip route shows:

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is 192.168.6.2 to network 0.0.0.0

S*    0.0.0.0/0 [1/0] via 192.168.6.2
      192.168.6.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.6.0/24 is directly connected, GigabitEthernet0/0
L        192.168.6.251/32 is directly connected, GigabitEthernet0/0
      192.168.101.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.101.0/24 is directly connected, Serial0/0/0
L        192.168.101.253/32 is directly connected, Serial0/0/0

Router 2 at sister branch:
sh ip int brief:
Interface                  IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0         192.168.7.250   YES NVRAM  up                    up

GigabitEthernet0/1         unassigned      YES NVRAM  administratively down down

Serial0/0/0                192.168.101.254 YES NVRAM  up                    up

sh ip route:
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is 192.168.101.253 to network 0.0.0.0

S*    0.0.0.0/0 [1/0] via 192.168.101.253
      192.168.7.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.7.0/24 is directly connected, GigabitEthernet0/0
L        192.168.7.250/32 is directly connected, GigabitEthernet0/0
      192.168.101.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.101.0/24 is directly connected, Serial0/0/0
L        192.168.101.254/32 is directly connected, Serial0/0/0
0
 

Author Comment

by:MightyMikey
ID: 34159791
I have gone over the config serveral times. Comparing it to the old cisco routers we have currently using until the issue is resolved. An intern thinks it has to do with the IP address being variably subnetted, with 2 subnets and 2 maks. The config on the old routers only say directly connected like some of the IP's in the information I have posted. He knows it has to do something with the routing config if each router can ping/communicate with each other but a machine on one router end cannot ping a machine on the other router end. Any suggestions are greatly appreciated.

To answer ikalmar'sfirst reply, we had set the two default routes as it was the same set up on the previous routers and they are working just fine. We have not attempted redist static yet.
0
 
LVL 34

Accepted Solution

by:
Istvan Kalmar earned 2000 total points
ID: 34159872
in this case you need route to 192.168.7.0/24 on SITE a

ip route 192.168.7.0 255.255.255.0 192.168.101.254
0
 

Author Comment

by:MightyMikey
ID: 34948315
There was another hop that is owned and managed by AT&T (gateway router).  We had to contact AT&T MIS support to have them add a route to the extended network.
0
 
LVL 71

Expert Comment

by:Qlemo
ID: 34986569
This question has been classified as abandoned and is being closed as part of the Cleanup Program. See my comment at the end of the question for more details.
0

Featured Post

Portable, direct connect server access

The ATEN CV211 connects a laptop directly to any server allowing you instant access to perform data maintenance and local operations, for quick troubleshooting, updating, service and repair.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
This article will show how Aten was able to supply easy management and control for Artear's video walls and wide range display configurations of their newsroom.
There's a multitude of different network monitoring solutions out there, and you're probably wondering what makes NetCrunch so special. It's completely agentless, but does let you create an agent, if you desire. It offers powerful scalability …
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …

718 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question