How to Enable Pasting of Filenames In IE 8

Hi,

Since upgrading to IE 8.0 under XP SP3, I can no longer paste filenames into fields for uploading files to web sites.  I am forced to click the browse button provided.  I pick my file, chose Open and it puts the file name into the filename box.  The filename box is grey.  It used to be I could paste the name of the file into the field.

I suspect this is a default setting on IE 8 that can be chaged.  Please let me know how to change this.
akivashapiroAsked:
Who is Participating?
 
johnb6767Commented:
Internet Explorer 8 Beefed Up Against Hackers And Phishers
http://www.tomsguide.com/us/internet-explorer-microsoft-security-hackers,news-1858.html

Guess I learned something new today as well....   :-)
0
 
johnb6767Commented:
Can you post an example of a public website? That should still work by default.....

The only two settings I can thikn of (which I wouldnt modify in any zone BUT the Trusted Sites), is.....

"Include local directory path when uploading files to a server"
"Allow Programmatic access to Clipboard"

I dont think they shoyuld control that, but worth a loookseee....
0
 
BCipolloneCommented:
"Tools>Internet Options - Security tab. Press the 'Default' button on each
security zone and accept the default security settings that the IE Team
recommends.

There are security settings to "Allow programmatic access to the clipboard"
and also "Include local directory path when uploading files to a server",
which you may have accidentally changed. (Accept the default security
settings)

Some sites may also restrict what can be pasted into an input field. (Too
long, invalid characters).

"

Quote from another site
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

 
akivashapiroAuthor Commented:
Sorry, gentlemen, the suggestions above have not worked.  Please see a screen shot of the file upload area.  This is a pw protected site, so you won't have access, but I get substantially the same thing on other site.s
Screen-Shot.bmp
0
 
akivashapiroAuthor Commented:
If you give me the url of a public web site for file upload, I'll post what it looks like in my browser.
0
 
johnb6767Commented:
I noticed the File Upload box on Virustotal.com, and noticed I couldnt do it either.....

Did find what looks to be an incomplete thread from a MS forum......

Cannot paste file path into Browse input box in IE8
http://social.answers.microsoft.com/Forums/en-US/InternetExplorer/thread/85f63579-5be9-47fb-9ebb-b9b2d9dd1123

Various others with unfinished discussions..... Google "Cannot paste file path into Browse input box in IE8"

From "http://blogs.msdn.com/b/ie/archive/2008/09/23/application-compatibility-logging-in-ie8.aspx?PageIndex=2"

Post starting "2 Oct 2008 10:09 AM "

"@Rado: Simply click BROWSE and then paste in the full file system path into the dialog.  This is the same in all latest-version browsers except Opera.

The hosting application cannot file the file upload control using the DOM when using the DOM APIs, because these are the same APIs used by javascript.
0
 
akivashapiroAuthor Commented:
Unfortunatley, there does not appear to be the solution I would like for this issue.  Thanks for the efforts.
0
 
johnb6767Commented:
Wish we could have been more help......
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.