• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1515
  • Last Modified:

IE8 not opening excel 2010

Currently Running windows 7 64-bit professional on our client workstations.  We currently have office 2010 on the machines as well.  Our current web browser is IE8
We have a problem.  When we try to download excel sheets from a hyperlink it will prompt us to either save it or open it.  We can save the excel file just fine but when we attempt to open it will open another IE8 window and that window remains blank after loading it.

I checked the file associations for XLS, XLSX, csv, and etc.  All of them point to the latest version of excel which is located \program files\microsoft office\office14\excel.
Also,  It doesnt matter what version of IE either.  I can use IE8 or IE9 and it still does the same thing(opening excel in a blank IE window).
Firefox was the one of the browsers that actually opens the excel file in  excel application.  Firefox seems to do it just fine but not IE8.
We didnt have this problem when running office 2007 in IE8.  it seems to be just office 2010 with any version of IE.

I tried the microsoft fix it methods that they recommend but that did not work.  Microsoft also mentioned checking the registry settings for the xls and xlsx files for subkeys of office.sheet.5, office.sheet.12 and etc.  My registry matches exactly what they recommend.
Another, I tried this by resetting IE back to defaults, clearing our personal settings, resetting security and running with all add-ons disabled.  Nothing is working.  Does anyone know of a solution??????
0
thefirstknight23
Asked:
thefirstknight23
  • 10
  • 6
  • 3
  • +1
1 Solution
 
AndyMcKCommented:
Try holding down the CTRL button when clicking on the 'open file' link.  Does that make a difference?
0
 
thefirstknight23Author Commented:
Thanks for your reply.

I tried what you suggested and it still does not open the excel file
just to let you know the steps

1. open IE8
2. browse to site with excel file hyper link
3. click on the hyper link
3. a new window opens with download prompt asking me if I want to open it or save it.
4. I click on open and it tries to open it in an IE window instead of opening it via excel app.

0
 
thefirstknight23Author Commented:
just to let you know, it tries to open it in an IE window but that window is blank.
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
AndyMcKCommented:
Don't let go of CTRL.  Keep it held down until the new window has fully opened up.
0
 
thefirstknight23Author Commented:
right,
I held down CTRL and it opened in another window.  while CTRL was pressed down, the open and save dialog box appeared.  While CTRL was pressed I clicked on open.  Still same results that I got without holding CTRL down.  

0
 
NorieVBA ExpertCommented:
Have you tried the 64-bit version of IE?
0
 
thefirstknight23Author Commented:
Yes, Both 32 bit version of IE and 64 bit version of IE does the same thing.
Sorry I did not mention that!!
Can anyone tell me how I might be able to contact microsoft to see if they have a possible fix or know about this issue?
If not then I am all ears for any other suggestions on this matter.  Thanks for all of your support!!!!
0
 
NorieVBA ExpertCommented:
This might be a stupid question but, do you actually want to open Excel files in IE8?

I've had similar problems but for different reasons, some of which were partly my own fault.

Not sure of a direct contact for Microsoft but I'm sure if other people are having the same problem it'll be posted on some forum/newsgroup somewhere.

That's the problem 'somewhere', you try a search but finding specific help can be a bit of a trial.

Have you checked the security settings?
0
 
AndyMcKCommented:
This does sounds like a security setting.

Add the url of the site to your trusted sites category (if you trust it :) ).  Go into the 'Custom Level' settings for trusted sites and find the Downloads section.  There should be an option there for "Automatic prompting for file downloads".  Enable this and see if it makes a difference.
0
 
thefirstknight23Author Commented:
@Imorie:No, I actually want it to open the excel app with the excel data instead of it opening it in an IE window .Microsoft recommends it to be that way.   Microsoft fixed the issue of it opening in IE.  They corrected the issue by editing the registry which corrects the way IE calls on the excel app.  When they show the registry keys for it,  All my registry settings match what they recommend.
See Microsoft documentation
http://support.microsoft.com/kb/162059

@andyMck:
The URL is our company website that is already added to our trusted list in IE.  This is for all clients on our network.  We made sure of this by adding trusted sites via GPO to IE.  I confirmed the IE security settings and made sure that our website is in the trusted list.  I went a step further and added the exact URL where for our excel sheets to the trusted zone.  That did not make a difference.
You mention "automatic prompting for file download" to be enabled.  I already tried this.  Infact I had it disabled for all zones(internet, local intranet, trusted sites, and restricted) and that did not work.  So I enabled it for all zones and that too did not work either.

This to me seems like a very new issue and the reason we see that it is not common is because
not everyone is running windows 7 64bit with IE8 and office 2010.  lol

imnorie and Andymck, Thank you for your suggestions!  I can assure you that this will be a problem for all of us in the future once the software becomes a little more common.  Do you think any of you can replicate what I am experiencing?
0
 
AndyMcKCommented:
I run Win7 64bit at work, I'll try and replicate.

What's the url format?  Are you just pointing to an xls file?  ie. http://mycompany.com/myfile.xls?
0
 
thefirstknight23Author Commented:
Andymck:
The url format is exactly what you mentioned.  
Cool, thanks for attempt to replicate.

Are you running office 2010 too and IE8?  If so then you will have matched exactly what I am running.
If not, It will still be interesting to see if any other version of office opens it correctly with IE8 and IE9.  Then we can narrow it down to see if it is just office 2010.  Thanks Andy!!!!!
0
 
NorieVBA ExpertCommented:
I've been using IE8 on Windows 7 since it came out, actually since the beta, and never had any problems like this.

The only major problem I had was when I tried the 64-bit version, and that was only that it didn't support Flash - so it's wasn't that major anyway.

I'm also running Excel 2010 (32-bit) though it's only recently (3 months) I actualy got the full version.

I didn't even try the 64-bit version of Excel because I wouldn't be able to use any of the 32-bit versions of Excel.

In fact I've only got 1 thing that's 64 bit and, I think anyway, that's something to do with a printer I don't use anymore.
0
 
MontoyaProcess Improvement MgrCommented:
I have a suggestion here, which you may have tired. We had a similar issue and this seemed to fix it. Run Microsoft Office Repair.  Sometimes the order in which these are installed and implemented creates problems and, for us, were most obvious in Excel.

Hope this gets you closer.
0
 
thefirstknight23Author Commented:
Iammontoya,
I have NOT tried that yet.  I will give that a try and see what it does.  
thanks!
0
 
thefirstknight23Author Commented:
I tried that repair option and that did not work either.
andymck, where you able to duplicate what I am experiencing??
0
 
AndyMcKCommented:
Sorry for delay, been a bit busy :)

I haven't been able to reproduce this one but I haven't been able to completely recreate your scenario either.

I'm running Office 2010 on Win7 64bit but I'm using IE9.  I'm also hosting the page on my local iis install and referencing a local file which may all be making a difference.  Regardless, clicking on a link to an xls or xlsx file brings up an "Open/Save" dialog box.  Clicking Open, opens the file in Excel.

It still sounds like a configuration issue to me.  Is the file hosted on the same domain as the page that's linking to it?  It almost sounds like you're clicking on a link from a webpage in one IE zone to a web page in a different IE zone.  That would force a launch of a second instance of IE.
0
 
thefirstknight23Author Commented:
I found the solution
Office 2010 will not open office apps under a non-ssl connection.
You have to edit the registry for it to allow it to open on a non-ssl connection.
here is the article.
http://support.microsoft.com/kb/2123563

0
 
AndyMcKCommented:
Weird, never heard of that one before.

Glad you found a solution.
0
 
thefirstknight23Author Commented:
This fixed the issue
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 10
  • 6
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now