Solved

Cannot pull dhcp ip switchport problem?

Posted on 2010-11-17
13
472 Views
Last Modified: 2012-05-10
I have a 2960 connected with 1gb copper to our 4507 core. Recently, we've noticed we cannot pull ip addresses from some of the switch ports, via DHCP. Specifically ports 1-3

What would be the cause of this?  There are 161 total mac addresses in the cam table. Several of them are learned via the uplink to the core. I have over 8000 mac entires free, so I don't think my CAM table is full

We have an IP phone which can plug into the mentioned switchports, and pull an IP via DHCP no problem. PCs cannot pull an IP if plugged directly into the switchports. However, if plugged into the back of the avaya phone, they can pull an ip

These switchports were also trunk links, with a default vlan in the data network. I changed some to a regular access port, and the pcs still could not pull an IP
0
Comment
Question by:orus
  • 7
  • 6
13 Comments
 
LVL 1

Expert Comment

by:clawrimore
ID: 34159472
Ports 1-3 need to be assigned to a specific VLAN, one which either has a DHCP server on it or for which BOOTP helpers have been created.  Even though they are no longer trunk ports, you need to either assign them to a VLAN or they will default to Native VLAN (VLAN1).
0
 

Author Comment

by:orus
ID: 34159493
yes they are part of vlan 14 (data)
0
 
LVL 1

Expert Comment

by:clawrimore
ID: 34159505
Is the rest of the switch on VLAN14?  Are you able to post an Interface config?
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 1

Expert Comment

by:clawrimore
ID: 34159520
Is Spanning-Tree enabled?  When you plug a device into the port, how long before the LED turns green?
0
 

Author Comment

by:orus
ID: 34159531
here are ports 1-3. I'm having the issue on other ports as well. Ip-phone works, but pcs cant pull anything plugged directly in
interface GigabitEthernet1/0/1
 switchport access vlan 14
 srr-queue bandwidth share 10 10 60 20
 queue-set 2
 priority-queue out
 mls qos trust dscp
 auto qos voip trust
!
interface GigabitEthernet1/0/2
 switchport trunk native vlan 10
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 queue-set 2
 priority-queue out
 mls qos trust dscp
 auto qos voip trust
!
interface GigabitEthernet1/0/3
 description ***IT WAP***
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 queue-set 2
 priority-queue out
 mls qos trust dscp
 auto qos voip trust
!

Open in new window

0
 

Author Comment

by:orus
ID: 34159540
yep, STP is enabled. Also, other ports are fully functional. It is strange indeed
0
 
LVL 1

Accepted Solution

by:
clawrimore earned 500 total points
ID: 34159616
OK.  Where is the DHCP server in relation to switchport 1?  Is it on the same switch? Different VLAN?  Is there still a trunk port to carry VLAN14 to the router?  If there is still a trunkport, is it #3?  Is #3 plugged in to an accesspoint?
0
 

Author Comment

by:orus
ID: 34159680
DHCP server is on a different switch, going through gig1/0/48.  It is on a different VLAN, VLAN 1. yes there is a trunk port to carry VLAN14

#3 is an AP and it is working yes
0
 
LVL 1

Expert Comment

by:clawrimore
ID: 34159802
DHCP on VLAN 1.
Client on VLAN14.
They can PING each other if they use static IP addresses.
Is there anything else on VLAN14?
It really sounds like BOOTP helper is not configured for VLAN14.  Because DHCP requests are broadcast, it needs the router to forward DHCP requests from VLAN14 to VLAN1.
On the router, interface VLAN14, do you have a command that is similar to "ip helper-address <dhcp>"?  You need one...
0
 

Author Comment

by:orus
ID: 34159818
we have had it on there a while actually. This is from the core switch. Do we need the ip helper command on the access switch as well

interface Vlan14
 description ***IT Personnel VLAN***
 ip address 172.16.14.1 255.255.255.0
 ip helper-address 172.16.1.14
0
 
LVL 1

Expert Comment

by:clawrimore
ID: 34159878
This command looks good and should be issued on the router only.  And of course, the DHCP server has 172.16.1.1 as it's default gateway?  And the client and DHCP server can PING if using static?
0
 

Author Comment

by:orus
ID: 34159886
i will try static and report back
0
 
LVL 1

Expert Comment

by:clawrimore
ID: 34169273
Were you able to test ping to ensure connectivity between VLANs?
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Netgear switch to Cisco switch VLAN not passing traffic 8 54
fabric 1 31
Which Switch is Switch - improving performance 9 71
HP Procurve and AAA authentication 2 33
The worst thing when starting a new job is when the previous Network Administrator left behind no documentation. How do you get into the devices? If you've been in this situation or just accidently mistyped your password, this article will hopefully…
This tutorial will go through the steps required to write a script that will back up the configuration settings of a HP-ProCurve switch. You will need to get the following things to follow this tutorial: Telnet Scripting Tool e.g. TST10.exe …
With Secure Portal Encryption, the recipient is sent a link to their email address directing them to the email laundry delivery page. From there, the recipient will be required to enter a user name and password to enter the page. Once the recipient …
In a recent question (https://www.experts-exchange.com/questions/29004105/Run-AutoHotkey-script-directly-from-Notepad.html) here at Experts Exchange, a member asked how to run an AutoHotkey script (.AHK) directly from Notepad++ (aka NPP). This video…

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question