[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 866
  • Last Modified:

DNS Error - Cannot joing a Windows 7 workstation to a SBS2003 Server

When trying to add a Win 7 professional workstation to the domain controller I receive the following error message:

An attempt to resolve the DNS name of a domain controller in the domain has failed.  Please verify that this client is configured to reach a DNS server that can resolve DNS name in the target domain.

When I do an nslookup I get the following message.  richtwpserver.richlandtwp can't find ... server failed.  

The event log states it cannot find the SOA record.  I  deleted the old SOA record and created a new one.  When creating the new one the .local was left off.

I have reviewed tech docs until I can't read any more.  Nothing seems to work.  I  tried to run diag.exe /fix.  It must not be installed on the server.  Can I download it.

DHCP is running on the router.  It seemed that DHCP and DNS work with each other so I was going to change it to the server and I recieved an error message.  

None of the system are appearing in the forward zone record.  System have been running slow and losing the connection to the SQL server.  I am starting to believe that it is all stemming from this problem.

Thank you for your help.
Bonne001
0
Bonne001
Asked:
Bonne001
1 Solution
 
frostsystemsCommented:
1) If more than one NIC exists on the Win7 machine, disable all other NICs except for 1 LAN adapter.

2) Assign a static DNS address on this NIC. The DNS server should be that of your SBS2003's IP.

3) Retry to join the domain.
0
 
blaslettCommented:
Assign the client PC a valid IP address for the network domain. ie if your network is 192.168.1.0-255.255.255.0 then select and unused IP in the 192.168.1.1-192.168.1.254 range.

Set the DNS IP to that of the SBS2003 server.

Gateway IP can also be that of the server.

IMO, DHCP server function should always reside on the DC, once you have this issue resolved I would transfer the DHCP role from the router to the server.
0
 
Bonne001Author Commented:
Add the IP# 192.168.1.29 DC 192.168.1.5 Gatway 192.168.1.1

Still does not work.  We have done this on XP systems and they work.
0
Will You Be GDPR Compliant by 5/28/2018?

GDPR? That's a regulation for the European Union. But, if you collect data from customers or employees within the EU, then you need to know about GDPR and make sure your organization is compliant by May 2018. Check out our preparation checklist to make sure you're on track today!

 
JBond2010Commented:
Flush the DNS cache on the Windows 7 PC. Go to the command prompt and type ipconfig /flushdns and press enter and then type ipconfig /registerdns and press enter.

Check the ip settings on the PC and make sure that the ip schema is a valid ip schema and that the PC's DNS address is pointing to your SBS2003 Server. Try to rejoin the PC to the domain.

Check in DNS to see if there is any stale records.
0
 
Rob WilliamsCommented:
DNS is your primary issue, and in an SBS domain you should have DHCP running on the server not the router. But when adding Win7 machines you should review all the necessary steps:
Deploying Win 7 in your SBS 2003 network:
http://cid-c756c44362cd94ad.skydrive.live.com/self.aspx/Windows7Stuff/HOW%20TO%20DEPLOY%20WINDOWS%207%20IN%20YOUR%20SBS%202003%20NETWORK.docx
0
 
Bonne001Author Commented:
Thank you JBond2010 I had tried flusing the DNS and registering it before but thought it never hurts to try again.  Didn't work.  

This is what I get when I do an IPconfig after flushing and registering the DNS
I have attached the screen shot.


The funny thing is the DC is picking the system up under computers.

I will read RobWill article and get back to you.
C:\Users\marge>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : marge-PC
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Broadcom NetLink (TM) Gigabit Ethernet
   Physical Address. . . . . . . . . : F0-4D-A2-2F-09-46
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 192.168.1.29(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.1
   DNS Servers . . . . . . . . . . . : 192.168.1.5
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{352C646A-96BA-4415-9588-440524FF5048}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 11:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft 6to4 Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Teredo Tunneling Pseudo-Interface:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e76:2058:124d:3f57:fee2(Pref
erred)
   Link-local IPv6 Address . . . . . : fe80::2058:124d:3f57:fee2%15(Preferred)
   Default Gateway . . . . . . . . . : ::
   NetBIOS over Tcpip. . . . . . . . : Disabled

C:\Users\marge>

Open in new window

0
 
Rob WilliamsCommented:
If not using the SBS as the DHCP server you should also add your DNS suffix to the advanced TCP/IP properties under DNS / "use this DNS suffix for this connection"
0
 
Bonne001Author Commented:
Thank you all for your help.  I had to call Microsoft to get this resolved quickly.  The problem was a corrupt DNS.  The xxx.local was actually resolving to an outside IPAddress?  It baffeled the MS Agent also.  I didn't uncover that yesterday when I did a nslookup it said it could not find the server; the same with ping!

Thank you again for your quick reply.

0
 
Rob WilliamsCommented:
Glad to hear to were able to 'resolve'.
Thanks for updating.
Did they explain how it might have wound up resolving to an external IP? Would be good information to have.
0
 
Bonne001Author Commented:
I'll ask during my follow-up with them and post it.  Good question!
0
 
Bonne001Author Commented:
Called Microsoft and had them help me rebuild the
DNS.
0

Featured Post

SMB Security Just Got a Layer Stronger

WatchGuard acquires Percipient Networks to extend protection to the DNS layer, further increasing the value of Total Security Suite.  Learn more about what this means for you and how you can improve your security with WatchGuard today!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now