Solved

error when using ping - destination unreachabe or host is unknown

Posted on 2010-11-17
5
562 Views
Last Modified: 2012-05-10
Hello guys and thanks as always for your time and expertise.
Here's my scenario which caused me to ask this question,  I was trying to install an application from a shared folder on a server.  I had three win7 clients and one winxp client (although please not this problem occurs on winxp systems as well.)  On the winxp client, I could connect to the server and everything went fine.
On the win7 clients, I couldn't access the server.  Please note I was able to ping all the other servers in this site except the one I needed.  The server is question is serer 2003 sp2.  I checked all of the relevant network settings and they were all good.  I ran the troubleshooter on win7 and it said everything was confirmed right.  However, when I tried to ping the server from the win7 clients, and sometimes from some of my xp clients, I get the destination unreachable or host is unknown error.
ok, so after being very frustrated, I pinged these clients from the server and then bang - problem fixed.  I just want to understand what happened here. Again,  the problem was fixed after I pinged the clients from the app server.
Did this ping from the server add the correct mapping to the arp table which fixed my problem.  I just want to know why the ping from the server fixed this issue.  
Anyway, thank you for your time and input.
0
Comment
Question by:pendal1
5 Comments
 
LVL 10

Accepted Solution

by:
akhalighi earned 167 total points
ID: 34161298
I'd say windows firewall my friend..., check that on your client machines. turn it off temporarily and see if ping works two ways..
0
 
LVL 25

Assisted Solution

by:Cyclops3590
Cyclops3590 earned 167 total points
ID: 34164073
it could be a firewall, but i'm don't think so.  i think its more likely a bug in the L3 device closest to your server or a problem with your server.  if you ping from the client to the server, ARP entries should be created along the entire L2 path.  Since you are getting a destination unreachable, this means it got to the last hop router and the next hop would be the server however when the router tried to find the MAC address of that server it got no reply so it thought the client with that IP didn't exist.  While it could be a firewall to prevent this I find it very hard to believe because this ARP request runs under much of the levels where firewalls filter at.  So its either the router got a reply and messed up the recording or the server is messed up and not responding back to requests (I'm thinking the latter).  

When you pinged from the server, all the L2 path ARPs took place properly.  As for your server, since its the one doing the request, the router will populate its ARP table because of the request information its seeing from the server's IP (the IP is in the packet, not the headers).  Thus a return L2 path could be completed for the client to start pinging.

If I'm right, then to test this either clear the ARP table on the router gateway the server uses or let the ARP entry associated with the server expire and be removed.  After this entry is confirmed out of the table retry your client to server ping.  It should fail.  If it succeeds then what I'm saying can't be right.

This is all I can think of though.
0
 

Author Comment

by:pendal1
ID: 34191320
It's not the firewall.  Thought of that and can confirm that's not it.
Cyclops3590 - just so you know the layout of this particular scenario.  The client in question and the server are in the same broadcast domain or same subnet.  With that being the case, doesn't that take the router out of the loop for this issue since I'm not actually trying to communicate with a resource on another subnet.  In other words there's no routing involved.  In this case, the server and the client should be in the same switch, or at the most the two nodes are in two different switches but same subnet.  With that being the case, would the arp table of the switch have been hosed until I pinged from the server to repair the arp table.  Please let me know what you think now. Sorry for the delay in posting.  Your help and input is greatly appreciated.
0
 
LVL 3

Assisted Solution

by:ivailoj
ivailoj earned 166 total points
ID: 34224464
After all that i see, you have duplicated IP ( or Netbios name do you ping by Ip or by name ) on this Server machine. ( problem is: windows detect this and usually pop-up message if this happens, but some times not )

Please paste here:
ipconfig /all - from all machines
and
arp -a - befor ping, and after ping.
and
route print - from one of win7
0
 

Author Closing Comment

by:pendal1
ID: 34278367
Guys thanks for your time and input.  Sorry for my delay in responding.  I have been under the weather to say the least.  I think I figured out what happened.  On the server in question - the nics were teamed but only one of the nics was plugged into the network.  I connected that nic to the switch and haven't had the problem since.  Perhaps the arp mappings were based on this nic's mac address.  In any case, the problem is resolved and I thank you for your valuable time and recommendations.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Network ports are the threads that hold network communication together. They are an essential part of networking that can be easily ignore or misunderstood, my goals is to show those who don't have a strong network foundation how network ports opera…
As companies replace their old PBX phone systems with Unified IP Communications, many are finding out that legacy applications such as fax do not work well with VoIP. Fortunately, Cloud Faxing provides a cost-effective alternative that works over an…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now