?
Solved

Windows 7 Machines Cannot Connect to Windows 2003 Shares

Posted on 2010-11-17
12
Medium Priority
?
828 Views
Last Modified: 2012-05-10
As of a couple of months ago none of my Windows 7 Machines can browse network shares on our 2003 servers.

I have network connectivity (internet is fine, I can ping the servers both by Name and IP, NSLookup is fine, etc.) AND I can browse the Win7 shares from 2003 and even XP....?  Strange.  Similarly, The XP machines have no problem with the 2003 shares

Having done the Win7 research in advance I made sure to set the appropriate NTLM Local Policys on the Win7 PCs and that worked like a charm.  Naturally, when the shares became ghosts, I checked that they were still set correctly in case an update reverted to the default and I had been caught off guard.  Yup, all good.

I can't believe this is so difficult to figure out.

My set up is:

Win2003 DCs and servers
Win2008 Core File server (not yet configured)
Win7 PCs
WinXP Pcs

AV is Symantec Endpoint Protection v11.0.5 and current (which I will uninstall once I get an install package created and copied over to a Win7 PCs for reinstall)

HELP!!
0
Comment
Question by:LateNiteR
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 4
12 Comments
 
LVL 17

Expert Comment

by:OriNetworks
ID: 34161721
Make sure time is accurate across the file server, clients and the DCs.
0
 
LVL 17

Expert Comment

by:Nik
ID: 34162584
Can you please tell what error you receive when you try to browse the shares?
We're working on the same configuration Windows 7/Windows Server 2003 native domain and never had any issues.
0
 
LVL 3

Author Comment

by:LateNiteR
ID: 34162922
Error:
"Windows cannot access \\ServerName
Check the spelling of the name. Otherwise, there might...."

Error Code: 0x80070035
The network path was not found

------------------------------------------------------------------
I have also confirmed that Time is synch'ed
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
LVL 17

Expert Comment

by:Nik
ID: 34163181
Have you followed these steps to check the possible issues:

Turn off any firewalls for debugging. If the firewall is the problem, you'll have to configure it to allow access to "trusted zone" addresses. Note that some firewalls must be completely uninstalled to stop them from affecting your networking.

PING each computer by IP address, and if successful, PING by name. You can obtain the IP address of a computer by opening a command prompt (DOS window) and typing IPCONFIG. This should work for any Windows version. A failure here needs to be corrected before you go any farther.

Check your Services are Started on all PCs: Workstation, DHCP Client, DNS Client, Server, TCP/IP Netbios helper, Computer Browser.

All computers should be in the same workgroup for computer browsing to function properly. File & Print Sharing has to be enabled on any computer you wish to share files or printers from. You also need to actually share the resource in question from My Computer, right click on the drive/printer/folder, and select sharing.

If you encounter difficulties accessing computers that are visible in Network Neighborhood, make sure the computer being accessed has an account with the same name/password as the system connecting to it uses to login.

While the default NetBIOS setting is correct for normal network configurations, it's possible for it to be altered, and it costs nothing to make sure it's correct. NETBIOS over TCP/IP must be enabled for normal network browsing.
0
 
LVL 17

Expert Comment

by:Nik
ID: 34163189
Also, I think that Symantec Endpoint protection could be the culprit. Can you try to remove it only temporarily?
0
 
LVL 3

Author Comment

by:LateNiteR
ID: 34164237
Windows Firewall IS disabled and as I said originally "...I can ping the servers both by Name and IP, NSLookup is fine, etc."

The NIC was set to the default and was getting its NetBIOS settings from DHCP.  I changed that to "enabled" which didn't change anything.

My network is a MS Domain and file sharing is enabled hence being able to browse shares between XP and 2003.  I can even browse Win7 shares from XP and 2003.

-----------------------------------------------------------

I will uninstall SEP to see if that is the culprit as soon as I can push-down a package to reinstall.
0
 
LVL 3

Author Comment

by:LateNiteR
ID: 34167606
I uninstalled SEP and nothing's changed.

I'm going to reinstall it and then uninstall all Windows updates since the July 2010.  It's after that things seemed to break down.
0
 
LVL 3

Accepted Solution

by:
LateNiteR earned 0 total points
ID: 34426908
I FOUND THE SOLUTION (Sorry Everyone!)

Searching and searching for an OS-Config or Patch issue lead me to ZERO but I began looking at other changes I'd made......and STILL came up short.  I'd given up.

I then began installing updates on my Son's PC (Win7 Pro)....at the other end of the house (see where this is going...?)  I happened to open windows explorer for some reason or  other when I noticed that HIS drive mappings to the NAS were still connected.  Naturally, I forgot about updating the OS (Something I'll be doing until NEXT Christmas) and looked at his settings.  All were identical to the other PCs.

THAT'S when it hit me.  I'd had bought a new Linksys/Cisco E1000 Wireless Router for one end of the house because it had GB LAN.  THAT was a change I hadn't anticipated to be a problem as WHO, in this day-and-age, would release a device that actually blocks Samba and other CIFS-like shares?!?!

To verify this, I took each PC into the other WiFi zone and each saw the NAS and the Win2003 shares perfectly.

I will award Nima the points as the largest contributor.
0
 
LVL 3

Author Comment

by:LateNiteR
ID: 34426912
....and yes, the E1000 does have the latest firmware installed and research indicates that Cisco does not yet have a solution to this behavior.
0
 
LVL 3

Author Comment

by:LateNiteR
ID: 34426921
Nima.  To keep this solution easy to find I have created a 2nd post to award your points.

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/Windows_7/Q_26701859.html
0
 
LVL 17

Expert Comment

by:Nik
ID: 34427021
Glad that you've solved it.
Thanks for the points and I wish you Happy Holidays!
0
 
LVL 3

Author Closing Comment

by:LateNiteR
ID: 34453316
The Linksys E1000 Blocks Samba and other shares.
0

Featured Post

[Webinar] Lessons on Recovering from Petya

Skyport is working hard to help customers recover from recent attacks, like the Petya worm. This work has brought to light some important lessons. New malware attacks like this can take down your entire environment. Learn from others mistakes on how to prevent Petya like worms.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A quick guide on how to use Group Policy to create a custom power plan and set it active on Windows 7.
IF you are either unfamiliar with rootkits, or want to know more about them, read on ....
In this video, we discuss why the need for additional vertical screen space has become more important in recent years, namely, due to the transition in the marketplace of 4x3 computer screens to 16x9 and 16x10 screens (so-called widescreen format). …
This Micro Tutorial will give you a basic overview of Windows Live Photo Gallery and show you various editing filters and touches to photos you can apply. This will be demonstrated using Windows Live Photo Gallery on Windows 7 operating system.
Suggested Courses

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question