?
Solved

Remote Desktop Web Access Server connection over internet

Posted on 2010-11-17
4
Medium Priority
?
1,052 Views
Last Modified: 2012-05-10
I am attempting to use Remote Desktop Web Access Server (RDweb) on an Windows 2008 R2 server to mimic the functionality of SBS's Remote Web workplace. My goal is to allow users to access remote desktops behind the corporate firewall without needing VPN.

I have installed the Remote Desktop Web Access role and have the webapp working. Users can connect to a remote desktop session when behind the corporate firewall. However from outside you are able to access the site but unable to make an RDP connection.  With SBS I remember needing to open port 4125. However I find no similar documentation for Remote Desktop  Web access server.

How can I enable connections via the internet?
0
Comment
Question by:Intuvo
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 15

Expert Comment

by:getzjd
ID: 34161856
What about port 443 and 3389?
0
 
LVL 9

Expert Comment

by:Trackhappy
ID: 34161868
Port 3389 probably. I'll try to find some evidence. Can you check your fiewall logs to see what is being blocked?
0
 
LVL 9

Accepted Solution

by:
Trackhappy earned 2000 total points
ID: 34161882
From :http://social.technet.microsoft.com/Forums/en/winserverTS/thread/3088d374-74d0-4c4c-9512-ebd317cf9288


Client PC Internet Explorer communicates with RDWeb via port 443 --> user clicks RemoteApp icon, which launches the RD Client and instructs it to connect to RDG via port 443 --> RDG server opens a connection to the RDSH via port 3389, acts as middle-man between client PC and RDSH server

To summarize key points, the RD Gateway server must be resolvable as well as reachable from the Internet via port 443, whereas the Remote Desktop Session Host server name must be resolvable/reachable via port 3389 from the RDG server.  Each role should have a ssl certificate that matches the name configured for it in RemoteApp Manager settings.

0
 

Author Comment

by:Intuvo
ID: 34192091
I was able to get this working. TrakcHappy was correct you only needs port 443 open. I installed the Remote Desktop Gateway service, and configured a proper ssl certificate. The only hard part to find was how to configure the RDWeb portal to use the remote desktop gateway. Those instructions are found here:

http://technet.microsoft.com/en-us/library/cc731465(WS.10).aspx

0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Scenario:  You do full backups to a internal hard drive in either product (SBS or Server 2008).  All goes well for a very long time.  One day, backups begin to fail with a message that the disk is full.  Your disk contains many, many more backups th…
Resolving an irritating Remote Desktop connection that stops your saved credentials from being used.
This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…
This tutorial will walk an individual through the steps necessary to install and configure the Windows Server Backup Utility. Directly connect an external storage device such as a USB drive, or CD\DVD burner: If the device is a USB drive, ensure i…

649 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question