Solved

Snapshoot Issue didnt consolidate after deleted Snapshoot via manager in VI and now System Running off Snapshot vmdk

Posted on 2010-11-17
11
429 Views
Last Modified: 2012-05-10
Hi

I have got an issue with a ESXi 3.5 Server

The Setup is:
IBM x225 2 x 2.8ghz CPU
Raid 5 SCSi U320 HDD
VMware Reporting 268.5GB Space - 1MB Free(the Problem)
VM = Windows 2003 SBS Server
2 x VD 1=60GB 1 =200GB (one of my first VM Servers i ever built so didnt leave enough space, made Windows Disk to Big)

Anyway, the other day i was just about to do some updates and thought i will make a Snapshot, of coarse there was not enough space to do so and got an error,but snapshot listed as done in the manager,  so i deleted snapshot in manager and though, all good,until they rang a few days later and said that server had stopped working, i had a look and run out of space

To get them working quickly reduced the memory from 3.5gb to 1GB i think and it started working again, unitl today when it stopped again, same error not enough space this time instead of having 3.5GB remaining it now has 1MB as i pressume the Snapshot VD that it seems to be still working off is still growing

What do i do from here

URGENT Help if anyone can advise

Thanks Adam


0
Comment
Question by:cdsaus
  • 4
  • 4
  • 2
  • +1
11 Comments
 
LVL 6

Expert Comment

by:ckivml
Comment Utility
Have you restarted your ESX Server and see.. try to do it so..
0
 
LVL 5

Expert Comment

by:dacasey
Comment Utility
Have you other snapshots your can remove to free up some space?
0
 

Author Comment

by:cdsaus
Comment Utility
Just restarted and now have 1.5GB free but still not enough can reduce the amount of ram from 1.5Gb to 1Gb and might start but just a temp fix, what is the full time fix

Thanks for your quick response

Adam
0
 

Author Comment

by:cdsaus
Comment Utility
no, it was first snapshot ever

somethings going wrong as its not listed in snapshot manager but still running of the snapshot vmdk

as per below:

[datastore2] MMSG-SBS1/MMSG-SBS1_1-000001.vmdk

rather then:

[datastore2] MMSG-SBS1/MMSG-SBS1.vmdk

i Pressume becuase there was not enough space to consolidate back into the Main File is this right

0
 
LVL 6

Expert Comment

by:ckivml
Comment Utility
as a permanent solution what i can see that.. either some how you have add a physical hard disk to it. or reduce your VD disk space.. i mean some how you have to get some free space to your esx.. any way i am checking for some alternate solution!..
0
Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

 

Author Comment

by:cdsaus
Comment Utility
yes absolutely,

I am happy to reduce the 200GB partition to 150Gb leaving Plenty, what would be the Process for that

Use something like Acronis Disk Director
0
 
LVL 6

Expert Comment

by:ckivml
Comment Utility
see below link it will help you.. to view the solution you have to register it.. it's free

http://searchvmware.techtarget.com/tip/0,289483,sid179_gci1322236_mem1,00.html?mboxConv=searchStorage_RegActivate_Submit&
0
 
LVL 28

Assisted Solution

by:bgoering
bgoering earned 250 total points
Comment Utility
As far as I can tell you have 2 options to get enough free space to recover from your situation:

1. Increase the size of your datastore either by:
   a. Adding another disk to your array and expanding the datastore to occupy the additional space
   b. Creating another array and adding that as an extent to your existing datastore

2. Creating another array and datastore and migrating some of the other vms off your existing datastore to free up space on your existing datastore. If you don't have vCenter Server and a storage vmotion license, you can use VMware Converter (http://www.vmware.com/products/converter) or Veeam FastSCP (http://www.veeam.com) to perform the migration

Once you have enough free space - you will need to get rid of your snapshot. If it is the only snapshot and the snapshot is large, you will need up to double the size of your base vmdk in free space in  order to consolidate your snapshot. Seeing as it does not appear in snapshot manager anymore, you will need to create a 2nd snapshot (so that something appears in snapshot manager) then do a delete all. This can take a very long time to complete for large snapshots.

OR - If it is not possible to get free space or another datastore as described above it is still possible to recover using VMware converter. You can use VMware converter to convert your VM to a VMware workstation type of VM and put it on a workstation - the conversion process will consolidate all of the snapshots into a single disk as well as allow you to resize the disks if needed (as described in the techtarget article ckivml posted). Once you have it converted power down your ESX based VM, then use VMware Workstation or Player to test the converted VM comes up and works. When satisfied that it does go back to your ESX and delete the troublesome VM. Next use VMware converter to "convert" the vm back to ESX. While this is a bit involved it will allow you to use storage that is offline from your ESX server in order to get the snapshot removed and back to normal.

Just as a rule of thumb, I try to maintain 15 to 20% free space on a datastore because VMware needs such space in order to allocate things such as swap files for vms when they are powered on and for snapshot growth and consolidation.

Good Luck
0
 

Author Comment

by:cdsaus
Comment Utility
I have an Idea can someone confirm if they think it might work

If i install something like Acronis DiskDirector and resize the Windows Partition to say 160GB out of the 200 leaving 40-50Gb Free and then go back into the Vm Setup and make the Partition to match the Windows Partion Size ie: 160Gb will this work'

Thanks Adam
0
 
LVL 28

Expert Comment

by:bgoering
Comment Utility
I wouldn't try to resize it as long as it has an active snapshot - can't imagine what might break then. The acronis would see the logical view (base disk + snapshot data) and likely any change you make has the potential to make the snapshot grow more.
0
 
LVL 6

Accepted Solution

by:
ckivml earned 250 total points
Comment Utility
Please find the attachment for instruction!..
VmWare-Notes.pdf
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
VM or Imaging options for a computer 4 64
VMWare 6 crashing 14 49
esxi multiple ip bind 5 37
login with Vsphere Client 14 42
When we have a dead host and we lose all connections to the ESXi, and we need to find a way to move all VMs from that dead ESXi host.
This article will show you how to create an ISO CD-ROM/DVD-ROM image (*.iso), and MD5 checksum signature, for use with VMware vSphere Hypervisor 6.5 (ESXi 6.5). It's a good idea to compare checksums, because many installations fail because of a corr…
Teach the user how to configure vSphere Replication and how to protect and recover VMs Open vSphere Web Client: Verify vsphere Replication is enabled: Enable vSphere Replication for a virtual machine: Verify replicated VM is created: Recover replica…
This Micro Tutorial walks you through using a remote console to access a server and install ESXi 5.1. This example is showing remote access and installation using a Dell server. The hypervisor is the very first component of your virtual infrastructu…

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now