?
Solved

How to resolve the size limit of file upload in SharePoint library?

Posted on 2010-11-18
4
Medium Priority
?
1,190 Views
Last Modified: 2012-05-10
Dear EE,

I would like to ask support on how to resolve the limit size of file when you upload something into the library.
I have already edited the web.config file in the IIS, added this lines:
<system.webServer>
  <security>
    <requestFiltering>
      <requestLimits maxAllowedContentLength="2147483648"/>
    </requestFiltering>
   </security>
</system.webServer>
before the closing tag </configuration>

I know that this "2147483648" = to 2GB, am I right? But why if I try to upload 50MB, can, but more than 50MB, like 65MB or 100MB, this message shows "The form submission cannot be processed because it exceeded the maximum length allowed by the Web administrator. Please resubmit the form with less data."
Kindly advise on how to increase the limit size of uploading file size...

Thank you!
0
Comment
Question by:Stiebel Eltron
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
4 Comments
 
LVL 10

Expert Comment

by:Humpdy
ID: 34162398
0
 

Author Comment

by:Stiebel Eltron
ID: 34162532
@Humpdy: I've checked the link that you advised, I already did the increasing the size limit into "2147483648". Do I need to change it to "52428800? And do I need to change the Request time out also? Because I couldn't find it from the web.config file that I have. And I'm not experiencing any time-outs...

Please advise...
0
 
LVL 10

Accepted Solution

by:
Humpdy earned 2000 total points
ID: 34162543
you don't need to change it to 52428800.
But change the request time as well.

Have you made the change in sharepoint as well ?
0
 
LVL 1

Expert Comment

by:Mafanaut
ID: 34162553
Hi,

There is a Maximum Upload Size Limit directly in SharePoint 2007. You can change that in central administration.
To change this, open the Central Administration, open Application Management.
Then open the General Settings of your web application.
On this page (quite a way down) you will find the Maximum upload size.
Change it to your preferred value.

Hope this helps,
Martin
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you have heard of RFC822 date formats, they can be quite a challenge in SQL Server. RFC822 is an Internet standard format for email message headers, including all dates within those headers. The RFC822 protocols are available in detail at:   ht…
Use this article to create a batch file to backup a Microsoft SQL Server database to a Windows folder.  The folder can be on the local hard drive or on a network share.  This batch file will query the SQL server to get the current date & time and wi…
Monitoring a network: how to monitor network services and why? Michael Kulchisky, MCSE, MCSA, MCP, VTSP, VSP, CCSP outlines the philosophy behind service monitoring and why a handshake validation is critical in network monitoring. Software utilized …
In this video, Percona Solution Engineer Dimitri Vanoverbeke discusses why you want to use at least three nodes in a database cluster. To discuss how Percona Consulting can help with your design and architecture needs for your database and infras…

777 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question