Solved

How can I disable F4 Key in Remote Access Environment (RDS) on Win 2008 R2 Server???

Posted on 2010-11-18
7
907 Views
Last Modified: 2013-11-21
Dear Sir,

I have a full RDS environment using Win 2008 R2.
I disabled F4 key in the registry... using the following reg:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,06,00,00,00,00,00,5B,E0,00,00,5C,E0,00,00,3e,00,00,00,0f,00,00,00,01,00,00,00,00,00

If I want to enable again, I use this one:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,03,00,00,00,00,00,00,00


If I access the server locally, then I open any application and try to close it using Alt+F4, it will not close because F4 key is disabled...
However if I access the server remotely RDP, and press Alt+F4, the application or any window will close.
I don't want Alt+F4 to close anything if I'm accessing remotely using Remote Desktop Services... RDS

I didn't have this issue before with Win 2003/2008 Server TS... F4 key was disable remotely and locally...
Microsoft changed something Between 2003/2008 and 2008 R2...

I'm not able to find any resource on what is changed between the 2 Windows Server versions related to remote access keys...

Please I need a help on how to disable F4 key in Win 2008 R2.

Thank You!

Regards,

-Charbel-
0
Comment
Question by:ISC-IT-Admin
  • 3
  • 3
7 Comments
 
LVL 74

Expert Comment

by:Glen Knight
Comment Utility
Have you got loopback processing enabled?

Just a guess really as if it's working on the local machine as you want it to this could be the problem.

See here for more details: http://support.microsoft.com/kb/141229
0
 
LVL 1

Author Comment

by:ISC-IT-Admin
Comment Utility
Hello Demazter,

Thank you for the reply.

Sorry I didn't understand what do you mean by loopback processing enabled?
I need to disable F4 key from remote access.
It's disabled locally on the server... but not remotely...

I used The IgnoreRemoteKeyboardLayout registry entry value 1, without success.

http://social.technet.microsoft.com/forums/en-US/winserverGP/thread/f68f92bd-4b43-42aa-b4fb-ab0070d3c42d/

Please any help on how to disable it on Win 2008 R2!

Thank You.

0
 
LVL 74

Expert Comment

by:Glen Knight
Comment Utility
OK, let me get this right, you are using the web interface yes?
If so then I don't believe that you are going to get this to work the way you want it to.
0
Too many email signature updates to deal with?

Do you feel like you are taking up all of your time constantly visiting users’ desks to make changes to email signatures? Wish you could manage all signatures from one central location, easily design them and deploy them quickly to users? Well, there is an easy way!

 
LVL 1

Author Comment

by:ISC-IT-Admin
Comment Utility
Hello demazter,

I didn't have this issue before with Win 2003 server.
If I access the server remotey in Win 2003, then I open any window and try to close it using Alt+F4, it won't close because F4 key is disabled in the registry...
However is not the case in Win 2008 R2, if I access the server Locally F4 is disabled, but remotely not...
I can still close any window remotely...

Any idea?

Thanks,
0
 
LVL 74

Expert Comment

by:Glen Knight
Comment Utility
First of all if you want correct answers, you need to answer my questions.

If you are launching a remote app and not connecting to the remote desktop services then you are as far as the client is concerned running an application (remote desktop) locally.  Therefore if you press ALT+F4 then this is a shortcut on the client machine not the server.

I would suggest the behaviour you are seeing is correct. Have you tried disabling ALT+F4 on the client?
0
 
LVL 1

Author Comment

by:ISC-IT-Admin
Comment Utility
Hello demazter,

Thank you for the reply.
Yes I'm running the application as RemoteApp with the user assignment permission...
In fact I'm using only one user name and all is accessing the same application, it's an exam application for students.

I'v tried to access the server remotelly from an XP PC without running the application, I connected normally Remote Desktop Services, and I opened My computer then press Alt+F4 it works, however locally from the server is not...

My Thin Clients are linux debian, I didn't find a solution yet on how to disable F4 on Linux.

Any Help.

Thank You!
0
 
LVL 13

Accepted Solution

by:
BCipollone earned 500 total points
Comment Utility
0

Featured Post

Want to promote your upcoming event?

Are you going to an event? Are you going to be exhibiting at a tradeshow? Talking at a conference? Using a promotional banner in your email signature ensures that your organization’s most important contacts stay in the know and can potentially spread the word about the event.

Join & Write a Comment

Remote Apps is a feature in server 2008 which allows users to run applications off Remote Desktop Servers without having to log into them to run the applications.  The user can either have a desktop shortcut installed or go through the web portal to…
Sometimes drives fill up and we don't know why.  If you don't understand the best way to use the tools available, you may end up being stumped as to why your drive says it's not full when you have no space left!  Here's how you can find out...
This tutorial will walk an individual through the process of configuring their Windows Server 2012 domain controller to synchronize its time with a trusted, external resource. Use Google, Bing, or other preferred search engine to locate trusted NTP …
This tutorial will walk an individual through setting the global and backup job media overwrite and protection periods in Backup Exec 2012. Log onto the Backup Exec Central Administration Server. Examine the services. If all or most of them are stop…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now