How can I disable F4 Key in Remote Access Environment (RDS) on Win 2008 R2 Server???

Dear Sir,

I have a full RDS environment using Win 2008 R2.
I disabled F4 key in the registry... using the following reg:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,06,00,00,00,00,00,5B,E0,00,00,5C,E0,00,00,3e,00,00,00,0f,00,00,00,01,00,00,00,00,00

If I want to enable again, I use this one:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"Scancode Map"=hex:00,00,00,00,00,00,00,00,03,00,00,00,00,00,00,00


If I access the server locally, then I open any application and try to close it using Alt+F4, it will not close because F4 key is disabled...
However if I access the server remotely RDP, and press Alt+F4, the application or any window will close.
I don't want Alt+F4 to close anything if I'm accessing remotely using Remote Desktop Services... RDS

I didn't have this issue before with Win 2003/2008 Server TS... F4 key was disable remotely and locally...
Microsoft changed something Between 2003/2008 and 2008 R2...

I'm not able to find any resource on what is changed between the 2 Windows Server versions related to remote access keys...

Please I need a help on how to disable F4 key in Win 2008 R2.

Thank You!

Regards,

-Charbel-
LVL 1
ISC-IT-AdminAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Glen KnightCommented:
Have you got loopback processing enabled?

Just a guess really as if it's working on the local machine as you want it to this could be the problem.

See here for more details: http://support.microsoft.com/kb/141229
0
ISC-IT-AdminAuthor Commented:
Hello Demazter,

Thank you for the reply.

Sorry I didn't understand what do you mean by loopback processing enabled?
I need to disable F4 key from remote access.
It's disabled locally on the server... but not remotely...

I used The IgnoreRemoteKeyboardLayout registry entry value 1, without success.

http://social.technet.microsoft.com/forums/en-US/winserverGP/thread/f68f92bd-4b43-42aa-b4fb-ab0070d3c42d/

Please any help on how to disable it on Win 2008 R2!

Thank You.

0
Glen KnightCommented:
OK, let me get this right, you are using the web interface yes?
If so then I don't believe that you are going to get this to work the way you want it to.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

ISC-IT-AdminAuthor Commented:
Hello demazter,

I didn't have this issue before with Win 2003 server.
If I access the server remotey in Win 2003, then I open any window and try to close it using Alt+F4, it won't close because F4 key is disabled in the registry...
However is not the case in Win 2008 R2, if I access the server Locally F4 is disabled, but remotely not...
I can still close any window remotely...

Any idea?

Thanks,
0
Glen KnightCommented:
First of all if you want correct answers, you need to answer my questions.

If you are launching a remote app and not connecting to the remote desktop services then you are as far as the client is concerned running an application (remote desktop) locally.  Therefore if you press ALT+F4 then this is a shortcut on the client machine not the server.

I would suggest the behaviour you are seeing is correct. Have you tried disabling ALT+F4 on the client?
0
ISC-IT-AdminAuthor Commented:
Hello demazter,

Thank you for the reply.
Yes I'm running the application as RemoteApp with the user assignment permission...
In fact I'm using only one user name and all is accessing the same application, it's an exam application for students.

I'v tried to access the server remotelly from an XP PC without running the application, I connected normally Remote Desktop Services, and I opened My computer then press Alt+F4 it works, however locally from the server is not...

My Thin Clients are linux debian, I didn't find a solution yet on how to disable F4 on Linux.

Any Help.

Thank You!
0
BCipolloneCommented:
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.