Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Avaya Softphone not connecting through Juniper SSG 140 VPN

Posted on 2010-11-18
12
Medium Priority
?
2,548 Views
Last Modified: 2012-05-10
Hi,

I have Avaya G450 gateway and i am using my H.323 terminal, Avaya softphone and avaya one x communicator successfully in the my own network (within the LAN).

We have set up L2TP VPN for connecting to the internal network from the outside. I am trying to use the softphone through L2TP VPN, i am able to reach (ping the server) but the softphone is not registering.

Can anybody tell me how i can solve this issue? which ports i need to open in the Juniper and how?
0
Comment
Question by:tayyabq8
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 2
  • 2
  • +2
12 Comments
 
LVL 12

Expert Comment

by:Kent W
ID: 34162646
Have you turned on L2TP VPN Passthrough on the router at the remote location, home / office, or wherever you are VPNing in from?
0
 
LVL 10

Expert Comment

by:abhijitmdp
ID: 34163663
I also faced the same problem once. I'll need some time to search on my knowledge.
0
 
LVL 18

Expert Comment

by:Sanga Collins
ID: 34164283
Firs thins to do is disable SIP ALG in the juniper. The second thing to do is enable source based NAT on the outgoing policy for the VOIP traffic.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:tayyabq8
ID: 34166139
@mugojava:L2TP VPN Passthrough is turned on.

@abhijitmdp:: take your time and let me know.

@sangamc:SIP ALG in the junipep is disabled. Could you pls explain how i can make outgoing policy for the VoIP and enable source based NAT on it?
0
 
LVL 18

Expert Comment

by:Sanga Collins
ID: 34166418
on which ever policy is sending outgoing traffic for VOIP, go to the advanced section and put a check mark on 'source translation' and set DIP to 'none (use egress interface ip)'
0
 

Author Comment

by:tayyabq8
ID: 34166785
tried still did not worked...
0
 

Author Comment

by:tayyabq8
ID: 34169417
with some luck i am able to register to the server and able to make some test calls.

I am facing a voice issue, if i am calling from my softphone to any number, the other person is able to hear me clearly but i am not able to hear him or any voice.

The policy from the trust to untrust for the VOIP traffic is already there.

Any ideas?
0
 
LVL 2

Expert Comment

by:ksaiki
ID: 34174440
Have you try to disable H323 ALG?  Juniper device has some known issue on Avaya VoIP.
If this does not help try to adjust mss size using 'set flow tcp-mss' command.  
0
 
LVL 10

Expert Comment

by:abhijitmdp
ID: 34199039
For further clarification please refer following table of IP Telephony Deployment Guide

 IP Station 2

 IP Station 2IP-Station2.jpg
0
 

Author Comment

by:tayyabq8
ID: 34226993
hi,

All the ports are already opened in the Juniper SSG 140 according to the Avaya guide. (Do i need to open some ports in the Avaya as well?)

Following is the procedure which i am following:

1- Connect to the VPN and after connecting i am able to reach/ping  my G450 Avaya GW and network.
2- I am using Avaya one-x 5.2 version for connecting to the PBx through VPN (I also tried Avaya IP softphone but same result)
3- To register to my PBx through VPN i have to put my trust interface to route mode. (I have to use the NAT mode for trust zone in order my internet to work, because the ADSL connection is configured in the juniper as well), please advise how i can use the route mode for that PBx purpose only, do i need to create another trust zone ?
4-Once the trusted interface is set to route mode (the internet will stop work) and i am able to connect to my PBx from outside using VPN.
6- After connecting i am able to dial the calls to the outside + my internal number extension, the other person can hear my voice clearly but i can not hear anybody.

Please advise how i can troubleshoot this issue.

Thanks.
0
 

Accepted Solution

by:
tayyabq8 earned 0 total points
ID: 34505246
I called the support team and they did some configuration changes in the avaya GW and now the issue is resolved.
0
 

Author Closing Comment

by:tayyabq8
ID: 34533045
Avaya Support team fixed the issue.
0

Featured Post

Sign your company up to try the MB 660 headset now

Take control and stay focused in noisy open office environments with the MB 660. By reducing background noise, you can revitalize your office and improve concentration.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

OpenVPN is a great open source VPN server that is capable of providing quick and easy VPN access to your network on the cheap.  By default the software is configured to allow open access to your network.  But what if you want to restrict users to on…
Why do some people recommend buying business VoIP from an ISP? What are the benefits to my company? What are the costs?
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

604 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question