Solved

ufsrestore from Solaris 10 to solaris 8 zone

Posted on 2010-11-18
6
1,201 Views
Last Modified: 2013-12-27
I am trying to restore a ufsdump file into a Solaris 8 zone on a Server & am getting stuck on this. Any ideas?
ufsrestore rf /export/home/test/test.dump                  
mount volume 2                                                    
then enter volume name (default: /export/home/test/test.dump)

My .dump file is in /export/home/test & I am trying to restore it to /zone/sol8/root/test - I am in this directory when I run the ufsrestore command.
0
Comment
Question by:itwex
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
6 Comments
 
LVL 78

Expert Comment

by:arnold
ID: 34163695
What was the ufsdump directive you used?
Did you hit enter? What happened?

0
 

Author Comment

by:itwex
ID: 34163721
Yes, tried <Enter> & got the following:

Wrong volume (1)                                                  
Mount volume 2                                                    
then enter volume name (default: /export/home/test/test.dump)  

Could the dump file be corrupt?
0
 
LVL 78

Expert Comment

by:arnold
ID: 34163841
Did you use ufsdump 0f /export/home/test/test.dump?
Is it an incremental backup
ufsdump 1f /export/home/test/test.dump?

run:
ufsrestore if /export/home/test/test.dump and see if you get a different response.
0
Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Author Comment

by:itwex
ID: 34164640
Hi,

I used ufsdump 0cfu filename /dev/md/dsk/d100
0
 
LVL 78

Accepted Solution

by:
arnold earned 250 total points
ID: 34166768
The problem is your use of the c option sine you are not using a tape there is no need to use the c option.

the dump file might be made up of two sections.

when dumping to a file, do not use the c flag.
look at /etc/dumpdates to see whether it create a two section of the same dump process.
If it has, you may have to use the s flag with a section designation
ufsrestore rfs filename 1
i.e. the initial dump will be offset 0, the second will be offset of 1.
You always have to feed last tape first.
0
 

Author Closing Comment

by:itwex
ID: 34174125
Thanks for your help. Problem now sorted.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

When you do backups in the Solaris Operating System, the file system must be inactive. Otherwise, the output may be inconsistent. A file system is inactive when it's unmounted or it's write-locked by the operating system. Although the fssnap utility…
Let's say you need to move the data of a file system from one partition to another. This generally involves dismounting the file system, backing it up to tapes, and restoring it to a new partition. You may also copy the file system from one place to…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
Suggested Courses

751 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question