Solved

Problem opening .xls files in Excel

Posted on 2010-11-18
25
390 Views
Last Modified: 2012-05-10
I have a PC with a strange excel problem.

When opening the xls directly, whereever its location on the PC may be I get the error as attached.

If I open excel first (which seems to take an age) the file appears in 'recentley opened', click this and it opens fine.

Any suggestions appreciated error message
0
Comment
Question by:Ripla5
  • 12
  • 8
  • 4
  • +1
25 Comments
 
LVL 3

Expert Comment

by:jplato
ID: 34163759
open the file in excel and then try clicking save as and overwrite the file on your desktop see if that helps.
0
 

Author Comment

by:Ripla5
ID: 34164086
Hi,

sorry, I already tried that, doesn't seem to matter where the spreadsheet is on the pc, it wont open directly.

Also, the problem is purely with the spreadsheet and does not affect any other files or programs.

0
 
LVL 3

Expert Comment

by:jplato
ID: 34164103
Does this happen on any other xls files?
0
 

Author Comment

by:Ripla5
ID: 34164108
No, just this one spreadsheet
0
 
LVL 3

Expert Comment

by:jplato
ID: 34164122
I would copy and paste this in a new work book and save it then delete that one seems to be corrupt
0
 

Author Comment

by:Ripla5
ID: 34164171
Apologies,
I'm certain when I opened some other spreadsheets before there wasn't an issue, now all of them are doing the same, also when I try your last suggestion I just get the same error

I'm thinking perhaps a reinstall of excel is next on the 'to do' list?
0
 
LVL 3

Expert Comment

by:jplato
ID: 34164194
0
 

Author Comment

by:Ripla5
ID: 34164616
Thanks for the suggestion, I thought that might fix it but no luck unfortunately

this is what the kb suggests:

Quit Excel and all other programs.
Click Start, and then click Run.
Type excel /unregserver, and then click OK.
Click Start, and then click Run.
Type excel /regserver, and then click OK.
Start Excel.
Quit Excel.

0
 
LVL 1

Expert Comment

by:Taha_sk
ID: 34165370
Try this.

for excel 2003

. Click "Tools", selecting "Options".

2. When the "Options" multi-tabbed dialog box appears, click the "General" tab.

3. Check "Ignore other applications".

4. Click "OK" to close the dialog box.
----------------

Excel 2007 or 2010

Click the Office button and then click Excel Options. Excel displays the Excel Options dialog box.
Click Advanced at the left side of the dialog box.
Scroll through the options until you can see the General group.
Make sure the Ignore Other Applications That Use Dynamic Data Exchange (DDE) check box is not selected.
Click OK.
0
 

Author Comment

by:Ripla5
ID: 34171846
Hi Taha_sk, thanks for the reply.

I have tried your suggestion but unfortunately that didn't cure it either.




0
 
LVL 30

Expert Comment

by:SiddharthRout
ID: 34173293
Have you tried this?

http://support.microsoft.com/kb/207574

Sid
0
 

Author Comment

by:Ripla5
ID: 34342299
apologies @ SiddharthRout - I didn't see your message come in

Your suggestion hasn't cured it either - as a workaround for now we are just going to stick with the 'recentley opened' option

In the new year we will be installing a newer version of Office so hopefully this will correct it.

Thanks for all suggestions
0
Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

 
LVL 30

Expert Comment

by:SiddharthRout
ID: 34342313
There has to be a simple solution for this...

Let me explore other options and get back to you...

Sid
0
 
LVL 30

Expert Comment

by:SiddharthRout
ID: 34342366
Most of the solutions have been given above.

The which are left are far fetched but I will still cover them up.

1) Reset the File type association. Easiest way to do it is, press "Shift" and then right click on the Excel File and then click on "Open With". Select Excel and before you click on 'OK', "Check " the checkbox which says "Always use the selected program to open this kind of file"

If the above still doesn't work then this option.

2) Right click on the file and click on Properties. Got to the "Security Tab" and post a screenshot of the same.

Sid
0
 

Author Comment

by:Ripla5
ID: 34343131
Hi Sid, screenshot attached...

 screenshot as requested
0
 
LVL 30

Expert Comment

by:SiddharthRout
ID: 34343233
What are the attributes for "Workshop"... below "System"? I guess "Workshop" is the Id from which you have logged on to this pc?

Sid
0
 

Author Comment

by:Ripla5
ID: 34343630
Hi Sid,

the attributes for System, workshop and administrators are all as the above attachment, and yes we are logged in as 'Workshop'
0
 
LVL 30

Expert Comment

by:SiddharthRout
ID: 34343669
That option also goes down the drain then...

As you have Read permissions :)

Sid
0
 
LVL 30

Expert Comment

by:SiddharthRout
ID: 34343688
You tried the 1st option given in ID: 34342366 right?

Sid
0
 

Author Comment

by:Ripla5
ID: 34343702
yes, tried that before doing the screen print
0
 
LVL 30

Expert Comment

by:SiddharthRout
ID: 34343778
Hmmm... I am mystified.

If you have tried all the options given by me and the other posters then there is something really wrong with your Excel Installation...

I would suggest once again go through all the suggestions given by everyone and if it still doesn't help then do a fresh install on your pc. When I say fresh install I mean formatting your pc and re-installing windows and then installing Excel.

Sid
0
 

Author Comment

by:Ripla5
ID: 34343814
Thanks for your efforst Sid, it beats the heck out of me too!

I will try the later install of Office first as this uses different registry keys and shouldn't interfere with the 2003 version

If that doesn't work then I will try and format :)
0
 
LVL 30

Expert Comment

by:SiddharthRout
ID: 34343828
Sounds like a plan :)

Sid
0
 

Accepted Solution

by:
Ripla5 earned 0 total points
ID: 34449761
Upgrade to 2007 has cured the issue
0
 

Author Closing Comment

by:Ripla5
ID: 34470619
Cured upgrading program
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
excel pivot question 4 40
macro for each dropdown 15 46
Excel Conditional Formatting in a Macro 4 26
Excel VBA - merge "specific" data from workbook in to "new" workbook. 19 23
Dealing with unintended Excel Active-X resizing quirks (VBA code simulates "self correction") David Miller (dlmille) Intro Not everyone is a fan of Active-X controls in spreadsheets (as opposed to the UserForm approach, the older Form controls …
Introduction While answering a recent question (http:/Q_27311462.html), I created an alternative function to the Excel Concatenate() function that you might find useful.  I tested several solutions and share the results in this article as well as t…
The view will learn how to download and install SIMTOOLS and FORMLIST into Excel, how to use SIMTOOLS to generate a Monte Carlo simulation of 30 sales calls, and how to calculate the conditional probability based on the results of the Monte Carlo …
This Micro Tutorial demonstrates using Microsoft Excel pivot tables, how to reverse engineer competitors' marketing strategies through backlinks.

867 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now