Solved

How can I downgrade ASP.NET v4.0 to .NET 3.5 SP1?

Posted on 2010-11-18
11
1,741 Views
Last Modified: 2012-05-10
We have purchased SOLARWINDWS ORION NPM and an engineer before me was not able to get it working properly. He was recently let go and I was moved into a junior engineering position. My first major project is to get this product up and running. I have been working with SOLARWINDS engineers and feel we have made progress, but there is still a web interface error when displaying details of a node. The SOLARWINDS engineer pointed out that we are running .NET 4 and that is not supported and recommended I downgrade to .NET 3.5 SP1. I thought this meant going to the CONTROL PANEL then PROGRAMS and FEATURES and removing the application there, but in there I see that .NET 3.5 is installed. The SOLARWINDS engineer was displaying .NET 4 by opening SERVER MANAGER and browsing to ROLES, IIS, THE SERVER IN QUESTION, then highlighting APPLICATION POOLS. There ASP.NET v4.0 is displayed. How can I get that back to .NET 3.5 SP1. Is this something totally different from the .NET in PROGRAMS and FEATURES? All assistance is appreciated.  Thanks
0
Comment
Question by:Thor2923
  • 5
  • 3
  • 3
11 Comments
 
LVL 1

Author Comment

by:Thor2923
Comment Utility
If anyone can also explain the difference between ASP.NET and the . NET in programs and features, I would appreciate it
0
 
LVL 52

Accepted Solution

by:
Carl Tawn earned 334 total points
Comment Utility
In the place where the engineer showed you that it was running .net 4, you should be able to change that to 2.0 (which is the same as 3.5 as far as IIS configuration is concerned).
0
 
LVL 1

Author Comment

by:Thor2923
Comment Utility
is that a right click thing? I am not sure where to change it
0
 
LVL 52

Assisted Solution

by:Carl Tawn
Carl Tawn earned 334 total points
Comment Utility
Actually, wrong place. If you browse to your website in IIS, right-click on the website and choose Properties. The switch to the tab named "ASP.Net"; on there should be a dropdown that will let you change the .Net version that the website targets.
0
 
LVL 15

Expert Comment

by:pcsmitpra
Comment Utility
What is the version of SOLARWINDWS ORION NPM you are using?
0
Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

 
LVL 1

Author Comment

by:Thor2923
Comment Utility
10.0....I have been told that is the most stable...I know the engineer before tried 10.1 and had nothing but problems
0
 
LVL 15

Assisted Solution

by:pcsmitpra
pcsmitpra earned 166 total points
Comment Utility
Hello

For Orion NPM Version 10.1, it supports .NET 3.5 and above. And as .NET Framework 4 works side by side with older Framework versions. It should work. Probably you need to choose the asp.net 2.0 version for the website.

Thank you
0
 
LVL 15

Expert Comment

by:pcsmitpra
Comment Utility
Please try to change the version of asp.net on website, IIS -> Website -> properties-> ASP.NET -> Select ASP.NET 2.0 there. Press Apply -> Ok . Also check Web Service Extensions , it should be enabled for asp.net 2.0.
Then restart the application pool for that website or IIS by iisreset command.
Launch the application, incase you still see the error .. Please paste the error here.
0
 
LVL 1

Author Comment

by:Thor2923
Comment Utility
and on the comment above.....about "browsing to your website in IIS"...I have IIS 7 open on a windows 2008 standard server. I see the SERVER NAME and below that is APPLICATION POOLS and SITES. I click the + next to SITES and see DEFAULT WEB SITE, SOLARWINDS NETPERFMON, SOLARWINDS ORION NETWORK CONFIGURATION.
I am assuming the website I am looking for is going to be under SOLARWINDS NETPERFMON, but I do not see any place to right click to get a drop down menu to change .NET. Do you know if I should drill down deeper? I do not see a PROPERTIES option on anything I right click.
0
 
LVL 52

Expert Comment

by:Carl Tawn
Comment Utility
Oh, ok, bit different for IIS 7.

Click on your site, then on the "Actions" panel click "Basic Settings". In that dialog will be a value called "Application pool", make a note of it.

Close the dialog, the click "Application Pools" in the left hand panel. Find teh application pool you found against the website. Right-click on it and choose "Basic Settings". In the Framework Version dropdown, select ".NET Framework v2.0.50727"
0
 
LVL 1

Author Closing Comment

by:Thor2923
Comment Utility
both experts were helpful
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Suggested Solutions

If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
Lync server 2013 Backup Service Error ID 4049 – After File Share Migration
When you create an app prototype with Adobe XD, you can insert system screens -- sharing or Control Center, for example -- with just a few clicks. This video shows you how. You can take the full course on Experts Exchange at http://bit.ly/XDcourse.
This tutorial demonstrates a quick way of adding group price to multiple Magento products.

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

6 Experts available now in Live!

Get 1:1 Help Now