Solved

How to configure Exchange 2007 with a local domain for external e-mails ?

Posted on 2010-11-18
9
398 Views
Last Modified: 2012-05-10
Hello Experts,  this is the scenario i  want to setup my exchange 2007 for receiving and sending e-mails with my external domain name, but i have .local domain with my 2008 server.
So i followed a tutorial,  

1.On the transport Hub  on the accepted domain   i entered my external domain name, and setted it   by default.

2.I created a send  Connector,  on the "space adress" i have set the "*" character for all domains
on the "network" tab i routed the messages  to my isp smtp, and checked use external lookup dns parameters on the transport server.

So my emails doesent wants to go out,   is it some other neceserray parameters for that configuration ?
0
Comment
Question by:pragmatick
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 3
9 Comments
 
LVL 57

Expert Comment

by:Pete Long
ID: 34163944
you need to add the public domain to the email policy.

heres a full walk through I wrote a while back http://www.petenetlive.com/KB/Article/0000263.htm
0
 
LVL 57

Accepted Solution

by:
Pete Long earned 334 total points
ID: 34163967
also im assuming smtp is open on your corporate firewall ?
0
 

Author Comment

by:pragmatick
ID: 34163982
No, i cheat with that.
I have a pop3 connector

so im reading on your tuto  i tell ya in a few mins.
0
Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 

Author Comment

by:pragmatick
ID: 34164016
i mean  we can use external smtp   there is no rule about that
but the port 25 is not forwarded on my exchange
0
 
LVL 57

Assisted Solution

by:Pete Long
Pete Long earned 334 total points
ID: 34164157
>>I have a pop3 connector

It must be third party pop3 support is no longer in Exchange 2007?

>>but the port 25 is not forwarded on my exchange

to send out you need SMTP port 25 open outbound - with a configured send connector and the ability to resolve DNS
to receive in you nee an MX record pointing either to you or a host that will collect for you, smtp inbound to the either the public IP of the mail server or an IP address hat will port forward it to the mail server, and finally anonymous access enabling on the internet facing connector.

Pete
0
 
LVL 1

Assisted Solution

by:Bruno Gagnon
Bruno Gagnon earned 166 total points
ID: 34164188
You also need to have an A and an MX record created on the public dns server that host the domain name. Set the address A record to point to the public ip address of your smtp server and the mx record point to the newly created A record i.e.:

MX      10       mail.mycompany.com
mail     A        150.223.12.10

make sure that your server is smtp is visible from outside your organisation with a test like

telnet mail.mycompany.com 25

it that connect from the outside you have one more step to succes.

HTH
0
 

Author Comment

by:pragmatick
ID: 34164226
yep its a third party as i have not sbs.

i have my domain name on a external isp who's providing e-mail and web support,
I use a pop3 connector for retrieving e-mails from that isp, and dispatching to the exchange mailboxes.

for sending e-mails its routed to a smarhost "my isp smtp"  but the message still doesnt go out.

i have read your tuto but its not my scenario.

0
 

Author Comment

by:pragmatick
ID: 34171865
Ok it seems that the problem  is the smarthost default port  for relaying.

because    the smarthost is   mail.c-c.ch    but the default port for smtp on my external isp is set on 587.
How can i change the default port for relaying ?
0
 

Author Comment

by:pragmatick
ID: 34172024
Fouded !

Open Exchange Management Shell and start by checking your Send Connector(s) :

   Get-SendConnector

You should get the name of your send connector(s) – like “Default Send Connector”.

If you haven’t messed up with the port configuration of the connector yet, it should be using the default port -25.
It is a good idea to confirm this with the command:

   Get-SendConnector | fl port

Then change the port with the command:

   Set-SendConnector –Identity “Your Send Connector Name” -Port 587

If you have only one Send Connector you can use that command too:

   Get-SendConnector | Set-SendConnector -Port 587

Of course, it is a good idea to check the final result again with:

   Get-SendConnector | fl port

Or even take a look at the full listing for the send connector:
Get-SendConnector | fl

0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Marketers need statistics and metrics like everybody else needs oxygen. In this article we explain how to enable marketing campaign statistics for Microsoft Exchange mail.
How to resolve IMCEAEX NDRs in Exchange or Exchange Online related to invalid X500 addresses.
In this video we show how to create an email address policy in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Mail Flow…
To show how to generate a certificate request in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.:  First we need to log into the Exchange Admin Center. Navigate to the Servers >> Certificates…

749 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question