Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 743
  • Last Modified:

BlackBerry Enterprise Server Express 5: SQL connection problems on Small Business Server 2008

We're installing BES Express 5.02 on an SBS 2008 which already hosts a pre-installed SQL Server. In the BES installation process, we selected "install on existing/local SQL server" but can't get it to connect for love nor money.

I'd like to avoid installation of yet another SQL Express instance by BES, if at all possible. Anything special about BES that won't let it talk to a local SQL server on an SBS?
0
zolcer
Asked:
zolcer
  • 4
  • 4
1 Solution
 
EvilPostItCommented:
On the remote SQL Server are remote connections allowed.

Have a look at the below article.

http://blogs.msdn.com/b/sqlexpress/archive/2005/05/05/415084.aspx
0
 
zolcerAuthor Commented:
We're installing BSE right on the SBS server. Is that a remote connection?
0
 
EvilPostItCommented:
Oh sorry missed that bit.

Not that would not be a remote connection. Can you confirm that the SQL Service is running?

Can you connect to is with other tools?
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
zolcerAuthor Commented:
Sure, the SQL service is running. Other applications are happily connecting to their own DB within the SBSMONITORING instance.

The SQL Server Browser is disabled.
0
 
EvilPostItCommented:
What edition of SQL? Express / Standard / Enterprise?
0
 
zolcerAuthor Commented:
The one that comes with Small Business Server 2008, Standard Edition. I suppose it's a 2005 Express.
0
 
EvilPostItCommented:
Can you find out what port it is running under?

If you are unsure on how to find this, look at my original post. In that article option a of step 2 should help you.
0
 
socrossCommented:
I was just having the exact same problem as described

I fixed it by:

1. Run Server Config Manager

Start > Run >  "sqlservermanager.msc"

2. Edit Network Configuration Protocols

Open the Network Configuration node and select the Instance of SQL Server you wish to use for BES
Right click on the "Named Pipes" and "TCP/IP" protocols and "Enable" them
Right click on the TCP/IP Protocol and select "Properties", go to the "IP Addresses" tab and at the bottom and empty the "TCP Dynamic Ports" field, then give it a fixed TCP port

3. Restart SQL Service

Go back to the Services node, right click on the Service which you were just editing and restart it.

4. Change Settings in BES setup

Change to fixed port and use the number you chose above.

0
 
zolcerAuthor Commented:
Quite right. I found some similar hints on RIM's own supportforums.blackberry.com - some posts contained the same steps you mentioned. It seems there are some extra nibbles you need to play with when you're installing BES on SBS 2008. Not sure which one actually did the trick, but it worked out in the end.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 4
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now