Solved

Network file sharing problems

Posted on 2010-11-18
12
505 Views
Last Modified: 2012-06-27
I think this should be fairly straight forward and easy to fix, but I can't seem to find the solution.

I have a small network setup. It was originally one server (windows 2000 server) and two workstations (windows 2000 desktop). I have since upgraded the desktops to XP (now 3 in all) and the Server is now 2003, (now three servers; all 2003). So, 3 pc's running XP professional and three servers running windows 2003 server standard edition.

My problem is that, from the beginning I had the server and workstations set up as a work group (no domain). All computers are in the same work group.

Before the upgrade I could browse to the windows 2000 server from both workstations and I could see the workstations from the server. The two workstations could see each other, but not browse. That was fine and all I needed at the time.

Now, that I have upgraded, two of the XP machines can browse to the Servers but the third one can not. The servers can not browse the desktops at all (any of them), but the servers can all see each other and browse each other.

I have all of the XP machines set up the same with File and Print sharing, etc. they all have the same IP / DNS settings (with different IPs of course). Every pc and server is in the same work group (still no domain).

I would like all of the servers and workstations to be able to browse to all the other machines in the group. If the XP machines can't browse each other, that would be OK, but at the minimum, I need all XP machines to browse the servers and all servers to be able to browse all XP machines.

By the way, I log into all of the machines as the administrator of the machine. All of the servers are logged in as the administrator ID and all of the XP machines have been given IDs and the IDs are configured as administrators.

Any help in getting this configured correctly would be appreciated.

Thanks.

0
Comment
Question by:section25
  • 5
  • 5
  • 2
12 Comments
 
LVL 2

Expert Comment

by:rgorelick60
Comment Utility
I would check to see if any of the computers you cannot browse have the windows firewall turned on(even if it shows off...double check by looking at the windows firewall and Internet connection sharing in the services, if it is started, stop the service and set it to manual...also if you cannot browse, can you connect to the computer thru the IP...ex: \\192.168.1.12...type IP into the address bar on my computer...any shared files/folders should appear...

another thing to look for is the setting to "enable netbios over TCP\IP...I have seen this setting restore the "browse" the network function...
0
 
LVL 8

Author Comment

by:section25
Comment Utility
To answer your questions:

1. The firewall is not running on any of the computers.
2. I can not connect by IP address (using \\192.168.1.204\c$ does not work)
3. netbios over tcpip is enabled on all computers

I was able to resolve one issue with the third workstation. Two of the workstations had been upgraded from windows 2000 to XP the 3rd one just had XP loaded directly on it. The third one was not able to browse any of the servers, but I noticed that it did not have NWLink/NetBios loaded as a protocol (like the other two). Now it does and now it can browse the servers.

However, I still can browse any of the XP machines from the Servers and I need to be able to do that. I did load NWlink on the servers as well, but that did not change anything. It seems like there is a permissions issues going from the server to the PC but not in the other direction.

If I try to map a drive to a server to an XP machine, it asks for an ID and password. I put in 'administrator' and the admin password and it comes back and says that the user has not been granted access to his machine.

If I try to map a drive to a server (from an XP machine), it lets me do it without asking for anything.

Also, I can ping the XP machines by name (c:\>ping ws1), but when I try to map a drive to the machine directly (\\ws1\c$), it says it can't find the machine.

Any other suggestions?
0
 
LVL 8

Author Comment

by:section25
Comment Utility
If only you could edit your comments...

Above where I said "However, I still can browse..."

I meant: "still can not browse..."
0
 
LVL 2

Expert Comment

by:rgorelick60
Comment Utility
If I try to map a drive to a server to an XP machine, it asks for an ID and password. I put in 'administrator' and the admin password and it comes back and says that the user has not been granted access to his machine.

you need to try logging into the PC with a known user account on that pc...since you do not have a domain, probably only an account of a local user on the PC can login...
0
 
LVL 2

Expert Comment

by:rgorelick60
Comment Utility
can you ping by name only or IP as well???...do you have anything shared on the computers you cannot browse???
0
 
LVL 8

Author Comment

by:section25
Comment Utility
I'm not sure what you mean by this: 'you need to try logging into the PC with a known user account on that pc...'

I do log into the PC with a known user (administrator).

When I try to access an XP machine from a server by entering "\\ws1\c$" directly on the explorer access bar, it pops up with a login window. The id in the window is already set to "\\ws1\guest" and is grayed out so I can not change it. I enter the admin password and of course it doesn't work (since I don't want to connect as guest anyway) and the same login box pops up again, but this time the id field is not filled in (and not grayed out) so I can enter the administrator ID into it (I tried both \\ws1\administrator and just administrator) and then I enter the admin password. It then comes back and tells me the machine can not be found.

I can ping by both name and IP.

If I set up a share (specifically) on the machines, I can see it from any other machine. However, I need access to the root of all drives on all machines. Since C$ is the default share for the C drive, I can not set up another share for the root of C. Only one share is allowed per folder (including the root folder).







0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 2

Expert Comment

by:rgorelick60
Comment Utility
I do not believe you can connect to the root on XP...you can only connect to anything that is shared...this has been my personal experience with XP...

read here...

http://en.wikipedia.org/wiki/Administrative_share

0
 
LVL 8

Author Comment

by:section25
Comment Utility
Thanks for the info, but I noticed this in the wiki article:

-------------------------------------------------------------
How to enable in Windows XP SP3

By default, Windows XP Service Pack 3 prevents access to the administrative shares through the network.

To enable administrative shares you have to:

    * Open Explorer and select Tools -> Folder Options
    * Select the View tab and scroll all the way down to the bottom of Advanced Settings
    * Make sure that "Use simple file sharing (Recommended)" is not selected

This should work instantly without the need for reboot.
--------------------------------------------------------

The checkbox for "use simple file sharing" is NOT checked on any of my XP machines and it still doesn't work.



0
 
LVL 2

Expert Comment

by:rgorelick60
Comment Utility
sometimes checking the box...to make it change...apply and then unchecking can reset it...
0
 
LVL 38

Expert Comment

by:ChiefIT
Comment Utility
You can not browse admin shares in "my network places"... Admin shares have a $ dollar sign appended to the share. You can see them under Managing a computer (computer management).

With that said, you have more problems than just shares. You can not ping one computer. That's a network problem. Most likely this is associated with a multihomed computer. Do any of your computers have dual nics or a VPN configured on them?
0
 
LVL 8

Author Comment

by:section25
Comment Utility
ChiefIT, I appreciate the info, but it sounds like you haven't read any of the above comments (or the original problem).

I'm not using "My Netowrk Places".
As stated above, I have been using the $ notation to access the shares all along.
And no, you do not access them from Computer Management. I'm trying to map a drive to them.
As stated above, I can ping all computers by both name and IP address.
There are no multi homed computers on the network and none are configured for VPN.

but thanks anyway.
0
 
LVL 38

Accepted Solution

by:
ChiefIT earned 500 total points
Comment Utility
Netbios is not a routeable protocol. Do you have VLANS configured between the servers and XP machines.

Also to use the netbios name, you will have to register the netbios name to IP in order for the machines to resolve. This works much like DNS, in a way. The client computers will send out netbios broadcasts in order to register with the Netbios server, (most likely the PDCe).

These netbios broadcasts help register the machine to determine what role it plays. It can be a Domain master browser, Backup browser, or not hold a browselist at all.

Since netbios is not routable, these broadcast messages will not go through a NAT router, across a VPN connection, most firewalls block Netbios, and a VLAN connection also blocks the broadcast traffic.

A great way to tell if the problem extends beyond netbios is using Ping:

Can you ping by IP address? (Uses ARP)
Can you ping by Fully Qualified domain Name of the computer? (Uses DNS resolution)
Can you ping by Netbios name (host name)? (Uses Netbios resolution)

If you can ping it, but not map to it, this means the browser service has stopped. Remember these netbios broadcast can elect a master browser. Well, if there is a master browser elected over the PDCe, then a master browser conflict will arrize and you will see Events 8021 or 8032 in the PDCe's event logs that say something like "xxx computer thinks it is the domain master browser, the browser service has stopped and an election has been forced"  The key here is the browser service stopping. If the browser service stopps, you will not be able to file and print share to that computer.

SO:
-Go to the problem children, and make sure the browser service is started and set to automatic.
-Make sure you are on the same broadcast domain.
-Make sure there are no firewalls blocking netbios
-Check your PDCe system event logs for events 8021 or 8032
- Make sure you use Netbios over TCP/IP rather than Netbios over DHCP. The default configuration assumes your DHCP server is the netbios domain master browser server (meaning the PDCe)
-Disable LMHOST lookup on all nics
-Make sure there is no multihomed nics because netbios will bind to one nic
-Ensure file and print sharing is enabled
-Ensure the workstation service is enabled
0

Featured Post

New My Cloud Pro Series - organize everything!

With space to keep virtually everything, the My Cloud Pro Series offers your team the network storage to edit, save and share production files from anywhere with an internet connection. Compatible with both Mac and PC, you're able to protect your content regardless of OS.

Join & Write a Comment

Suggested Solutions

I'm a big fan of Windows' offline folder caching and have used it on my laptops for over a decade.  One thing I don't like about it, however, is how difficult Microsoft has made it for the cache to be moved out of the Windows folder.  Here's how to …
ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
Here's a very brief overview of the methods PRTG Network Monitor (https://www.paessler.com/prtg) offers for monitoring bandwidth, to help you decide which methods you´d like to investigate in more detail.  The methods are covered in more detail in o…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

14 Experts available now in Live!

Get 1:1 Help Now