Calendar Items Disappear in OWA when Cached Mode Outlook opens

I have an Exchange server 2007.  When users add items on the calendar in OWA the items are fine. When the users open Outlook 2007 with Cached mode turned off thye see the calendar items. If they then close Outlook 2007 and turn on Cached Mode then the items entered in OWA disappear.  If I use an old version of Outlook (2002) everything seems just fine. This is happening with mulitple users.  on mulitple pc's.  All using a newer version of Outlook..
degoodwinAsked:
Who is Participating?
 
degoodwinAuthor Commented:
Yes I have done that. As I said this is happening on MULTIPLE computers on MULTIPLE accounts.  so the chances that 8 different accounts and 8 different OST's are all messed up exactly the same is pretty slim
0
 
ash007Commented:
Can u brief error in application logs?..
0
 
AshwinRaj111Commented:
Does the Outlook have Third Party Add-Ins.
What happens with Outlook in Online Mode?

If the user keeps his Outlook Profile in Online Mode and check the Calendar does the Calendar Item disappear from OWA.

Also once the Calendar Item disappears in OWA does it show in Cached Outlook anymore?

Looks like a corruption in the Mailbox Calendar. Every Time you open the Outlook in Cache mode the Sync of .OST file and Mailbox corrupts the Mailbox.
Try moving the Users Mailbox to another Database and then check if it shows the same behaviour.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
degoodwinAuthor Commented:
There is no error in the app log.  It is happening on multiple mailboxes on one exchange server so it isnt corruption on a single mailbox.  If I use Outlook with Cached Mode turned off it is ok. However 10 of the users are sales force and run Outlook on laptops that travel and need to run in cached mode.
0
 
AshwinRaj111Commented:
Have you tried deleting the OST file on the Outlook and then creating a new Profile in Cache Mode.
0
 
AshwinRaj111Commented:

From what i can think of is a Database Corruption where Multiple Mailboxes are corrupted.
You could always try to move a Mailbox to another Database which would eliminate corruption of that Mailbox and then configure a new Profile and see if you get the same problem for that Mailbox.
0
 
degoodwinAuthor Commented:
The Problem was with autodiscovery on the IIS server and Excahnge 2007. The autodiscovery was corrupt. Once that was fixed everything started working again.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.