[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 450
  • Last Modified:

Remote Desktops - you can login but no Desktop is displayed - Windows XP Pro SP3

I can get a Remote Desktops session going, and enter an account name, and password,  but after clicking on the OK button, no desktop is displayed, it just seems to hang, and then the session is disconnected.

The pc I'm using to initiate the session is running Windows XP Pro SP3, the target pc is also running Windows XP Pro SP3.  Their both in a Windows domain, the domain controller is running Windows 2003 R2 Standard.

Anyone have a suggestion on a fix for this problem?  If you need additional info let me know.
0
mobot
Asked:
mobot
  • 3
  • 3
  • 2
  • +2
5 Solutions
 
agengler11Commented:
Run This Command:            
mstsc /console /v:[server's IP] 

Open in new window

0
 
ProgSysAdminCommented:
How do you know that you are logged in if you don't see the remote desktop?
0
 
John JenningsOwnerCommented:
First and foremost, ensure that Remote Desktop is enabled for that particular machine (the target):

http://www.microsoft.com/windowsxp/using/mobility/getstarted/remoteintro.mspx

Secondly, you're going to want to verify that port 3389 is allowed through your Windows Firewall. You can verify this by following steps in the link listed above.

Finally, the last thing you'll need to check (if applicable) is port forwarding on any routers between the two machines. If these two PCs are on the same network subnet (i.e. - small business or home network) then this should not be an issue.

Check these things out, and then let me know if you find anything out of the normal, or have any other questions.
0
Visualize your virtual and backup environments

Create well-organized and polished visualizations of your virtual and backup environments when planning VMware vSphere, Microsoft Hyper-V or Veeam deployments. It helps you to gain better visibility and valuable business insights.

 
SirtenKenCommented:
Try recreating the profile of the account you're logging into on the target computer. Works for terminal servers 90% of the time.
0
 
mobotAuthor Commented:
agengler11 - What pc should I run the cmd on?  When I run that cmd it opens up a Remote Desktop session to the server.

Prosysadmin and everyone else - Your right, my bad, I'm not getting logged in.  I went to the pc and saw that the name of the account I'm using to login, as being the last user to login, so I thought I was getting logged in, further testing shows that's not the case.

JohnThePro - Remote Desktop is enabled, the Windows Firewall is turned off. The pc's are in different vlans, I need to try and get a remote desktop session going into a different pc in the same vlan.

SirtenKen - I've deleted the profile and logged in to recreate it, but no joy.

I'm going to try and Remote Desktop into another pc in the same vlan as this one, and I'll get back to you guys.
0
 
John JenningsOwnerCommented:
Different VLANs?

By default, a VLAN is for exactly the purpose of segregating network traffic. Unless explicit declared on the network device hosting the VLAN, you cannot pass the traffic through from one to the other.

I'm kinda assuming you already did this, though. If not, you'll need to.

0
 
John JenningsOwnerCommented:
Some networking equipment will even allow you to do this on a per-port basis, enabling certain ports on the switch to reside on mulitple VLANs.
0
 
SirtenKenCommented:
Do you have a BroadCom NIC? There have been RDP problems associated with the LSO setting, which you may want to disable:

From the Broadcom Gigabit Ethernet Teaming Services: Broadcom NetXtreme II™ Network Adapter User Guide:

"Large Send Offload (LSO) is a feature provided by Broadcom network adapters that prevents an upper level protocol such as TCP from breaking a large data packet into a series of smaller packets with headers appended to them. The protocol stack need only generate a single header for a data packet as large as 64 KB, and the adapter hardware breaks the data buffer into appropriately-sized Ethernet frames with the correctly sequenced header (based on the single header originally provided)."

Reference: http://www.petri.co.il/network-issues-with-windows-server-2008-rdp-on-dell-servers.htm
0
 
agengler11Commented:
Run the command on your PC you are using to connect to the remote PC.
0
 
mobotAuthor Commented:
Guys - one of our Desktop techs came up with the solution after some googling.  This registy hack is what fixed it.  Hope this helps somebody else.

Reolved RDP issue of opening the desktop session. It was a video issue. For Nvidia there is registry setting
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management]

"SessionImageSize"=dword:00000020

Where 00000020 is hex for 32
0
 
mobotAuthor Commented:
I'll split the points, I appreciate everyone trying to help us out here.  Some obsure Nvidia registry hack never occurred to me.  Thanks guys.
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

  • 3
  • 3
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now