?
Solved

Bonding (2) T1's on single VWIC

Posted on 2010-11-18
18
Medium Priority
?
728 Views
Last Modified: 2012-05-10
Hello, I have a brand new CISCO 3900 router that I need to connect up (2) T1's in a single VWIC.  We have a single VWIC with (2) T1 ports.   Our ISP installed a new 3MB circuit, but it came with 2 individual T1's.   I need to bond both T1's together in a single serial interface card, but I'm not sure of how.  Shover is below:


Cisco IOS Software, C3900 Software (C3900-UNIVERSALK9-M), Version 15.0(1)M1,
RELEASE SOFTWARE (fc1)
0
Comment
Question by:Nole_Fan
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
18 Comments
 
LVL 14

Expert Comment

by:SIM50
ID: 34168147
It would be something like this:

interface Multilink1
ip address IP_ADDRESS SUBNET_MASK
encapsulation ppp
ppp multilink
ppp multilink group 1

interface Serial0/0/0
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 1

interface Serial0/0/1
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 1
0
 

Author Comment

by:Nole_Fan
ID: 34168370
It looks like that is for using 2 serial cards.  Is that correct?  I've actually got 1 serial card, with 2 T1 interfaces.
0
 

Author Comment

by:Nole_Fan
ID: 34187770
1serial Card, with 2 T1's interfaces and 1 IP address.
0
Ransomware Attacks Keeping You Up at Night?

Will your organization be ransomware's next victim?  The good news is that these attacks are predicable and therefore preventable. Learn more about how you can  stop a ransomware attacks before encryption takes place with our Ransomware Prevention Kit!

 
LVL 14

Expert Comment

by:SIM50
ID: 34188041
You can look up their locations synthax by either looking in config or doing sh service-module.
0
 

Author Comment

by:Nole_Fan
ID: 34188054
I'm sorry, I dont know what that means
0
 
LVL 14

Expert Comment

by:SIM50
ID: 34188119
When you type "show service-module" in enabled mode, it will list all modules installed. Below is the example from my router that has T1 modules installed.

sh serv
Interface Serial0/0/0
Module type is T1/fractional
    Hardware revision is 1.0, Software revision is 001,
    Image checksum is 0xA691A0, Protocol revision is 0.1
Receiver has no alarms.
Framing is ESF, Line Code is B8ZS, Current clock source is line,
Fraction has 24 timeslots (64 Kbits/sec each), Net bandwidth is 1536 Kbits/sec.
<removed statistics for brievity>

Interface Serial0/1/0
Module type is T1/fractional
    Hardware revision is 1.0, Software revision is 001,
    Image checksum is 0xA691A0, Protocol revision is 0.1
Receiver has no alarms.
<removed statistics for brievity>
0
 

Author Comment

by:Nole_Fan
ID: 34188144
When I enter that command I get the error below.  % unknown command %  and it points to service-module.  this is running v15
0
 
LVL 14

Expert Comment

by:SIM50
ID: 34188165
Can you post your sanitized (without usernames & passwords) switch configuration?
0
 
LVL 14

Expert Comment

by:SIM50
ID: 34188187
Sorry, meant router configuration.
0
 

Author Comment

by:Nole_Fan
ID: 34188236

3725CLK#wr t
Building configuration...

Current configuration : 8475 bytes
!
! Last configuration change at 14:24:00 UTC Mon Nov 22 2010
!
version 15.0
no service timestamps debug uptime
no service timestamps log uptime
service password-encryption
!

!
card type t1 0 0
card type t1 0 1


!
controller T1 0/0/1
 cablelength long 0db
 channel-group 0 timeslots 1-24

!
!
!
!
interface GigabitEthernet0/0
 description
 ip address x.x.x.x x.x.x.x



!
interface Serial0/0/1:0
 description MPLS to USC
 bandwidth 3088
 ip address x.x.x.x x.x.x.x
 fair-queue

!
router eigrp 1
 distribute-list 1 out eigrp 1
 network x.x.x.x
 network x.x.x.x
 redistribute static
 auto-summary
!
ip forward-protocol nd
!
no ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!

Heres the code for the router with the static routes, eigrp, credentials, and security removed.  Were using s0/0/1 port for the 2 T1's.

Open in new window

0
 
LVL 14

Expert Comment

by:SIM50
ID: 34188739
controller T1 0/0/0
 cablelength long 0db
 channel-group 0 timeslots 1-24

interface Multilink1
 ip address IP_ADDRESS SUBNET_MASK
 encapsulation ppp
 ppp multilink
 ppp multilink group 1

interface Serial0/0/0:0
 no ip address
 encapsulation ppp
 ppp multilink
 ppp multilink group 1

interface Serial0/0/1:0
 no ip address
 encapsulation ppp
 ppp multilink
 ppp multilink group 1
0
 

Author Comment

by:Nole_Fan
ID: 34188851
Ok, that still looks like its using 2 separate serial interfaces.  

The card thats installed has 2 T1 slots in a single serial card (VWIC2-2MFT-T1/E1).   We installed a serial interface with 2 T1 interfaces, because the other serial interfaces are already in use.  

s0/0/0 has an independent backup line installed and s0/0/1 has the VWIC2-2MFT-T1/E1  installed.
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 1000 total points
ID: 34192399
controller T1 0/0/1
 cablelength long 0db
 channel-group 0 timeslots 1-24  <== this command creates the serial interface below

interface Serial0/0/1:0  <== the ":0" is the channel-group created above
 no ip address


If you have the 2-port VWIC, then you will have 2 controller interfaces:

controller T1 0/0/0
 cablelength long 0db
 channel-group 0 timeslots 1-24

interface serial 0/0/0:0
 ppp multilink
 ppp multilink group 1

controller T1 0/0/1
 cablelength long 0db
 channel-group 0 timeslots 1-24

interface serial 0/0/1:0
 ppp multilink
 ppp multilink group 1

0
 
LVL 5

Assisted Solution

by:group0
group0 earned 1000 total points
ID: 34365615
lrmoore's solution is the correct one here, you always have to configure the T1 controllers in order for the Serial interface to show up.  There is no such thing as bonding the 2 T1 into a single Serial interface, you have to use Multilink PPP (MLPPP) to bond them to the Multilink1 interface.  However, you cannot use MLPPP to bond the circuits unless:

1) both T1's terminate on the same router on the remote end, and
2) the other end is also configured for MLPPP

In other words, if it wasn't provisioned for bonding, configuring it to do so on your side will have no effect, or cause an outage.  Generally, a circuit provider will need to build out an entirely new set of physical circuits in order to convert 2 standalone circuits into multilink-capable.

If your circuits aren't provisioned for multilink, the best you can do is configure load-sharing per-packet, which will round-robin outgoing packets over each circuit, but again this has to be done on both ends for proper effect.
0
 
LVL 70

Expert Comment

by:Qlemo
ID: 34581080
This question has been classified as abandoned and is being closed as part of the Cleanup Program.  See my comment at the end of the question for more details.
0

Featured Post

Optimum High-Definition Video Viewing and Control

The ATEN VM0404HA 4x4 4K HDMI Matrix Switch supports 4K resolutions of UHD (3840 x 2160) and DCI (4096 x 2160) with refresh rates of 30 Hz (4:4:4) and 60 Hz (4:2:0). It is ideal for applications where the routing of 4K digital signals is required.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to set-up an On Demand, IPSec, Site to SIte, VPN from a Draytek Vigor Router to a Cyberoam UTM Appliance. A concise guide to the settings required on both devices
This article is in regards to the Cisco QSFP-4SFP10G-CU1M cables, which are designed to uplink/downlink 40GB ports to 10GB SFP ports. I recently experienced this and found very little configuration documentation on how these are supposed to be confi…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
In this brief tutorial Pawel from AdRem Software explains how you can quickly find out which services are running on your network, or what are the IP addresses of servers responsible for each service. Software used is freeware NetCrunch Tools (https…
Suggested Courses
Course of the Month14 days, 1 hour left to enroll

800 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question