Solved

Problem with SCCM Deployment after Computer boots into WIN PE via PXE

Posted on 2010-11-18
3
2,403 Views
Last Modified: 2013-11-21
I'm trying to deploy Windows 7 Enterprise using PXE boot.  Windows PE boots up but spontaneously restarts after ~30 seconds.  I've been able to use [F8] to spawn a command prompt within the PE session and I've confirmed that:
- it has a valid IP address
- it can acccess the local disk
- I can copy files from the PE session to a file server in the domain

I tried redefining the PXE service point cert and updating the boot images but it had no effect.

How can I track down what's wrong?

If it helps, here are the contents of the smsts.log file from a problem PE session:

<![LOG[LOGGING: Finalize process ID set to 776]LOG]!><time="15:47:36.316+000" date="11-18-2010" component="TSBootShell" context="" type="1" thread="780" file="tslogging.cpp:1489">
<![LOG[==============================[ TSBootShell.exe ]==============================]LOG]!><time="15:47:36.316+000" date="11-18-2010" component="TSBootShell" context="" type="1" thread="780" file="bootshell.cpp:963">
<![LOG[Succeeded loading resource DLL 'X:\sms\bin\i386\1033\TSRES.DLL']LOG]!><time="15:47:36.316+000" date="11-18-2010" component="TSBootShell" context="" type="1" thread="780" file="util.cpp:869">
<![LOG[Debug shell is enabled]LOG]!><time="15:47:36.316+000" date="11-18-2010" component="TSBootShell" context="" type="1" thread="780" file="bootshell.cpp:974">
<![LOG[Waiting for PNP initialization...]LOG]!><time="15:47:36.378+000" date="11-18-2010" component="TSBootShell" context="" type="1" thread="788" file="bootshell.cpp:59">
<![LOG[Booted from network (PXE)]LOG]!><time="15:47:36.378+000" date="11-18-2010" component="TSBootShell" context="" type="1" thread="788" file="configpath.cpp:198">
<![LOG[Found config path X:\sms\data\]LOG]!><time="15:47:36.378+000" date="11-18-2010" component="TSBootShell" context="" type="1" thread="788" file="bootshell.cpp:553">
<![LOG[Booting from removable media, not restoring bootloaders on hard drive]LOG]!><time="15:47:36.378+000" date="11-18-2010" component="TSBootShell" context="" type="1" thread="788" file="bootshell.cpp:564">
<![LOG[Executing command line: wpeinit.exe -winpe]LOG]!><time="15:47:36.378+000" date="11-18-2010" component="TSBootShell" context="" type="1" thread="788" file="bootshell.cpp:767">
<![LOG[Executing command line: X:\WINDOWS\system32\cmd.exe /k]LOG]!><time="15:47:37.314+000" date="11-18-2010" component="TSBootShell" context="" type="1" thread="780" file="bootshell.cpp:767">
<![LOG[The command completed successfully.]LOG]!><time="15:47:37.314+000" date="11-18-2010" component="TSBootShell" context="" type="1" thread="780" file="bootshell.cpp:850">
<![LOG[Successfully launched command shell.]LOG]!><time="15:47:37.314+000" date="11-18-2010" component="TSBootShell" context="" type="1" thread="780" file="bootshell.cpp:430">
<![LOG[The command completed successfully.]LOG]!><time="15:47:48.749+000" date="11-18-2010" component="TSBootShell" context="" type="1" thread="788" file="bootshell.cpp:850">
<![LOG[Starting DNS client service.]LOG]!><time="15:47:48.749+000" date="11-18-2010" component="TSBootShell" context="" type="1" thread="788" file="bootshell.cpp:597">
<![LOG[Executing command line: X:\sms\bin\i386\TsmBootstrap.exe /env:WinPE /configpath:X:\sms\data\]LOG]!><time="15:47:49.264+000" date="11-18-2010" component="TSBootShell" context="" type="1" thread="788" file="bootshell.cpp:767">
<![LOG[The command completed successfully.]LOG]!><time="15:47:49.264+000" date="11-18-2010" component="TSBootShell" context="" type="1" thread="788" file="bootshell.cpp:850">
<![LOG[==============================[ TSMBootStrap.exe ]==============================]LOG]!><time="15:47:49.295+000" date="11-18-2010" component="TSMBootstrap" context="" type="1" thread="1180" file="tsmbootstrap.cpp:1039">
<![LOG[Command line: X:\sms\bin\i386\TsmBootstrap.exe /env:WinPE /configpath:X:\sms\data\]LOG]!><time="15:47:49.295+000" date="11-18-2010" component="TSMBootstrap" context="" type="0" thread="1180" file="tsmbootstrap.cpp:1040">
<![LOG[Succeeded loading resource DLL 'X:\sms\bin\i386\1033\TSRES.DLL']LOG]!><time="15:47:49.295+000" date="11-18-2010" component="TSMBootstrap" context="" type="1" thread="1180" file="util.cpp:869">
<![LOG[Succeeded loading resource DLL 'X:\sms\bin\i386\TSRESNLC.DLL']LOG]!><time="15:47:49.311+000" date="11-18-2010" component="TSMBootstrap" context="" type="1" thread="1180" file="resourceutils.cpp:152">
<![LOG[Processor Is IA64: 0]LOG]!><time="15:47:49.311+000" date="11-18-2010" component="TSMBootstrap" context="" type="1" thread="1180" file="tsmbootstrap.cpp:1005">
<![LOG[PXE Boot with Root = X:\]LOG]!><time="15:47:49.311+000" date="11-18-2010" component="TSMBootstrap" context="" type="1" thread="1180" file="tsmbootstrap.cpp:921">
<![LOG[Executing from PXE in WinPE]LOG]!><time="15:47:49.311+000" date="11-18-2010" component="TSMBootstrap" context="" type="0" thread="1180" file="tsmbootstrap.cpp:936">
<![LOG[Loading TsPxe.dll from X:\sms\bin\i386\TsPxe.dll]LOG]!><time="15:47:49.311+000" date="11-18-2010" component="TSMBootstrap" context="" type="0" thread="1180" file="tsmbootstraputil.cpp:1319">
<![LOG[TsPxe.dll loaded]LOG]!><time="15:47:49.311+000" date="11-18-2010" component="TSPxe" context="" type="0" thread="1180" file="tsmbootstraputil.cpp:1329">
<![LOG[Device has PXE booted]LOG]!><time="15:47:49.311+000" date="11-18-2010" component="TSPxe" context="" type="0" thread="1180" file="tspxe.cpp:122">
<![LOG[Variable Path: \SMSTemp\2010.11.18.15.44.40.0001.{17B1C00C-9A43-48B9-9264-D91B14BEB6B2}.boot.var]LOG]!><time="15:47:49.311+000" date="11-18-2010" component="TSPxe" context="" type="0" thread="1180" file="tspxe.cpp:134">
<![LOG[Variable Key Len: 61]LOG]!><time="15:47:49.311+000" date="11-18-2010" component="TSPxe" context="" type="0" thread="1180" file="tspxe.cpp:141">
<![LOG[Succesfully added firewall rule for Tftp]LOG]!><time="15:47:49.342+000" date="11-18-2010" component="TSPxe" context="" type="0" thread="1180" file="fwopen.cpp:123">
<![LOG[Executing: X:\sms\bin\i386\smstftp.exe -i 10.150.156.26 get \SMSTemp\2010.11.18.15.44.40.0001.{17B1C00C-9A43-48B9-9264-D91B14BEB6B2}.boot.var X:\sms\data\variables.dat]LOG]!><time="15:47:49.342+000" date="11-18-2010" component="TSPxe" context="" type="0" thread="1180" file="tspxe.cpp:177">
<![LOG[Command line for extension .exe is "%1" %*]LOG]!><time="15:47:49.467+000" date="11-18-2010" component="TSPxe" context="" type="0" thread="1180" file="commandline.cpp:229">
<![LOG[Set command line: "X:\sms\bin\i386\smstftp.exe" -i 10.150.156.26 get \SMSTemp\2010.11.18.15.44.40.0001.{17B1C00C-9A43-48B9-9264-D91B14BEB6B2}.boot.var X:\sms\data\variables.dat]LOG]!><time="15:47:49.467+000" date="11-18-2010" component="TSPxe" context="" type="0" thread="1180" file="commandline.cpp:707">
<![LOG[Executing command line: "X:\sms\bin\i386\smstftp.exe" -i 10.150.156.26 get \SMSTemp\2010.11.18.15.44.40.0001.{17B1C00C-9A43-48B9-9264-D91B14BEB6B2}.boot.var X:\sms\data\variables.dat]LOG]!><time="15:47:49.467+000" date="11-18-2010" component="TSPxe" context="" type="1" thread="1180" file="commandline.cpp:805">
<![LOG[Process completed with exit code 0]LOG]!><time="15:47:49.514+000" date="11-18-2010" component="TSPxe" context="" type="1" thread="1180" file="commandline.cpp:1102">
<![LOG[Succesfully removed firewall rule for Tftp]LOG]!><time="15:47:49.514+000" date="11-18-2010" component="TSPxe" context="" type="0" thread="1180" file="fwopen.cpp:146">
<![LOG[Successfully downloaded pxe variable file.]LOG]!><time="15:47:49.514+000" date="11-18-2010" component="TSPxe" context="" type="1" thread="1180" file="tspxe.cpp:187">
<![LOG[we are booted using PXE]LOG]!><time="15:47:49.514+000" date="11-18-2010" component="TSPxe" context="" type="1" thread="1180" file="tsmediawizardcontrol.cpp:2242">
<![LOG[we are booted using PXE and we use a generated password]LOG]!><time="15:47:49.514+000" date="11-18-2010" component="TSPxe" context="" type="1" thread="1180" file="tsmediawizardcontrol.cpp:2247">
<![LOG[Loading Media Variables from "X:\sms\data\variables.dat"]LOG]!><time="15:47:49.529+000" date="11-18-2010" component="TSPxe" context="" type="1" thread="1180" file="tsremovablemedia.cpp:321">
<![LOG[CryptDecrypt (hKey, 0, 1, 0, pData, &dwDecryptedLen), HRESULT=80090005 (e:\nts_sms_fre\sms\framework\smscrypt\windes.cpp,185)]LOG]!><time="15:47:49.529+000" date="11-18-2010" component="TSPxe" context="" type="0" thread="1180" file="windes.cpp:185">
<![LOG[SMS::Crypto::DES::DecryptBuffer( (BYTE*)pszPassword, wcslen(pszPassword)*sizeof(WCHAR), encryptedBuffer.getBuffer(), encryptedBuffer.size(), pbDecryptedBuffer, dwDecryptedBufferSize ), HRESULT=80090005 (e:\nts_sms_fre\sms\framework\tscore\tsremovablemedia.cpp,386)]LOG]!><time="15:47:49.529+000" date="11-18-2010" component="TSPxe" context="" type="0" thread="1180" file="tsremovablemedia.cpp:386">
<![LOG[Verifying media password.]LOG]!><time="15:47:49.529+000" date="11-18-2010" component="TSPxe" context="" type="1" thread="1180" file="tsmediawizardcontrol.cpp:268">
<![LOG[Loading Media Variables from "X:\sms\data\variables.dat"]LOG]!><time="15:47:49.529+000" date="11-18-2010" component="TSPxe" context="" type="1" thread="1180" file="tsremovablemedia.cpp:321">
<![LOG[Found network adapter "Intel(R) PRO/100 VE Network Connection" with IP Address 10.100.105.206.]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSPxe" context="" type="0" thread="1180" file="tsmbootstraputil.cpp:434">
<![LOG[Loading Media Variables from "X:\sms\data\variables.dat"]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSPxe" context="" type="1" thread="1180" file="tsremovablemedia.cpp:321">
<![LOG[CryptDecrypt (hKey, 0, 1, 0, pData, &dwDecryptedLen), HRESULT=80090005 (e:\nts_sms_fre\sms\framework\smscrypt\windes.cpp,185)]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSPxe" context="" type="0" thread="1180" file="windes.cpp:185">
<![LOG[SMS::Crypto::DES::DecryptBuffer( (BYTE*)pszPassword, wcslen(pszPassword)*sizeof(WCHAR), encryptedBuffer.getBuffer(), encryptedBuffer.size(), pbDecryptedBuffer, dwDecryptedBufferSize ), HRESULT=80090005 (e:\nts_sms_fre\sms\framework\tscore\tsremovablemedia.cpp,386)]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSPxe" context="" type="0" thread="1180" file="tsremovablemedia.cpp:386">
<![LOG[Entering TSMediaWizardControl::GetPolicy.]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSPxe" context="" type="0" thread="1180" file="tsmediawizardcontrol.cpp:483">
<![LOG[Environment scope "Global\{51A016B6-F0DE-4752-B97C-54E6F386A912}" successfully created]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSPxe" context="" type="1" thread="1180" file="environmentscope.cpp:250">
<![LOG[Environment scope "Global\{BA3A3900-CA6D-4ac1-8C28-5073AFC22B03}" successfully created]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSPxe" context="" type="1" thread="1180" file="environmentscope.cpp:250">
<![LOG[Setting LogMaxSize to 1000000]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSPxe" context="" type="1" thread="1180" file="tsmediawizardcontrol.cpp:511">
<![LOG[Setting LogMaxHistory to 1]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSPxe" context="" type="1" thread="1180" file="tsmediawizardcontrol.cpp:512">
<![LOG[Setting LogLevel to 0]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSPxe" context="" type="1" thread="1180" file="tsmediawizardcontrol.cpp:513">
<![LOG[Setting LogEnabled to 1]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSPxe" context="" type="1" thread="1180" file="tsmediawizardcontrol.cpp:514">
<![LOG[Setting LogDebug to 1]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSPxe" context="" type="1" thread="1180" file="tsmediawizardcontrol.cpp:515">
<![LOG[Loading variables from the Task Sequencing Removable Media.]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSPxe" context="" type="1" thread="1180" file="tsmediawizardcontrol.cpp:535">
<![LOG[Loading Media Variables from "X:\sms\data\variables.dat"]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSPxe" context="" type="1" thread="1180" file="tsremovablemedia.cpp:321">
<![LOG[Setting _SMSMediaGuid TS environment variable]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSPxe" context="" type="1" thread="1180" file="tsmediawizardcontrol.cpp:552">
<![LOG[Setting _SMSTSBootMediaPackageID TS environment variable]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSPxe" context="" type="1" thread="1180" file="tsmediawizardcontrol.cpp:552">
<![LOG[Setting _SMSTSHTTPPort TS environment variable]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSPxe" context="" type="1" thread="1180" file="tsmediawizardcontrol.cpp:552">
<![LOG[Setting _SMSTSHTTPSPort TS environment variable]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSPxe" context="" type="1" thread="1180" file="tsmediawizardcontrol.cpp:552">
<![LOG[Setting _SMSTSIISSSLState TS environment variable]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSPxe" context="" type="1" thread="1180" file="tsmediawizardcontrol.cpp:552">
<![LOG[Setting _SMSTSLaunchMode TS environment variable]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSPxe" context="" type="1" thread="1180" file="tsmediawizardcontrol.cpp:552">
<![LOG[Setting _SMSTSMP TS environment variable]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSPxe" context="" type="1" thread="1180" file="tsmediawizardcontrol.cpp:552">
<![LOG[Setting _SMSTSMPPort TS environment variable]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSPxe" context="" type="1" thread="1180" file="tsmediawizardcontrol.cpp:552">
<![LOG[Setting _SMSTSMediaPFX TS environment variable]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSPxe" context="" type="1" thread="1180" file="tsmediawizardcontrol.cpp:552">
<![LOG[Setting _SMSTSPublicRootKey TS environment variable]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSPxe" context="" type="1" thread="1180" file="tsmediawizardcontrol.cpp:552">
<![LOG[Setting _SMSTSSiteCode TS environment variable]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSPxe" context="" type="1" thread="1180" file="tsmediawizardcontrol.cpp:552">
<![LOG[Setting _SMSTSUseFirstCert TS environment variable]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSPxe" context="" type="1" thread="1180" file="tsmediawizardcontrol.cpp:552">
<![LOG[Setting _SMSTSx64UnknownMachineGUID TS environment variable]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSPxe" context="" type="1" thread="1180" file="tsmediawizardcontrol.cpp:552">
<![LOG[Setting _SMSTSx86UnknownMachineGUID TS environment variable]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSPxe" context="" type="1" thread="1180" file="tsmediawizardcontrol.cpp:552">
<![LOG[sMPCert.size() > 0, HRESULT=80004005 (e:\nts_sms_fre\sms\client\tasksequence\tsmbootstrap\tsmediawizardcontrol.cpp,564)]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSPxe" context="" type="0" thread="1180" file="tsmediawizardcontrol.cpp:564">
<![LOG[No MP Certificates.]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSPxe" context="" type="3" thread="1180" file="tsmediawizardcontrol.cpp:564">
<![LOG[Exiting TSMediaWizardControl::GetPolicy.]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSPxe" context="" type="0" thread="1180" file="tsmediawizardcontrol.cpp:1108">
<![LOG[GetPolicy(), HRESULT=80004005 (e:\nts_sms_fre\sms\client\tasksequence\tsmbootstrap\tsmediawizardcontrol.cpp,2072)]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSPxe" context="" type="0" thread="1180" file="tsmediawizardcontrol.cpp:2072">
<![LOG[RunWizardForPXE(), HRESULT=80004005 (e:\nts_sms_fre\sms\client\tasksequence\tsmbootstrap\tsmediawizardcontrol.cpp,2402)]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSPxe" context="" type="0" thread="1180" file="tsmediawizardcontrol.cpp:2402">
<![LOG[oTSMediaWizardControl.Run( sMediaRoot, true, true ), HRESULT=80004005 (e:\nts_sms_fre\sms\client\tasksequence\tsmbootstrap\tsmbootstrap.cpp,937)]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSPxe" context="" type="0" thread="1180" file="tsmbootstrap.cpp:937">
<![LOG[Execute( eExecutionEnv, sConfigPath, sTSXMLFile, uBootCount, &uExitCode ), HRESULT=80004005 (e:\nts_sms_fre\sms\client\tasksequence\tsmbootstrap\tsmbootstrap.cpp,1106)]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSPxe" context="" type="0" thread="1180" file="tsmbootstrap.cpp:1106">
<![LOG[Exiting with return code 0x80004005]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSPxe" context="" type="1" thread="1180" file="tsmbootstrap.cpp:1118">
<![LOG[Execution complete.]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSBootShell" context="" type="1" thread="788" file="bootshell.cpp:624">
<![LOG[Finalizing logging from process 776]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSBootShell" context="" type="1" thread="788" file="tslogging.cpp:1736">
<![LOG[Finalizing logs to root of first available drive]LOG]!><time="15:47:49.560+000" date="11-18-2010" component="TSBootShell" context="" type="1" thread="788" file="tslogging.cpp:1578">
<![LOG[LOGGING: Setting log directory to "X:\SMSTSLog".]LOG]!><time="15:47:49.576+000" date="11-18-2010" component="TSBootShell" context="" type="1" thread="788" file="tslogging.cpp:1803">

0
Comment
Question by:Ian-Thomas
3 Comments
 
LVL 5

Expert Comment

by:bwoodall
ID: 34168330
The only error message in that log file is the following.

No MP Certificates.
0
 
LVL 8

Accepted Solution

by:
MarkieS earned 500 total points
ID: 34171107
0
 

Author Comment

by:Ian-Thomas
ID: 34190818
The problem was, indeed, related to WebDAV being present but not configured on Windows Server 2008 R2.  We walked through the process described here:

Use the following procedure to enable WebDAV and create an Authoring Rule for Windows Server 2008 and Windows Server 2008 R2

but found that it didn't actually manipulate the underlying xml file:

C:\Windows\System32\inetsrv\Config\Schema\WebDAV_Schema.xlm

So we made the changes to the file itself:

 <element name="properties">
   <attribute name="allowAnonymousPropfind" type="bool" defaultValue="true" />
   <attribute name="allowInfinitePropfindDepth" type="bool" defaultValue="true" />
   <attribute name="allowCustomProperties" type="bool" defaultValue="false" />

And then re-installed the SCCM Management Point.  It worked.

0

Featured Post

Live: Real-Time Solutions, Start Here

Receive instant 1:1 support from technology experts, using our real-time conversation and whiteboard interface. Your first 5 minutes are always free.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Remote Apps is a feature in server 2008 which allows users to run applications off Remote Desktop Servers without having to log into them to run the applications.  The user can either have a desktop shortcut installed or go through the web portal to…
Know what services you can and cannot, should and should not combine on your server.
Established in 1997, Technology Architects has become one of the most reputable technology solutions companies in the country. TA have been providing businesses with cost effective state-of-the-art solutions and unparalleled service that is designed…
With Secure Portal Encryption, the recipient is sent a link to their email address directing them to the email laundry delivery page. From there, the recipient will be required to enter a user name and password to enter the page. Once the recipient …

776 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question