Disable "Save As" and "Save" in Excel 2003

I have found numerous articles about how to disable the save as for a single workbook but i need to remove those features from excel entirely.  If I go to open up a new excel sheet i want the save functionally gone completely for every sheet opened.  My reason for this is due to using thin clients.  They run a software that is document controll software that contains read only excel sheets.  The problem is that you can click on save as and it will allow you to browse the network and find open shares.  This is not an option that i want.  I am using a windows 2008 r2 domain.  If there is a group policy that i can enable to kill network browsing that would work as well.  
Who is Participating?
pnrhaitConnect With a Mentor Commented:
Depending on what office suite you are using,, if 2003 download the adm files import to your gpo or if you are using office 2007 or 2010 download the admx & adm files and import to you gpo. I have applied the link below:

Office 2003: http://www.microsoft.com/downloads/en/details.aspx?familyid=ba8bc720-edc2-479b-b115-5abb70b3f490&displaylang=en

2007: http://www.microsoft.com/downloads/en/details.aspx?FamilyID=92d8519a-e143-4aee-8f7a-e4bbaeba13e7&displaylang=en

2010: http://www.microsoft.com/downloads/en/details.aspx?FamilyID=64b837b6-0aa0-4c07-bc34-bec3990a7956&displaylang=en

The steps are:

1. Create a new GPO and name it Excel Save disable
2. Right click on it and click edit
3. Under User Configuration right click over Administrative Templates and select Add/Remove Template
4. Hit add and browse to your template files that you downloaded and open the adm folder. Select ExcelXX for whatever suite you are using and hit ok
5. Close out of Add\Remove Templates
6. Expand you Excel Template and it should be under Excel Options -> Save is where you will locate the Save As gp
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
If users do not have permission to browse those shares then they would not see them if Access-based Enumeration was enabled on the root folder share.

In the Share & Storage Management console right click on the root folder share and Properties. Click the Advanced button and tick Access-based Enumeration. OK and OK.

Make sure your TS users are not allowed to have access to the share. What they do not have access to by permissions they will not see by AbE.

My suggestion would be to create an addin which will do the following

1) Remove "Save", "Save As" Icon
2) Disable "Ctrl +S"
3) Insert a code in the Workbook_BeforeSave to disable saving.

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Sorry didn't see MPECSInc's answer. Yes that is a brilliant option if you can do that. If not then do it via the addin...
AisinAutoAuthor Commented:
Hmm I will look into the Abe option.  I will respond to you again tomorrow.  Thanks.
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
There are other methods of tying down the TS/RDS users via Group Policy including doing such things as hiding drive letters, My Computer, hiding right click menus, menu items, and more.

We create and link any number of GPOs to specific OUs for user's TS environments.

Sorry then link your new gp to its correct OU or users
AisinAutoAuthor Commented:
I have it locked down tight, you cannot see anything in My Computer, but the little "Network" button appears in the save as menu.  That is what i am really trying to kill.
Then just use the gp above
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Make sure Network Discovery is disabled for users.

AisinAutoAuthor Commented:
Ok both of you are giving out good answers.  Let me do some good ol gpo editing fun here and see which one will fix this.
Swapnil NirmalConnect With a Mentor Manager, Audit AnalyticsCommented:
To enable the FileSaveBlock subkey settings, follow these steps:
Exit Excel.
For Excel 2003, install security update 933666 if it is not installed.
Click Start, click Run, type regedit in the Open box, and then click OK.
Locate and then click to select one of the following registry subkeys:

Excel 2007

Excel 2003

Note If the FileSaveBlock subkey does not exist, create it. To do this, follow these steps:
Click to select the Security subkey.
On the Edit menu, point to New, and then click Key.
Type FileSaveBlock, and then press ENTER.
On the Edit menu, point to New, and then click DWORD Value.
Type the DWORD name for the files that you want to restrict, and then press ENTER. For example, to restrict the .xls, .xla, .xlt, .xlm, .xlw, and .xlb file types, type BinaryFiles.
Right-click the DWORD name that you typed in step 6, and then click Modify.
In the Value data box, type 1, and then click OK.
On the File menu, click Exit to exit Registry Editor.

for more details visit http://support.microsoft.com/kb/945797/
AisinAutoAuthor Commented:
Thanks for the help on this.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.