Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 748
  • Last Modified:

CGI on IIS6 will not execute exe it will try to download instead

Hi,

We are setting up an application on server 2003 with IIS 6 we have created a site and the directories using port 82 we have allowed all unknown CGI and ISAPI to run and also created a "new web service extension" specifically for our exe and pointed it to the correct location. Whenever we try to browse to the site using port 82 we get error 404 or via port 80 it simply tries to downoload the exe.

Any thought please?
0
CompTroub
Asked:
CompTroub
  • 2
1 Solution
 
crawforditsCommented:
328360 How to enable and disable ISAPI extensions and CGI applications in
IIS
http://support.microsoft.com/?id=328360

328419 How To Add and Remove Web Service Extension Files in IIS 6.0
http://support.microsoft.com/?id=328419

If the folder containing the CGI has "Scripts and Executables" Execute
permissions and the CGI is enabled in Web Service Extensions, it will
execute on the server.

If you do not have "Scripts and Executables", then CGI will be downloaded.
If you do not enable CGI in Web Service Extensions, you will get 404.

Also please verify CGI.
0
 
CompTroubAuthor Commented:
that wa all done thanks. We figured it out. We had to create a virtual directory under the site and assign rights and the executable to that all is good.

thanks
0
 
CompTroubAuthor Commented:
Fixed myself
0

Featured Post

Veeam and MySQL: How to Perform Backup & Recovery

MySQL and the MariaDB variant are among the most used databases in Linux environments, and many critical applications support their data on them. Watch this recorded webinar to find out how Veeam Backup & Replication allows you to get consistent backups of MySQL databases.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now