Solved

Line Protocol down!

Posted on 2010-11-18
6
534 Views
Last Modified: 2012-05-10
I tried swapping out a 2621xm, with a wic T1 in it, for an 1841 with a T1 controller in it. I have done this several times.  When I plugged the 1841 into the smartjack, the serial interface came up, but line protocol did not

I had the interface configured exactly like the 2621xm. I called telco and verified the following:
linecode should be b8
framing should be esf
encoding should be ppp
we should clock on line (default)

Anyone have any ideas?
I am stumped. There is not much to this. The cable from smartjack to the t1 card is good, I know because I had to fail back to the 2621xm
aaa new-model

!

!

aaa authentication login local_auth local

!

aaa session-id common

no ip subnet-zero

no ip source-route

no ip gratuitous-arps

ip cef

!

!

!

!

no ip bootp server

ip domain list 

no ip domain lookup

ip domain name 

ip name-server 172.16.1.14

ip name-server 172.16.1.62

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

!

crypto pki trustpoint TP-self-signed-3366751035

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-3366751035

revocation-check none

rsakeypair TP-self-signed-3366751035

!

!

crypto pki certificate chain TP-self-signed-3366751035

certificate self-signed 01

  3082024F 308201B8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 33333636 37353130 3335301E 170D3130 31313136 32303033

  33365A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 33363637

  35313033 3530819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  810084D3 C4E08983 559280DA 1043B2E5 EF9D1BB6 EE98AC12 3B0DC3E0 898AF173

  840F1580 4E1D5D08 D31C0E09 B9780F4D CF31B9A6 981AEA52 ADA0C4F7 542129F1

  94199711 F31EB75F B1FAD2FB A45231ED 5673F713 9B188FAC 26A6C296 840E39AE

  4961CC3A 0F787AB6 8BBD8CAE 88EC18AE 16169B61 29609F23 16A04B29 027F1252

  3EAB0203 010001A3 77307530 0F060355 1D130101 FF040530 030101FF 30220603

  551D1104 1B301982 1742522D 4D504C53 2D43452E 63706B2E 6368706B 2E636F6D

  301F0603 551D2304 18301680 1418C976 97650FD3 34B2358D BE81A9D4 B54AC245

  83301D06 03551D0E 04160414 18C97697 650FD334 B2358DBE 81A9D4B5 4AC24583

  300D0609 2A864886 F70D0101 04050003 81810040 98CE916A 512FC78E B686137D

  09A23013 F8D6AC51 DE876600 6F82C7F6 DAC53B6B B7641813 10A14BAC 50249D6F

  272A84AE 06720F41 F7E47976 9D085517 32BD2D45 9B3B62F9 97EAD370 B51DF31B

  3F099B93 9E727820 A37E22AD BB038E9A F368EDDB B3A40353 ED345FBD FB1A5241

  3B75CC5C 08B55625 DB65616B D3A75920 88B9E7

  quit



!

!

controller T1 0/0/0

framing esf

linecode b8zs

cablelength long 0db

channel-group 0 timeslots 24

!

!

class-map match-any VOICE

match ip dscp ef

match ip precedence 5

class-map match-any VOICE_SIGNALING

match ip precedence 3

match ip dscp af31

class-map match-any in-LAN

match access-group 101

!

!

policy-map VOIP_WAN

class VOICE

  priority percent 40

class VOICE_SIGNALING

  bandwidth percent 15

class class-default

  fair-queue

  random-detect

policy-map QoS-Policy

  description ***** Ensured Marking *****

class in-LAN

  set ip dscp ef

!

!

!

!

!

interface FastEthernet0/0

description ***Physical interface for voice and data***

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.1

description ***Data network***

encapsulation dot1Q 1 native

ip address 172.16.21.1 255.255.255.0

ip helper-address 172.16.1.14

!

interface FastEthernet0/0.2

description ***Voice network***

encapsulation dot1Q 22

ip address 172.16.22.1 255.255.255.0

ip helper-address 172.16.1.14

service-policy input QoS-Policy

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Serial0/0/0:0

description Connection to Qwest

ip address 63xxxxxxx2 255.255.255.252

ip flow ingress

ip flow egress

encapsulation ppp

max-reserved-bandwidth 100

Open in new window

BR-MPLS-CE#sh int s0/0/0:0

Serial0/0/0:0 is up, line protocol is down

  Hardware is GT96K Serial

  Description: Connection to Qwest

  Internet address is 6xxxxxxx2/30

  MTU 1500 bytes, BW 64 Kbit/sec, DLY 20000 usec,

     reliability 246/255, txload 1/255, rxload 1/255

  Encapsulation PPP, LCP REQsent, loopback not set

  Keepalive set (10 sec)

  Last input never, output 00:00:01, output hang never

  Last clearing of "show interface" counters 00:33:42

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: Class-based queueing

  Output queue: 0/1000/64/0 (size/max total/threshold/drops)

     Conversations  0/1/16 (active/max active/max total)

     Reserved Conversations 1/1 (allocated/max allocated)

     Available Bandwidth 30 kilobits/sec

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     0 packets input, 0 bytes, 0 no buffer

     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

     7 input errors, 7 CRC, 6 frame, 6 overrun, 0 ignored, 2 abort

     10 packets output, 140 bytes, 0 underruns

     0 output errors, 0 collisions, 1 interface resets

     0 unknown protocol drops

     0 output buffer failures, 0 output buffers swapped out

     1 carrier transitions

  Timeslot(s) Used:24, SCC: 0, Transmitter delay is 0 flags

BR-MPLS-CE#sh log

Open in new window

Here is the existing 2621xm config

interface Serial0/0
 description Connection to Qwest MPLS Router
 ip address 6xxxxx 2 255.255.255.252
 no ip redirects
 ip flow ingress
 ip flow egress
 encapsulation ppp
 service-module t1 timeslots 1-24
 max-reserved-bandwidth 100
 service-policy output VOIP_WAN

Open in new window

0
Comment
Question by:orus
  • 4
  • 2
6 Comments
 

Author Comment

by:orus
ID: 34170017
here is sh controller t1. note that it is not connected to anything right now



BR-MPLS-CE#sh controller t1
T1 0/0/0 is down.
  Applique type is Channelized T1
  Cablelength is long 0db
  Transmitter is sending remote alarm.
  Receiver has loss of signal.
  alarm-trigger is not set
  Soaking time: 3, Clearance time: 10
  AIS State:Clear  LOS State:Clear  LOF State:Clear
  Version info Firmware: 20071011, FPGA: 13, spm_count = 0
  Framing is ESF, Line Code is B8ZS, Clock Source is Line.
  CRC Threshold is 320. Reported from firmware  is 320.
  Data in current interval (15 seconds elapsed):
     0 Line Code Violations, 0 Path Code Violations
     0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
     0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 15 Unavail Secs
  Total Data (last 26 15 minute intervals):
     8219 Line Code Violations, 2 Path Code Violations,
     3 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins,
     2 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 23309 Unavail Secs
BR-MPLS-CE#
0
 
LVL 9

Accepted Solution

by:
Anton74 earned 500 total points
ID: 34170484
Is "Cablelength is long" correct? If not try executing "cablelength short" command.
0
 

Author Comment

by:orus
ID: 34172095
Yes thats what the original router had.  Cable is 6 ft
0
Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

 
LVL 9

Expert Comment

by:Anton74
ID: 34172177
"long" does not sound correct for a 6ft cable, I'd switch it to short to see if that helps.
0
 

Author Comment

by:orus
ID: 34233616
here was the issue:

controller T1 0/0/0

framing esf

linecode b8zs

cablelength long 0db

channel-group 0 timeslots 24

instead of 1-24, i put just 24
0
 

Author Closing Comment

by:orus
ID: 34233621
did not catch mistake
0

Featured Post

Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Suggested Solutions

New Server 172.16.200.2  was moved from behind Router R2 f0/1 to behind router R1 int f/01 and has now address 172.16.100.2. But we want users still to be able to connected to it by old IP. How to do it ? We can used destination NAT (DNAT).  In DNAT…
There are two basic ways to configure a static route for Cisco IOS devices. I've written this article to highlight a case study comparing the configuration of a static route using the next-hop IP and the configuration of a static route using an outg…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now