Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win


RDP Print issue connected to a Windows 2008 Std SP2 32-bit Server

Posted on 2010-11-18
Medium Priority
Last Modified: 2013-11-21
I working on a clients newly configured Windows 2008 32-bit server with SP2 applied.  Local printers print fine, regardless if they are network printers or shared on a workstation.  When users remote in with RDP into a Terminal Server session their printers on the remote end auto-create properly on the server.  When a print job is sent to the session printer, it appears in the queue and disappears, but nothing prints.  

When I tried to pause the remote printer in the RDP session to do testing, I receive the bang message:  Operation could not be completed (Error 0x00000005). Access is denied.

I then reviewed the event log and found the following message:

Log Name:      System
Source:        Microsoft-Windows-PrintSpooler
Date:          11/18/2010 8:25:04 PM
Event ID:      6161
Task Category: None
Level:         Error
Keywords:      Classic
User:          BEB\Staff5
Computer:      SERVER1.BEB.local
The document Test Page, owned by Staff5, failed to print on printer HP LaserJet 4100 Series PCL6 (redirected 1). Try to print the document again, or restart the print spooler.
Data type: RAW. Size of the spool file in bytes: 138349. Number of bytes printed: 0. Total number of pages in the document: 1. Number of pages printed: 0. Client computer: \\SERVER1. Win32 error code returned by the print processor: 5. Access is denied.

Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <Provider Name="Microsoft-Windows-PrintSpooler" Guid="{e4c60dfa-ecc5-4889-b406-e9ddd38463c8}" EventSourceName="Print" />
    <EventID Qualifiers="49152">6161</EventID>
    <TimeCreated SystemTime="2010-11-19T02:25:04.000Z" />
    <Correlation />
    <Execution ProcessID="0" ThreadID="0" />
    <Security UserID="S-1-5-21-3199217662-775032281-2980391550-1111" />
    <Data Name="param1">Test Page</Data>
    <Data Name="param2">Staff5</Data>
    <Data Name="param3">HP LaserJet 4100 Series PCL6 (redirected 1)</Data>
    <Data Name="param4">RAW</Data>
    <Data Name="param5">138349</Data>
    <Data Name="param6">0</Data>
    <Data Name="param7">1</Data>
    <Data Name="param8">0</Data>
    <Data Name="param9">\\SERVER1</Data>
    <Data Name="param10">5</Data>
    <Data Name="param11">Access is denied.

This looks like a rights issue, but I'm logged in as the Administrator.  The same issue occurs with other user accounts as well, regardless if they are admin priv or not.

Does anyone know what this might be caused by before I call Microsoft and open a ticket with them?

Thank you.
Question by:evolutionjeff
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
LVL 10

Expert Comment

ID: 34170123
Have you tried redirecting their default printer from the TS server? ie.

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default\Addins\RDPDR]

Now only their local default printer shows on the TS for printing. They have their own rights locally to print, right? Their default printer can be a networked printer or usb printer.

Author Comment

ID: 34170175
No, I have not made any registry changes.  Plus remote users still need to see the printers on the local LAN as well.  This "should" just work as is.  Again, it's a newly setup Windows 2008 server that the client did.  It appears that AD is loaded properly, the only real error I see in the event log is the event ID I listed.

I even setup a HP4100 printer definition on my remote PC of which I am the administrator and paused it, then logged into the Terminal Server session, the printer auto-created, but still cannot print to it.  Same errors if I try to pause the session printer it created.  
LVL 17

Accepted Solution

Spike99 earned 500 total points
ID: 34174291
If you look at the error you got, the last line says "Access is denied."

So, I would check permissions on the SPOOL folder.  Other people have had the same issue on 2008 servers and have solved it by granting users rights to the system32\spool folder on the server.

Here is one EE post with an accepted answer on the very same issue:

I hope this helps.


Author Comment

ID: 34175911
Yes, I saw the access is denied message, which is why I thought it was a rights or permissions issue.  I had already changed the permissions of the SPOOL directory to allow full control by the Users group and Print Operators group, which the users were members of as well as the Administrator user.  

I just changed it to include implicitly each user and administrator and gave each user full control and I was then able to print remotely.  That seemed to do the trick, but I'm not all that happy that I had to do this step to get it to work.

I had searched for this issue on this site and didn't find it for some reason.  Thanks for the heads up and helping me with the issue!!

LVL 17

Expert Comment

ID: 34198880
No problem! I'm always happy to help out.

Thanks for the points! :-D

Featured Post

Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Remote Apps is a feature in server 2008 which allows users to run applications off Remote Desktop Servers without having to log into them to run the applications.  The user can either have a desktop shortcut installed or go through the web portal to…
This article explains how to install and use the NTBackup utility that comes with Windows Server.
This tutorial will show how to push an installation of Backup Exec to an additional server in both 2012 and 2014 versions of the software. Click on the Backup Exec button in the upper left corner. From here, select Installation and Licensing, then I…
This tutorial will walk an individual through locating and launching the BEUtility application and how to execute it on the appropriate database. Log onto the server running the Backup Exec database. In a larger environment, this would generally be …

597 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question