Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 5514
  • Last Modified:

PsExec could not start

I am trying to use PSEXEC to execute a file on a local machine... I have the file placed in the c:\ of the computer that I am running psexec on... When I type in the command I get the following message....

D:\>dir d:\t.cmd
 Volume in drive D is DATA
 Volume Serial Number is 3897-F764

 Directory of d:\

11/18/2010  03:46p                   6 t.cmd
               1 File(s)              6 bytes
               0 Dir(s)   9,518,014,464 bytes free

D:\>psexec.exe D:\t.cmd

PsExec v1.42 - execute processes remotely
Copyright (C) 2001-2003 Mark Russinovich
www.sysinternals.com


PsExec could not start D:\t.cmd on DBMS-PHK1:
The system cannot find the file specified.

I've verified the file name is correct ... however it says that it can't be found? any help would be greatly appreciated!!
0
Itai_Argoetti
Asked:
Itai_Argoetti
  • 5
  • 4
  • 2
  • +2
1 Solution
 
NarendraGCommented:

This tool only designed to execute process remotely

or try using network path

\\localpc\d\t.cmd

Good Luck
0
 
SacTechGroupCommented:
shouldnt that be \\localhost

Anyhow psexec WILL execute on a local machine when no computer name is provided

It is stated that the file to be executed is on C:\ but that path is never called.  If i had an executeable at say 'c:\myexe.exe' then my psexec command would look like [psexec c:\myexe.exe]

http://technet.microsoft.com/en-us/sysinternals/bb897553.aspx
0
 
arnoldCommented:
Why not execute the file d:\t.cmd?
I think the example above might have to reference d as an administrative share
\\DBMS-PHK1\d$\t.cmd  The issue could be that the t.cmd file is trying to executes something else that is not found based on the settings available in psexec.
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
Itai_ArgoettiAuthor Commented:
Some remarks:
1. This command run already for several months with no problem. Few days ago it stopped working.
2. I tried to resetart the server. Didn't help
0
 
arnoldCommented:
Check the DEP settings on the system, it appears that one of the MS updates changes it from Turn on DEP for essential windows programs and services only. to Turn on DEP  for all programs and services except those I select.
properties of my computer\advanced\performance settings\Data Execution Prevention


The question remains why not simply execute the d:\t.cmd.
use schtasks to schedule the running of this command if needed c:\windows\tasks.
0
 
SacTechGroupCommented:
In the description it statest the the file is in c:\ and that execution is taking place on the local machine.  Based on the example it seems there is a path issue.. Is it in c:\ or D:\  if it cant find it it wont run.

Ok it has been running?  by whom?  Looking at the dir output I see that t.cmd is 6 bytes.  What could possibly be in there that is only 6 bytes??  Can you edit the command and copy/paste its contents to this thread?  I have a feeling your command was corrupted.
0
 
Itai_ArgoettiAuthor Commented:
Arnold, I don't have this DEP option in my server. It's a W2000 server.
0
 
Itai_ArgoettiAuthor Commented:
In the description, by mistake I wrote that I'm placing the file on C:\ drive, but, as you can see in the rest of the description that it's on D:\...
0
 
arnoldCommented:
What about SacTechGroup's comment dealing with the contents of the t.cmd file being corrupted?
0
 
Itai_ArgoettiAuthor Commented:
Arnold, the "t.cmd" is a test file demonstrate the problem. I have the problem with any other files.
0
 
arnoldCommented:
What a are the commands that you are trying to execute?  YOu have to make sure that these commands are preceeded with the full path and can not assume that because you can run the command locally as written in t.cmd, that the command will be found when executed through psexec.
This deals with the %PATH% variable.
set the t.cmd with the following command:

echo "IT works"

and see if you have a different response.
0
 
YarnoSGCommented:
if you use the -c switch on psexec, it will copy the script to the target before trying to execute it.



Using the "D:\" in your command line is risky - the remote client might not have a D: drive.

try this:
psexec.exe  \\targetcomputer -c t.cmd
(from your d: drive) - it will copy your "t.cmd" script and then execute it.

0
 
Itai_ArgoettiAuthor Commented:
a
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 5
  • 4
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now