Solved

LINUX FTP SERVER HANGING

Posted on 2010-11-19
10
521 Views
Last Modified: 2012-05-10
My ftp server hangs an hour or so after booting. All the lights look normal. The server is a Compaq Proliant DL380 G2 running Linux Redhart  2.6.18-128.1.14.el5 #1 SMP. Only message I am getting with dmesg is as follows:

agpgart: unable to determine aperture size.
agpgart: agp_backend_initialize() failed.
agpgart-serverworks: probe of 0000:00:00.0 failed with error -22
agpgart: unable to determine aperture size.
agpgart: agp_backend_initialize() failed.
agpgart-serverworks: probe of 0000:00:00.1 failed with error -22
agpgart: ServerWorks CNB20HE is unsupported due to lack of documentation.
agpgart: ServerWorks CNB20HE is unsupported due to lack of documentation.

Please help me resolve this hanging issue.

Thank you in advance
0
Comment
Question by:kwahae
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 2
  • +1
10 Comments
 
LVL 2

Expert Comment

by:karthi4all
ID: 34171544
agpgart is a video related library..

Have you installed anything realated to video like X windows or using any gui environment like kde or gnome?

try disabling 'screen saver'

note: if you dont need gui disable the loading x windows system,
0
 

Author Comment

by:kwahae
ID: 34171707
Unfortunately this server was administered by another admin so I dont know what had changed. How do I disable the screen saver and disable the loading x windows?
0
 
LVL 2

Expert Comment

by:karthi4all
ID: 34171806
If you want Linux to boot in console mode (non-GUI) at startup.
You need to edit the /etc/inittab

before doing this, make a backup /etc/inittab
cp /etc/inittab /etc/inittab-bak

On the line
id:5:initdefault:

change the 5 to a 3
id:3:initdefault:

If you want to switch back to original config, just run
mv /etc/inittab-bak  /etc/inittab

For doing all this you should have root access
0
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 
LVL 2

Assisted Solution

by:karthi4all
karthi4all earned 333 total points
ID: 34171823
One thing do not try this , if you don't have command line knowledge of linux.

Try updating before all of this.....
0
 
LVL 2

Accepted Solution

by:
karthi4all earned 333 total points
ID: 34171852
Try updating the kernel and packages of your  linux distro before all of this.....

use

$>yum update
0
 

Author Comment

by:kwahae
ID: 34171940
Hi,

Please note that init level is already set to 3 and yum update is refusing with following messages:

[root@ftp httpd]# yum update
Loaded plugins: rhnplugin, security
There was an error communicating with RHN.
RHN support will be disabled.
Error communicating with server. The message was:
Connection refused
Skipping security plugin, no data
Setting up Update Process
Skipping security plugin, no data
Skipping security plugin, no data
No Packages marked for Update
[root@ftp httpd]#
0
 
LVL 6

Expert Comment

by:JRoyse
ID: 34178547

Three things,
#1 Has the memory been tested with Memtest86 or the like bootable cdrom?  Anytime a server hangs I really recommend checking memory.

#2 real easy - Update the BIOS!

#3Another is the video card chip s dead/dying.  Has this server been working for a long time properly prior to these errors?

Heat may have been an underlying cause?

You may be able to enter the bios and change/disable settings related to the AGP card, or add a new PCI video card to try to work-around this as a problem.  

There is a related problem I found on google if that helps.

http://www.linuxforums.org/forum/red-hat-fedora-linux/66421-initial-boot-problems.html
0
 

Author Comment

by:kwahae
ID: 34178943
The machine  has been working for a long time before. Will try the recommended  option and come back to you Monday.

Thanks
0
 
LVL 2

Expert Comment

by:RouterRat
ID: 35359765
I am having the same problem.

I didn't install desktop environment, only ssh server and base system.

I still get it my server is HP DL380 G2 6GB ram dial processor and it's Debian Squeeze.

0
 
LVL 2

Assisted Solution

by:RouterRat
RouterRat earned 167 total points
ID: 35359808
I just found the solution to this.

Go to F9 ROM baset setup utiity at the startup and choose your OS as Linux. Mine was other operating system.

Once you choose it everything worked.

Hope it fixes yours too.
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Little introduction about CP: CP is a command on linux that use to copy files and folder from one location to another location. Example usage of CP as follow: cp /myfoder /pathto/destination/folder/ cp abc.tar.gz /pathto/destination/folder/ab…
Introduction We as admins face situation where we need to redirect websites to another. This may be required as a part of an upgrade keeping the old URL but website should be served from new URL. This document would brief you on different ways ca…
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question