Solved

phpmyadmin login problem

Posted on 2010-11-19
3
757 Views
Last Modified: 2012-08-14
Dear Experts:

Installed phpmyadmin in rhel5 did manual config bycopying the config.sample.inc.php to config.inc.php edited and the same is attached for your reference

after this when open firefox explorer with localhost/phpmyadmin iam getting like the below
phpMyAdmin
Welcome to phpMyAdmin
Language
Log in
Username:
Password:
Cookies must be enabled past this point.
Cannot load mcrypt extension. Please check your PHP configuration.
---------------------------------------------------------------------------------------
Please help in
1.how  should i be able to login in the above
2. how to fix the mcrypt extension

Please help thanks in advance.
configincphp.txt
0
Comment
Question by:D_wathi
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 

Accepted Solution

by:
Fintel earned 250 total points
ID: 34171782
You can disable the mcrypt warning in the config.inc.php file.

mcrypt is not required to use phpmyadmin.

You have to change the $cfg['McryptDisableWarning'] variable in your config file.
0
 

Author Comment

by:D_wathi
ID: 34171798
Hi , i did a change in the auth_type like below changed cookie to config and
$cfg['Servers'][$i]['auth_type'] = 'config';

after this restart the httpd now opened the firewox with http:// locahost\phpmyadmin
still iam able to see  Cannot load mcrypt extension. Please check your PHP configuration. on the web page but able to login as root and the password.

Sir, if i try with the ipaddress of the system iam not getting webpage getting the error posted below
error
MySQL said: Documentation
#1045 - Access denied for user 'root'@'localhost' (using password: NO)

---------------------------------
please help me in the following:
1. how to make the phpmyadmin accessible with the ip address
2. Cookies must be enabled past this point.
3.Cannot load mcrypt extension. Please check your PHP configuration.
please help.






0
 
LVL 13

Assisted Solution

by:dsmile
dsmile earned 250 total points
ID: 34172237
1. It's not phpMyAdmin problem, it's mysql's

You need to grant permission for 'root' user to access MySQL DB from specific IP

Use this command in mysql console.

GRANT ALL ON *.* TO 'root'@'your host IP';

2. It's phpMyAdmin's error that the only fix is install another version (as far as I know).
If you use auth_type 'config' or 'http' then it won't be a problem anymore.

3. Read this

http://www.linuxforums.org/forum/red-hat-fedora-linux/44539-installing-mcrypt-what-do-work-php.html
0

Featured Post

How To Reduce Deployment Times With Pre-Baked AMIs

Even if we can't include all the files in the base image, we can sometimes include some of the larger files that we would otherwise have to download, and we can also sometimes remove the most time-consuming steps. This can help a lot with reducing deployment times.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article shows the steps required to install WordPress on Azure. Web Apps, Mobile Apps, API Apps, or Functions, in Azure all these run in an App Service plan. WordPress is no exception and requires an App Service Plan and Database to install
In part one, we reviewed the prerequisites required for installing SQL Server vNext. In this part we will explore how to install Microsoft's SQL Server on Ubuntu 16.04.
The viewer will learn how to dynamically set the form action using jQuery.
This tutorial will teach you the core code needed to finalize the addition of a watermark to your image. The viewer will use a small PHP class to learn and create a watermark.

617 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question