Wordpress 3.0 Multisite: dashboard works but sites don't? Domain wildcard problem? Apache one?

Hi,

I've installed Wordpress 3.0.1 on my Ubuntu server and enabled the multi-site functionality (in order to later migrate several WP blogs to one WP multi-site). So far, so good.

I'm accessing and managing the main site via http://wplinux.test.local/wp-admin. There everything works fine, I can add plugins, posts, pages, etc.

But when I want to actually view a post or a page (like http://wplinux.test.local/about/) I get errors since they can't be found!?

Also when accessing http://wplinux.test.local I get the standard Apache welcome page instead of the main WP site: "It works! This is the default web page for this server. The web server software is running but no content has been added, yet."

The same for subsites. I can access and manage them (example: http://test1.wplinux.test.local/wp-admin/) but get errors when I want to actually view a page like this one: http://test1.wplinux.test.local/2010/11/18/hello-world/

I get an 'this link seems to be broken' error ...

Here's what I did DNS wise:

I've created a new zone on my DNS server > test.local
I've added a new host: *.test.local mapped to 192.168.1.57 (my Ubuntu server) - as this page seems to suggest: http://codex.wordpress.org/Migrating_Multiple_Blogs_into_WordPress_3.0_Multisite (step 3)
I've added 'ServerAlias *.test.local' to the 'default' (actually '000-default' for some reason) file in /etc/apache2/

So ... where did I go wrong??

Thank you very much :)

Jerome

[added:

Also: Why do the additional sites get *.wplinux.test.local addresses? Shouldn't they get *.test.local addresses?]
XeronimoAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
jar3817Connect With a Mentor Commented:
It's the same issue, all of that relies on mod_rewrite for apache and it isn't setup right. Post your httpd.conf file so we can see how you have it setup.
0
 
jar3817Commented:
This is a problem with your modrewrite (in your .htaccess file). It's working for your dashboard because the /wp-admin location is a really in the filesystem and the /about url get rewritten to something like /?p=###. Try accessing the pages and posts by their id number instead to see if that works. You can change that in the dashboard under Settings - Permalinks.

Look in your apache error and access logs to see what's going on. You need to set "AllowOverride AuthConfig" in your httpd.conf file for the main site or the vhost that takes care of wordpress. I've seen problems with just allowing Authconfig, where you get a message about mod_rewrite not being allowed...if that's the case you need to change the AllowOverride to "all" rather than just "authconfig".

As for your last question, subdomain sites are created under the domain of the main wp site. If your main wp site is at "wplinux.test.local" then all subsites will be subsite.wplinux.test.local.
0
 
XeronimoAuthor Commented:
Hi,

Thanks so far but I've now reinstalled the whole thing using sub-directories instead of sub-domains. I thought that was easier ......

Yet it isn't really. When I try to access a sub-directory I've created on the main site (example: http://linuxwp.test.local/galileo/) I get an error telling me that this page/site does not exist ... Accessing the backend of that directory doesn't work either therefore :(

I once got this running on a Windows server with IIS but I'd like to have it on Ubuntu now.

Any other suggestions??

Thanks!
0
 
XeronimoAuthor Commented:
IIt's been indeed the mod_rewrite settings in the httpd.conf!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.