• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 919
  • Last Modified:

Excel 2007 opens blank sheet with every file


I have problem with one of our users. Each time he opens an Excel spreadsheet  (previously saved), he gets another new one in the background. This happens with every excel file so, as he is in finance, he ends up with a lot of blank open workbooks.

It also does it if you open Excel - Close the new sheet - Then Open a saved file. He will get the saved file and then Book1 appearing in the background.

Has anyone got any ideas how to stop this?

2 Solutions
Brad Sims, CCNANetwork AdministratorCommented:
It sounds like a Macro it setup to do this.  Have you checked the Macros?
Did the user recently upgrade the Office?

If yes then there is a possibility that there may be several XLStart folders. Please use the windows search utility to find for the number of XLStart folders.

We will take it from there.

Swapnil NirmalManager, Audit AnalyticsCommented:
is the additional blank file opening is named as personal.xlsb? if yes than your personal.xls workbook is not hidden.
to solve this. go to view tab, click on Hide when the file personal.xlsb is active. I hope it solves your problem.
further, delete all the excel files except personal.xlsb from the folder C:\Documents and Settings\<username>\Application Data\Microsoft\Excel\XLSTART. taking backup before deleting is recommended
Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Swapnil NirmalManager, Audit AnalyticsCommented:
What does your command line look like in Folder Options>File Types?

Go to Start>Settings>Control Panel>Folder Options>File Types

If using WinXP OS you would scroll down to .XLS then "Advanced">Open>Edit.

In Command line the path should be similar to this....


You must have the double quotes and the <space>/e prevents a new book from

Below have "use DDE" checked and this in the DDE message box....[open("%1")]

Application should read "Excel"(no quotes
piemckayAuthor Commented:

Thanks for all the comments.

John15-16 - No macros present.

SiddharthRout - It wasn't an upgrade, just straight installation of 2007. There are two XLSTART folders in Program Files and in the user's profile. Both are empty.

n_swapnil - As above the XLSTART folders are empty already. The Open command is


The DDE settyings are as you suggested. My own version of Excel has the settings you have written and has no problems. I have tried to remove the %1 at the end, but it keeps putting it back in when I close the menu. Very strange. Any way to reset these or delete and recreate it?

piemckayAuthor Commented:
Sorry edit to above it reads.


(Office 2k7)
Rory ArchibaldCommented:
Is he opening the files from within Excel, or by double-clicking in Explorer?
piemckayAuthor Commented:
It happens if he opens the files both ways.
piemckayAuthor Commented:
It was a mix of the two issues with an add in causing the problem of opening a new sheet, and also the file-open command was incorrect.

It wouldn't allow me to change settings so I just reinstalled office, which seemed to reset everything.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now