Solved

Cannont ping NLB 'full internet name' but can the IP

Posted on 2010-11-19
24
1,180 Views
Last Modified: 2012-08-13
We have 2 Windows 2008 R2  virtual servers running in Hyper V. We have NLB set up and working on those two virtual servers. I have set the NLB  and it is working fine, no errors etc. I can Ping the IP of the cluster, but cannot ping the clusters 'full internet name'

NLB 1: 192.168.89.x
NLB 2: 192.168.89.x
Cluster IP: 192.168.89.174
Cluster 'full internet name': Cluster136
Cluster Operation Mode: Multicast
Port Rules set to allow all on the 192.168.89.174 address
Firewall set to allow all NLB traffic through.

I have added an A record in DNS and also added a reservation in DHCP to the cluster IP and MAC.

I have had a 'google' and cant find anything that relates directly to this. I dont have an issue with it not being able to resolve the name if it doesnt affect what we are doing, however I am being asked the question as to why the name cant be resolved. Is this how NLB is or have I dont something wrong?

Help!

Cluster Settings
0
Comment
Question by:mattdsc
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 13
  • 10
24 Comments
 
LVL 23

Expert Comment

by:jakethecatuk
ID: 34172096
from another machine, can you do an 'nslookup cluster136' and get a result?

if you can, try ipconfig /flushdns and then try pinging by name again.
0
 

Author Comment

by:mattdsc
ID: 34172097
Forgot to add that the host server has one NIC
0
 

Author Comment

by:mattdsc
ID: 34172102
Thats another thing. The nslookup brings back a totally different name! I have checked DNS and done a cache clear and scavange and can confirm the name that is coming back doesnt exisit in DNS
0
NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

 
LVL 23

Expert Comment

by:jakethecatuk
ID: 34172105
also, if you do ping -a {ip address of cluster} - does it resolve the name?
0
 
LVL 23

Expert Comment

by:jakethecatuk
ID: 34172115
when you do the nslookup, is the DNS server that you added the record to giving the reply?

also, why are you using static DHCP reservation for this - seems an odd thing to do.
0
 

Author Comment

by:mattdsc
ID: 34172116
Jake; no it doesnt its bringing back that other name that isnt the cluster.
0
 

Author Comment

by:mattdsc
ID: 34172123
I added the static IP reservation to try and pin it down. If its the wrong thing to do, then I am happy to remove. Very new to this to be honest.
0
 
LVL 23

Expert Comment

by:jakethecatuk
ID: 34172131
personally, I would never have a cluster on a DHCP reservation - static IP's all the way.

going back to the nslookup, is the server that is replying with the wrong if the one you added the record to?
0
 

Author Comment

by:mattdsc
ID: 34172167
We have a DNS server within our development domain and 2 in our main back office. The DHCP is in our back office infrastructure, but all the relivant links and trusts in place.

I have just checked the DNS server set to the NLB server and it was incorrect, so I have changed this. I can now ping cluster136 and get a reply from the actual NLB server that is hosting the NLB.

However I cannot still ping from my own machine, which as it happens has the DNS set to the back office DNS server.

I think you are going to say I need to put an A record in the back office DNS server too??
0
 
LVL 23

Expert Comment

by:jakethecatuk
ID: 34172217
You've got it...
0
 

Author Comment

by:mattdsc
ID: 34172346
As the other DNS server is on a seperate domain (guess this is a different question) do I simply add an A record on that domain? As it will show it as the other domain but the correct IP? so as follows Cluster136.dev.local (this is set already and working fine on that domain) and the new one will be Cluster136.backoffice.local.

Thanks for your help Jake.
0
 
LVL 7

Expert Comment

by:ieden
ID: 34172453
You may need to do a search in your reverse lookup zone for 168.192.in-addr-arpa for the address and delete any other entries except the one for your server.
0
 

Author Comment

by:mattdsc
ID: 34172494
Thanks, have checked that reverse lookup area and there it was the old record. Ive deleted, but still unsure what record to add to the DNS on the back office domain.
0
 
LVL 23

Accepted Solution

by:
jakethecatuk earned 500 total points
ID: 34172546
if you want to reference the cluster by it's FQDN and not cause any other problems, create a new zone called 'cluster136.dev.local' and create a blank A record with the IP address in it.

doing it this way will avoid any problems trying to talk to dev.local
0
 

Author Comment

by:mattdsc
ID: 34172578
Cheers Jake, Primary, Secondry or Stub Zone?
0
 
LVL 23

Expert Comment

by:jakethecatuk
ID: 34172642
can your back office DNS servers see your dev domain DNS servers?

0
 

Author Comment

by:mattdsc
ID: 34172663
Yes and I have just connected to the dev DNS server via the DNS window
0
 
LVL 23

Expert Comment

by:jakethecatuk
ID: 34172691
if they can see each other then you could add dev.local as a secondary zone to your back office DNS servers.

if you do this, you will need to enable zone transfers on your dev.local dns server for the dev.local domain.
0
 

Author Comment

by:mattdsc
ID: 34172779
We do have forwarders setup to the dev domain from the back office. How can I tell if we have zone transfers already set?
0
 
LVL 23

Expert Comment

by:jakethecatuk
ID: 34172901
on the dev server, right click on the forward zone dev.local and choose properties.  one of the tabs is called 'Zone Transfers'.  It should be disabled by default - this is where you enable it.  you can enable it for any server, or just your back office DNS servers.
0
 

Author Comment

by:mattdsc
ID: 34172957
Ok I see, thanks. What options would I have if I didnt want to set that up?!
0
 
LVL 23

Expert Comment

by:jakethecatuk
ID: 34172984
if you don't want to do zone transfers...and you only want the cluster name to be available on your back office DNS servers, then create the zone as I described above (making it a primary zone).
if you want more than one DNS record for your dev.local domain, create a primary zone called dev.local and add the required records to it.
0
 

Author Comment

by:mattdsc
ID: 34172992
Awesome, thanks. I will try that.
0
 

Author Comment

by:mattdsc
ID: 34174563
I have tried every which way to add this and it says the dev.local and IP range is already there. I assume I now need to add 'cluster136.dev.local' and create a blank A record with the IP address in it. Is this done on the dev DNS or the back office? I did it on the back office and it said it failed
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Technology opened people to different means of presenting information, but PowerPoint remains to be above competition. Know why PPT still works today.
It’s been over a month into 2017, and there is already a sophisticated Gmail phishing email making it rounds. New techniques and tactics, have given hackers a way to authentically impersonate your contacts.How it Works The attack works by targeti…
Viewers will learn how to maximize accessibility options in an Excel workbook for users with accessibility issues.
The viewer will learn how to simulate a series of coin tosses with the rand() function and learn how to make these “tosses” depend on a predetermined probability. Flipping Coins in Excel: Enter =RAND() into cell A2: Recalculate the random variable…

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question