Solved

Exchange 2007 on SBS 2008

Posted on 2010-11-19
3
535 Views
Last Modified: 2012-05-10
Having just installed a new SBS2008 server clients are unable to set the Out Of Office and getting a message that the server is offline.  I have found the cause - the internal URL is incorrect and auto discovery is failing.  I am trying to enter the following command

Set-WebServicesVirtualDirectory -Identity "SERVERNAME\EWS (Default Web Site)" -InternalURL https://SERVERNAME/EWS/Exchange.asmx -ExternalURL https://mailserver.domain.co.uk -BasicAuthentication:$true

in the Exchange Management Shell but get the follwing error

Set-WebServicesVirtualDirectory : The operation could not be performed because
object 'SERVERNAME\EWS (Default Web Site)' could not be found on domain controller
 'TCE-SRV.ce.local'.
At line:1 char:32
+ Set-WebServicesVirtualDirectory <<<<  -Identity "SERVERNAME\EWS (Default Web Sit
e)" -InternalURL https://SERVERNAME/EWS/Exchange.asmx -ExternalURL https://mailser
ver.domain.co.uk -BasicAuthentication:$true
    + CategoryInfo          : NotSpecified: (0:Int32) [Set-WebServicesVirtualD
   irectory], ManagementObjectNotFoundException
    + FullyQualifiedErrorId : A894A82A,Microsoft.Exchange.Management.SystemCon
   figurationTasks.SetWebServicesVirtualDirectory

Surely im doing something very simple wrong?
0
Comment
Question by:PurpleJelly
  • 2
3 Comments
 
LVL 5

Accepted Solution

by:
prashubvp earned 500 total points
ID: 34172831
its unable to find the EWS directory
Try this command:

Set-WebServicesVirtualDirectory -Identity "EWS (Default Web Site)" -InternalURL https://SERVERNAME/EWS/Exchange.asmx -ExternalURL https://mailserver.domain.co.uk -BasicAuthentication:$true

Refer the below link

http://www.msexchange.org/articles_tutorials/exchange-server-2007/management-administration/configuring-exchange-server-2007-web-services-urls.html

0
 

Author Comment

by:PurpleJelly
ID: 34172970
Same error even with above command - any other suggestions?
0
 

Author Comment

by:PurpleJelly
ID: 34173098
Have now resolved

failed to notice when using the "Get-webservicesvirtualdirectory | fl identity,internalurl,externalurl" command it reported the following

SERVERNAME\EWS (SBS Web Applications) and not (Default Web Site)

Will award points
0

Featured Post

Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Need to create a list of users who are members of Remote Desktop Users 7 40
GPO on certain users 17 33
Restore a DC asap 11 36
Unable to hit site 2 23
Read this checklist to learn more about the 15 things you should never include in an email signature.
This article explains how to install and use the NTBackup utility that comes with Windows Server.
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…

685 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question