Solved

Exchange 2007 on SBS 2008

Posted on 2010-11-19
3
515 Views
Last Modified: 2012-05-10
Having just installed a new SBS2008 server clients are unable to set the Out Of Office and getting a message that the server is offline.  I have found the cause - the internal URL is incorrect and auto discovery is failing.  I am trying to enter the following command

Set-WebServicesVirtualDirectory -Identity "SERVERNAME\EWS (Default Web Site)" -InternalURL https://SERVERNAME/EWS/Exchange.asmx -ExternalURL https://mailserver.domain.co.uk -BasicAuthentication:$true

in the Exchange Management Shell but get the follwing error

Set-WebServicesVirtualDirectory : The operation could not be performed because
object 'SERVERNAME\EWS (Default Web Site)' could not be found on domain controller
 'TCE-SRV.ce.local'.
At line:1 char:32
+ Set-WebServicesVirtualDirectory <<<<  -Identity "SERVERNAME\EWS (Default Web Sit
e)" -InternalURL https://SERVERNAME/EWS/Exchange.asmx -ExternalURL https://mailser
ver.domain.co.uk -BasicAuthentication:$true
    + CategoryInfo          : NotSpecified: (0:Int32) [Set-WebServicesVirtualD
   irectory], ManagementObjectNotFoundException
    + FullyQualifiedErrorId : A894A82A,Microsoft.Exchange.Management.SystemCon
   figurationTasks.SetWebServicesVirtualDirectory

Surely im doing something very simple wrong?
0
Comment
Question by:PurpleJelly
  • 2
3 Comments
 
LVL 5

Accepted Solution

by:
prashubvp earned 500 total points
ID: 34172831
its unable to find the EWS directory
Try this command:

Set-WebServicesVirtualDirectory -Identity "EWS (Default Web Site)" -InternalURL https://SERVERNAME/EWS/Exchange.asmx -ExternalURL https://mailserver.domain.co.uk -BasicAuthentication:$true

Refer the below link

http://www.msexchange.org/articles_tutorials/exchange-server-2007/management-administration/configuring-exchange-server-2007-web-services-urls.html

0
 

Author Comment

by:PurpleJelly
ID: 34172970
Same error even with above command - any other suggestions?
0
 

Author Comment

by:PurpleJelly
ID: 34173098
Have now resolved

failed to notice when using the "Get-webservicesvirtualdirectory | fl identity,internalurl,externalurl" command it reported the following

SERVERNAME\EWS (SBS Web Applications) and not (Default Web Site)

Will award points
0

Featured Post

Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article explains in simple steps how to renew expiring Exchange Server Internal Transport Certificate.
Find out what you should include to make the best professional email signature for your organization.
This tutorial will walk an individual through locating and launching the BEUtility application to properly change the service account username and\or password in situation where it may be necessary or where the password has been inadvertently change…
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …

912 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now