Solved

Error updating a list item in workflow Moss 2007

Posted on 2010-11-19
7
705 Views
Last Modified: 2012-05-10
I'm having a problem with a formally stable workflow. New instances appear as 'stopped' for end users and as 'error' for myself as administrator. I havent made any changes as far as I can see to the wrokflow and the lists permissions seem not to have changed.

The error in list item message jumps around the workflow a bit too when i make minor edits, like adding Log statements.

Here are 2 examples of that


19/11/2010 12:50 Comment  Expense Workflow Starting  
19/11/2010 12:50 Error  System Account Error updating a list item List item not found 
19/11/2010 12:50 Comment  Step 1  
19/11/2010 12:50 Comment  Step 2  
19/11/2010 12:50 Comment  Step 3  
19/11/2010 12:50 Comment  Step 4  
19/11/2010 12:50 Comment  Step 5  
19/11/2010 12:50 Comment  Step 6  
19/11/2010 12:50 Error  System Account An error has occured in Approve Expenses. 

Open in new window


19/11/2010 12:57 Error  System Account  Error updating a list item List item not found 
19/11/2010 12:57 Comment  Expense Workflow Starting  
19/11/2010 12:57 Comment  Step 1  
19/11/2010 12:57 Comment  Step 2  
19/11/2010 12:57 Comment  Step 3  
19/11/2010 12:57 Comment  Step 4  
19/11/2010 12:57 Comment  Step 5  
19/11/2010 12:57 Comment  Step 6  
19/11/2010 12:57 Error  System Account An error has occured in Approve Expenses. 

Open in new window

Here I stick a Pausing for 1 min at the start:

19/11/2010 13:02 Comment  System Account Pausing for 1 minutes  
19/11/2010 13:05 Comment  System Account Pausing complete  
19/11/2010 13:05 Comment  Expense Workflow Starting  
19/11/2010 13:05 Comment  Step 1  
19/11/2010 13:05 Comment  Step 2  
19/11/2010 13:05 Comment  Step 3  
19/11/2010 13:05 Comment  Step 4  
19/11/2010 13:05 Comment  Step 5  
19/11/2010 13:05 Comment  Step 6  
19/11/2010 13:05 Error  System Account Error updating a list item List item not found 
19/11/2010 13:05 Error  System Account  An error has occured in Approve Expenses. 

Open in new window


Has anyone any tips on how i should go about diagnosing this issue?

I dont see how



0
Comment
Question by:egmckenna
  • 4
  • 3
7 Comments
 
LVL 17

Expert Comment

by:GreatGerm
ID: 34174274
This is always a good document:

http://office.microsoft.com/en-us/sharepoint-designer-help/troubleshoot-workflow-errors-HA010237912.aspx

What is the workflow doing after "Step 6" is commented?  Also, how many items are in the list (might be a timeout issue if too many)?
0
 

Author Comment

by:egmckenna
ID: 34174768
This aint going be fixed by no  'how to' on the microsoft site ;)
step 6 in which version of my workflow?

Theres no difference between each version  except for the positions of the Log statements.

Theres 1 update items command at the last step of the process
0
 
LVL 17

Accepted Solution

by:
GreatGerm earned 500 total points
ID: 34174876
Actually, the "how-to"s on the Microsoft sites are usually pretty good.  Don't discount them.

All three examples list an error after "Step 6" so does version really matter?

I can't see your workflow so I will need to know how you have that item update setup to be able to help.
0
SharePoint Admin?

Enable Your Employees To Focus On The Core With Intuitive Onscreen Guidance That is With You At The Moment of Need.

 

Author Comment

by:egmckenna
ID: 34187373
Well the error remark at the end is just a summary of the workflow errors, so you'll always have a  remark there as long as you have errors.

I think theres no problem with the workflow, its that somehow the list has become dissassociated from the permission structure in sharepoint.

Where the error occurs jumps around the workflow, regardless of changes made or not

Is there someway a list itself can become checked out?
0
 

Author Comment

by:egmckenna
ID: 34188782
when i rebuild the 2 sections below I can the same errors.

So this tell me at tleast the workflow is fine, its just that there is a permission issue of some kind with makes no sense to me as I am using a admin account. And this woirkflow was fine up till recently.
errors.JPG
0
 

Author Comment

by:egmckenna
ID: 34189886
+Pts
0
 
LVL 17

Expert Comment

by:GreatGerm
ID: 34193771
Not seeing where you're getting that it's a permission issue.  For either of the actions causing the issue can you please show me how it's identifying which item to update?
0

Featured Post

Instantly Create Instructional Tutorials

Contextual Guidance at the moment of need helps your employees adopt to new software or processes instantly. Boost knowledge retention and employee engagement step-by-step with one easy solution.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Sharepoint KB 2 87
SharePoint List Calculated Field 4 54
Sharepoint data after Hyper-V restore 4 27
REST call Failing 1 7
Work Over Net is a new and very powerful collaboration product. With its new easy interface it is becoming very competitive to other similar products like webex and office interactive. WON 2010 have the standard business tools needed for multi-offic…
Summary In SharePoint 2010 it is easy to create custom color themes to jazz up a site. Theme colors can also be created in PowerPoint 2010 with a few clicks. But how do the chosen colors actually look in the SharePoint site? The attached PowerPoint…
Attackers love to prey on accounts that have privileges. Reducing privileged accounts and protecting privileged accounts therefore is paramount. Users, groups, and service accounts need to be protected to help protect the entire Active Directory …

735 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question