?
Solved

Cannot connect to Novell's iMonitor

Posted on 2010-11-19
10
Medium Priority
?
2,024 Views
Last Modified: 2012-05-10
I am not able to get into my iMonitor on my OES2 box.  Everytime I try it tells me the webpage is not available.  I have tried starting and stopping Apache and Tomcat to no avail.  I can get into iManger just fine so I'm pretty sure Apache and Tomcat are working.  Any ideas!
0
Comment
Question by:usd431tech
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 3
10 Comments
 
LVL 3

Expert Comment

by:nlandas
ID: 34173347
Is the TCP port open through the firewall for iMonitor? What URL are you using to get there?

http://ipaddress:8008/nds or http://ipaddress:8028/nds
0
 
LVL 3

Expert Comment

by:nlandas
ID: 34173358
I think that 8030 is also used on some OS installs.

8028 for http and 8030 for https but I don't use it often.
0
 
LVL 18

Accepted Solution

by:
ZENandEmailguy earned 2000 total points
ID: 34173369
check to make sure the the novell-httpstk process is running.  Also look in the /etc/init.d directory and see if you see a novell-imonitor

I'd suggest cd /etc/init.d
ls novell-*  to see what init scripts start with novell-  

if you find the ones I mention, try

./novell-httpstk status (or restart)

then try to access iMonitor.

iMonitor is part of the Novell Remote Manager, and isn't controlled by Apache/Tomcat. Rather by the httpstk and possibly the portal init script or the imonitor init script.

Scott
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 

Author Comment

by:usd431tech
ID: 34174264
I checked the ./novell-httpstk status and it stated it was dead.  I was able to start it and then I am able to get to the login page.  As soon as I try to login it kills it.
0
 

Author Comment

by:usd431tech
ID: 34174359
The address I am using to get to the login page is https://dnsname:8009.  When I try the 8028 or the 8030 I get nothing.
0
 
LVL 18

Assisted Solution

by:ZENandEmailguy
ZENandEmailguy earned 2000 total points
ID: 34174606
Sounds like you may have expired certificates and as such it won't let you do anything.  Try the following, it won't hurt anything:

as root open a terminal prompt and:

ndsconfig upgrade

you'll need the admin username and context (cn=admin.o=itscontext)  and the admin password

This process will examine the SAS object and the KMO objects and refresh them if needed.

Once done and hopefully it will give the successful message, restart the novell-httpstk and see if it will work.
0
 

Author Comment

by:usd431tech
ID: 34174699
After running ndsconfig upgrade it gives this - ERROR:  ndsconfig return value=9.  I went ahead and restarted novell-httpstkd and same results.
0
 
LVL 18

Assisted Solution

by:ZENandEmailguy
ZENandEmailguy earned 2000 total points
ID: 34174726
Have you changed IP addresses on the box?

Look into the /etc/opt/novell/eDirectory/conf directory at the nds.conf and confirm all settings there are correct.

If they aren't, make a copy of the file and then edit to correct them.  Once done, restart the ndsd (which will close all connections to the server and potentially interrupt users so be aware.

There may also be a .conf file controlling the novell-httpstk but I can't remember and unfortunately don't have an OES box available to me to check.
0
 

Author Comment

by:usd431tech
ID: 34174771
It is working, I tried a different browser and port 8030 and it comes up fine.  Thanks for your help!
0

Featured Post

On Demand Webinar: Networking for the Cloud Era

Did you know SD-WANs can improve network connectivity? Check out this webinar to learn how an SD-WAN simplified, one-click tool can help you migrate and manage data in the cloud.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this blog post, we’ll look at how using thread_statistics can cause high memory usage.
Hey fellow admins! This time, I have a little fairy tale for you. As many tales do, it starts boring and then gets pretty gory. I hope you like it. TL;DR: It is about an important security matter, you should read it if you run or administer Windows …
In this video we outline the Physical Segments view of NetCrunch network monitor. By following this brief how-to video, you will be able to learn how NetCrunch visualizes your network, how granular is the information collected, as well as where to f…
How to fix incompatible JVM issue while installing Eclipse While installing Eclipse in windows, got one error like above and unable to proceed with the installation. This video describes how to successfully install Eclipse. How to solve incompa…
Suggested Courses

800 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question