Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 739
  • Last Modified:

ASP website not working in IIS7 on server 2008 SBS

I have a website done with ASP. The website works fine in 2000 server IIS5 and Server 2003 IIS6 and Server 2008 Standard with IIS7. However I am unable to get my Website to run on Server 2008 SBS.

I have the site set up as a virtual directory under the default website. I created an application pool too.

When trying to run the site I get the following error.

"An error occurred on the server when processing the URL. Please contact the system administrator. If you are the system administrator please click here to find out more about this error."

When I click on the "click here" it takes me to a help page about enabling ASP but  ASP is already enabled by default on SBS.

Any suggestions on how to get my site to work.
0
hstulberg
Asked:
hstulberg
  • 7
  • 4
1 Solution
 
Paul MacDonaldDirector, Information SystemsCommented:
Is the site configured for the proper version of the .Net Framework?  Can you browse the site from IIS itself, or does that error too.
0
 
hstulbergAuthor Commented:
The site is not in don net just ASP.
0
 
Paul MacDonaldDirector, Information SystemsCommented:
Is classic ASP enabled in IIS on your server?
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
hstulbergAuthor Commented:
Classic ASP is enabled.
0
 
Paul MacDonaldDirector, Information SystemsCommented:
Okay, can you browse the site from within IIS (right-click and "Browse")?  Do you get any other error messages?
0
 
hstulbergAuthor Commented:
I can brows to the home page which is a login page. That is where the error occurs. If i try to log in i ge the same error and that is as far as I can go.
0
 
Paul MacDonaldDirector, Information SystemsCommented:
Does the login page require SSL?  Is a certificate configured?  Does the login page require anything else (like an external component or somesuch) which might be missing?
0
 
hstulbergAuthor Commented:
SSL not required. Not sure what you mean buy an external compnent. If you mean a database for the login, its all there.
0
 
hstulbergAuthor Commented:
I have found a solution to the problem outside of Experts-Exchange.  I will post the solution next week.  It will definitely benefit the EE community.
0
 
hstulbergAuthor Commented:
I have found the following solution outside of expter exchange.

When you are installing WSUS, you can choose either installing WSUS on the Default Web Site or on a new Web Site.

The Scenario: Windows server 2008 R2 x64 with IIS 7.5, Default Web Site already has some Application deployed.

Ok, so your “dedicated” WSUS server already got some IIS application on it and yet, what with WSUS ? well.. you can choose in the wizard to install the WSUS on a new site with other port then the default 80 – port 8530 .

Everything goes fine and the WSUS is working perfectly. Oops – we have a problem ! – the application in the Default Web Site is not working anymore.

When you browse to the application you get Error 500.19 with the following details:

HTTP Error 500.19 – Internal Server Error
The requested page cannot be accessed because the related configuration data for the page is invalid. Module DynamicCompressionModule
Notification SendResponse
Handler StaticFile
Error Code 0x8007007e
Requested URL http://localhost:80/
Physical Path <some Path>
Logon Method Anonymous
Logon User Anonymous




To resolve this situation, review the ApplicationHost.config (locate it in under C:\windows\inetsrv\config). In the ApplicationHost.config find these lines :

<scheme name=”xpress” doStaticCompression=”false” doDynamicCompression=”true
dll=”C:\Windows\system32\inetsrv\suscomp.dll” staticCompressionLevel=”10?
dynamicCompressionLevel=”0? />

Found it ? okay, it’s time to deal the situation. run this executable with the following parameters: %windir%\system32\inetsrv\appcmd.exe set config -section:system.webServer/httpCompression /-[name='xpress']

This command will disable the suscomp.dll which is being installed by the WSUS. the compression schemes are defined globally and loaded in every application Pool. when WSUS x64 register this dll it will result this error when x64 version of suscomp.dll attempts to load in an application pool which is running in x32 mode.

If, from some any reason you want to enable the compression again, run this command : %windir%\system32\inetsrv\appcmd.exe set config -section:system.webServer/httpCompression /+[name='xpress',doStaticCompression='false',dll='%windir%\system32\inetsrv\suscomp.dll']
0
 
hstulbergAuthor Commented:
Found answer outside of expert exchange.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

  • 7
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now