Solved

blackberry will not connect to exchange owa but website works

Posted on 2010-11-19
22
1,769 Views
Last Modified: 2013-03-19
first time i am experiencing something like this.  We run exchange server 2007 in windows server 2008.  we have an ssl certificate on the website.  what happens is when we go to https://mail.company.com/owa from the web browser we have no problems at all logging in.  When I go to setup the account on a blackberry using the blackberry bis website.  i ienter in the same exact address, login info that i do on the website.  the owa website works 100% but sprint.blackberry.com tells me that the server address is not valid? is there any setting for this? anything to do with authentication, and iis settings? i have no clue i have looked everywhere.  I've been snooping around about this issue for about a week now and i'm just mindboggled by this.  I have connected many blackberries to exchange owa and this one tells me that server is invalid when in fact it is.  any ideas ?
0
Comment
Question by:SLEEPYAL
  • 10
  • 6
  • 3
  • +3
22 Comments
 
LVL 10

Expert Comment

by:ThorinO
ID: 34173967
Can you run the tests at http://www.testexchangeconnectivity.com and see if there are any errors?
0
 
LVL 6

Expert Comment

by:stavros41
ID: 34173968
May I ask why you have the blackberries configured this way? BES Express 5 is free and you can still use BIS to activate.
0
 

Author Comment

by:SLEEPYAL
ID: 34174054
i don't want to go through the process of installing bes express 5 its timely and the client doesn't want to pay for the man hour time.
0
Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
LVL 9

Expert Comment

by:dexIT
ID: 34174144
If you're connecting through OWA/Exchange method, could be something as simple as HTTP(S) <- which is missing. If it's only happening to one user then you should try removing the account and re-adding it.
0
 

Author Comment

by:SLEEPYAL
ID: 34174460
i am entering https and it is not for one user, it is for all users.
0
 

Author Comment

by:SLEEPYAL
ID: 34174579
this is me loggied into the owa website for this account this is me loggied into the owa website for this account
0
 

Author Comment

by:SLEEPYAL
ID: 34174591
this is sprint telling me that this server is not valid.
0
 
LVL 10

Expert Comment

by:ThorinO
ID: 34174608
Did you run the tests at http://www.testexchangeconnectivity.com/? 

Have you tried putting in the domain like domain\administrator
0
 

Author Comment

by:SLEEPYAL
ID: 34174670
i tried putting in the username as domain\username and that doesn't work. i posted images of whats happening.  which tests should i run on that website? http://www.testexchangeconnectivity.com/? 
all of them? which particular ones?
0
 
LVL 10

Expert Comment

by:ThorinO
ID: 34174677
Do the Microsoft Exchange ActiveSync Connectivity Tests  and Microsoft Office Outlook Connectivity Tests
0
 

Author Comment

by:SLEEPYAL
ID: 34174808
active synce test results

 ExRCA is testing Exchange ActiveSync.  
  Exchange ActiveSync was tested successfully.
   Test Steps
   Attempting to resolve the host name mail.pemconewarkdental.com in DNS.
  The host name resolved successfully.
   Additional Details
  IP addresses returned: 75.151.180.186
 
 Testing TCP port 443 on host mail.pemconewarkdental.com to ensure it's listening and open.
  The port was opened successfully.
 Testing the SSL certificate to make sure it's valid.
  The certificate passed all validation requirements.
   Test Steps
   Validating the certificate name.
  The certificate name was validated successfully.
   Additional Details
  Host name mail.pemconewarkdental.com was found in the Certificate Subject Common name.
 
 Validating certificate trust for Windows Mobile devices.
  The test passed with some warnings encountered. Please expand the additional details.
   Additional Details
  The certificate is only trusted on Windows Mobile 5.0 with the Messaging and Security Feature Pack and later versions. Windows Mobile 5.0 devices won't be able to sync. Root = E=info@valicert.com, CN=http://www.valicert.com/, OU=ValiCert Class 2 Policy Validation Authority, O="ValiCert, Inc.", L=ValiCert Validation Network
 
 Testing the certificate date to confirm the certificate is valid.
  Date validation passed. The certificate hasn't expired.
   Additional Details
  The certificate is valid. NotBefore = 11/19/2010 3:57:26 PM, NotAfter = 11/26/2012 2:50:55 PM
 
 
 
 Checking the IIS configuration for client certificate authentication.
  Client certificate authentication wasn't detected.
   Additional Details
  Accept/Require Client Certificates isn't configured.
 
 Testing HTTP Authentication Methods for URL https://mail.pemconewarkdental.com/Microsoft-Server-Activesync/.
  The HTTP authentication methods are correct.
   Additional Details
  ExRCA found all expected authentication methods and no disallowed methods. Methods found: Basic
 
 An ActiveSync session is being attempted with the server.
  Testing of an Exchange ActiveSync session completed successfully.
   Test Steps
   Attempting to send the OPTIONS command to the server.
  The OPTIONS response was successfully received and is valid.
   Additional Details
  Headers received: Allow: OPTIONS,POST
MS-Server-ActiveSync: 8.1
MS-ASProtocolVersions: 1.0,2.0,2.1,2.5,12.0,12.1
MS-ASProtocolCommands: Sync,SendMail,SmartForward,SmartReply,GetAttachment,GetHierarchy,CreateCollection,DeleteCollection,MoveCollection,FolderSync,FolderCreate,FolderDelete,FolderUpdate,MoveItems,GetItemEstimate,MeetingResponse,Search,Settings,Ping,ItemOperations,Provision,ResolveRecipients,ValidateCert
Public: OPTIONS,POST
Content-Length: 0
Cache-Control: private
Date: Fri, 19 Nov 2010 17:24:36 GMT
Server: Microsoft-IIS/7.0
X-AspNet-Version: 2.0.50727
X-Powered-By: ASP.NET

 
 
 Attempting the FolderSync command on the Exchange ActiveSync session.
  The FolderSync command completed successfully.
   Additional Details
  Number of folders: 16
 
 Attempting the initial sync to the Inbox folder. This initial sync won't return any data.
  The Sync command completed successfully.
   Additional Details
  Status: 1
 
 Attempting to test the GetItemEstimate command for the Inbox folder.
  ExRCA successfully received the GetItemEstimate response from the server.
   Additional Details
  Estimate: 3 messages
 
 
 
 
 
0
 
LVL 9

Expert Comment

by:dexIT
ID: 34174862
Please provide the results of your ActiveSync Tests. Try to connect without using "\OWA" and Fully Qualified Domain Name and not a prefix, domain.com\user opposed to domain\user
0
 
LVL 9

Expert Comment

by:dexIT
ID: 34174868
Active Sync appears to be working.
0
 

Author Comment

by:SLEEPYAL
ID: 34174869
heres the results of my office outlook anywhere tests

 
 Testing RPC/HTTP connectivity.
  The RPC/HTTP test failed.
   Test Steps
   Attempting to resolve the host name mail.pemconewarkdental.com in DNS.
  The host name resolved successfully.
   Additional Details
  IP addresses returned: 75.151.180.186
 
 Testing TCP port 443 on host mail.pemconewarkdental.com to ensure it's listening and open.
  The port was opened successfully.
 Testing the SSL certificate to make sure it's valid.
  The certificate passed all validation requirements.
   Test Steps
   Validating the certificate name.
  The certificate name was validated successfully.
   Additional Details
  Host name mail.pemconewarkdental.com was found in the Certificate Subject Common name.
 
 Certificate trust is being validated.
  The certificate is trusted and all certificates are present in the chain.
   Additional Details
  The certificate chain has been validated up to a trusted root. Root = OU=Go Daddy Class 2 Certification Authority, O="The Go Daddy Group, Inc.", C=US.
 
 Testing the certificate date to confirm the certificate is valid.
  Date validation passed. The certificate hasn't expired.
   Additional Details
  The certificate is valid. NotBefore = 11/19/2010 3:57:26 PM, NotAfter = 11/26/2012 2:50:55 PM
 
 
 
 Checking the IIS configuration for client certificate authentication.
  Client certificate authentication wasn't detected.
   Additional Details
  Accept/Require Client Certificates isn't configured.
 
 Testing HTTP Authentication Methods for URL https://mail.pemconewarkdental.com/rpc/rpcproxy.dll.
  The HTTP authentication test failed.
   Additional Details
  A Web exception occurred because an HTTP 404 - NotFound response was received from IIS7.
 
 
 
0
 
LVL 9

Expert Comment

by:dexIT
ID: 34175520
I had a similar issue to this, this is almost a separate issue all together. As far as Active Sync goes, this should not affect being able to connect to a blackberry or iPhone. I would advise for you to verify the ActiveSync settings under the user's account, delete the account on the BB and retry to create it using the above format, I mentioned.
0
 
LVL 9

Expert Comment

by:dexIT
ID: 34175539
On EPS, perform a test-outlookwebservices and test-outlookconnectivity and post results please
0
 

Author Comment

by:SLEEPYAL
ID: 34175765
what is EPS? i'm sorry it doesn't ring a bell to me.
0
 
LVL 9

Expert Comment

by:dexIT
ID: 34205513
Exchange Power Shell, you can go to start->all programs->microsoft exchange server->exchange power shell
or open power shell and run add-pssnapin *e2010* followed by the above commands

test-outlookwebservices - http://technet.microsoft.com/en-us/library/bb124509.aspx
test-outlookconnectivity - http://technet.microsoft.com/en-us/library/dd638082.aspx
0
 

Expert Comment

by:ITLegal
ID: 34621742
I am having the exact same issue (as the opening of this forum) with a Blackberry and Exchange 2010.  Has anyone had further luck with this?
0
 

Accepted Solution

by:
SLEEPYAL earned 0 total points
ID: 34755770
the problem was that the ssl certificate had to be a multiple domain certificate and autodiscover had to be enabled somewhere that is what the problem was supposedly
0
 

Author Closing Comment

by:SLEEPYAL
ID: 34820040
done
0
 

Expert Comment

by:tango_it
ID: 38999651
Could you give more details regarding the ssl settings and autodiscover?
0

Featured Post

Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article aims to explain the working of CircularLogArchiver. This tool was designed to solve the buildup of log file in cases where systems do not support circular logging or where circular logging is not enabled
This article explains how to install and use the NTBackup utility that comes with Windows Server.
The video tutorial explains the basics of the Exchange server Database Availability groups. The components of this video include: 1. Automatic Failover 2. Failover Clustering 3. Active Manager
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…

790 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question