Novell client loaded, WinXP, slow initial browse/load of Windows 2008R2 files

We are moving from a Novell 5.1 network to a Windows 2008R2 server.  Still need the novell server for a while.  Have the Novell Client 32 4.91 sp5 loaded (tried with IR1 also).  No problem with Windows7 machines.  However, on WindowsXP machines, if the machine is idle for even 5 minutes, when you click on My Computer/Windows Explorer, or Application File open dialog or tried to open a file, the display of files in explorer delays for about 45 seconds as well as when tryinig to open the file.  Then after that it is quick,unless you have another period of inactivity.  

Symantec's SEP is not a factor.  If I uninstall the Novell Client, then the problem goes away.  If I reinstall the client, the problem reappears.  Since I need access to the Novell Server for a while yet, what is the solution.

cwsoft05Asked:
Who is Participating?
 
pgm554Connect With a Mentor Commented:
Check the binding order of the client on the XP machine(no ipx)and make sure you have SLP configures correctly.
0
 
johnb6767Connect With a Mentor Commented:
Not only the Bindings, but also check to make sure that the Providers are in teh right order.... Microsoft Networks at the top, WebClient at the bottom.....Any Novell stuff in the middle....
0
 
cwsoft05Author Commented:
There is typically ms ms file and print sharing. Ms net client. Ms terminal service. Synantec xxxx client. Novell client. Maybe ms web client. What is proper order. Win7 gas msfp. Msclient. Symantec or ms term next and netware last. Plea4ae clarify what specidfica"ly is best.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
pgm554Commented:
What is doing your DHCP,the Windows box?

Do you have an SLP (usually the ip address of the Netware box)provider in the in the DHCP scope configured?

http://support.microsoft.com/kb/285019
0
 
cwsoft05Author Commented:
Don't think I do. Win is doing dhcp. Netware was but I switched. I will chec0k that slp is configured on the netware box also. This is a 5.1 box
0
 
pgm554Commented:
SLP is how the NW client finds the NW box.If it can't see it ,it tries to multicast to find out what the resources are.
You could try putting in a static slp provider in the NW client and see if that fixes your issue.
You may be experiencing a hang because of this.
I remember this issue a very long time ago (2001)and am trying to remember the fix.

You might want to try this too:

Go int o the client properties, Protocol Preferences, for IP select just
SLP and NDS; then, still in the client properties, go into Advanced
Settings and change the Name Resolution timeout to 1 second from the
original 10.

Close Client settings, go into Control Panel -> Networking, then from
the Top menu Bar Go to Advanced -> Advanced Settings -> Provider Order.
Move the Microsoft Windows Network to the top, followed by the NetWare
Services.

0
 
pgm554Commented:
What's the MS spack on the XP boxes?

There was an issue with the mups.sys in earlier versions of XP.
0
 
BudDurlandCommented:
For us, the problem was with name resolution, NetWare looking up Windows server and vice versa.  

Check out this TID: http://www.novell.com/support/viewContent.do?externalId=7004092&sliceId=1

Specifically, scroll down to "solution 6".  It requires some registry editing, but it really did the trick for us.
0
 
cwsoft05Author Commented:
service pack 3
0
 
johnb6767Commented:
start>run>cmd

Post the contents of the txt file please.....


reg query "HKLM\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order" /s>np.txt
notepad np.txt
echo.

Open in new window

0
 
deroodeConnect With a Mentor Systems AdministratorCommented:
The problem comes from having two network providers (MS client and Novell client) .

When the workstation starts looking for a server, whichever Network provider is configured first in the binding order (Control panel - Network connections -  Advanced - Advanced settings - Provider order) will go out on the network looking for the servername. When it finds the correct name and type server it will return quickly, but when it doesn't find the correct type server (e.g. the MS clients looking for a Netware servername) it will timeout after 45 seconds, and only then pass control to the other network provider.

When most of your servers are MS, you may want to configure the MS client first, but experience delays when accessing a Netware server.

The Badnameserver cache configuration mentioned by BudDurland works well, but only works with the Novell client, so this works best when the Novell client configured as first. You then would either configure a high timeout (a day) but have each windows server lookup experience a delay as the Novell client times out and places the server in the Bad name cache, or prepopulate the bad name cache.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.