• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1941
  • Last Modified:

Mac OS X Windows 7 printer sharing greyed out

Hello-

I have a new Windows 7 PC connected via USB to an HP LaserJet 1320. This printer is shared on a peer-to-peer network, printer sharing is turned on, password protection required is turned off, and encryption is set to 40bit (not 128bit). On the network is a MacBook running Mac OS X 10.6.4. On the Mac, I went to add printer, Windows printer, located the printer on the network and associated the driver and printing worked fine.

A day or two later, the user reported that the printer stopped working. Now, whenever a job is sent to the printer, the printer queue on the Mac reports "On Hold (Authentication Required)". Pressing Resume and selecting either the Mac user or the guest account has no effect (recall that the Windows 7 PC should not be expecting a password at all as password protected sharing is turned off).

Expecting to find some Mac printer driver wonkiness, I went to System Settings and "Printer and Fax". I tried to re-add the same printer, only to find that when I go to add a printer, the entire "Windows" section is grayed out. I cannot add any Windows printers.

I look forward to any suggestions on how correct this printer issue.

Thanks,
CTSMKE
0
ctsmequon
Asked:
ctsmequon
  • 2
1 Solution
 
Lance_PCommented:
On the Windows 7 PC (assuming it is in workgroup) Set the administrator password and specify the same on the mac. This should work fine if its just an authentication issue.

The User can have his/her own login credentials.
0
 
ctsmequonAuthor Commented:
I ended up using LPR for this issue.

Mac OS X 10.6 to Windows 7 Shared Printing

On the Windows 7 PC
1. In Windows 7 Control Panel
2. Select "Programs and Features" pane
3. Click "Turn Windows Features on or off"
4. Click on the "LPD Print Service". Under "Print and Document Services"
5. Ensure printer(s) are shared

On the Mac
1. Open "System Preferences" - "Print & Fax"
2. Click "+" to add a printer
3. Right hand button tool bar to customize and add  "Advanced" button
4. Select "Advanced"
5. In the "Type:" field select "LPD/LPR Host or Printer"
6. In the "URL:" field enter lpd://IPserver/PrinterShareName; (e.g., lpd://10.0.1.4/mp800)
    Using lpd://ServeName/PrinterShareName does not work, the IP address must replace ServerName
    The IP address is the address of your PC, the one assigned by your router
7. Click the "Add" button
0
 
ctsmequonAuthor Commented:
The original question was never resolved. This is only a workaround.
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now