Solved

How to enable active FTP on Windows Server 2003 R2?

Posted on 2010-11-19
13
1,543 Views
Last Modified: 2012-05-10
Does anyone know how to enable active FTP on Windows Server 2003 R2?  Currently passive FTP, through IIS, is enabled, which won't work with our firewall rules.
0
Comment
Question by:KP0596
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
13 Comments
 
LVL 7

Expert Comment

by:DominoG
ID: 34174095
0
 

Author Comment

by:KP0596
ID: 34174148
I already googled for the above article, the problem is is that it doesn't tell you how to disable passive FTP and only run Active FTP.
0
 
LVL 10

Expert Comment

by:moon_blue69
ID: 34174193
That is to set up passive ftp. If its Just normal FTP go to windows components in add or remove programs. select iis and click on details select ftp and install it. Go to administrative tools click on IIS under local computer select ftp sites right click default ftp site and properties -> under security you can leave it at anonymous if you do not want to supply username and password. or add the users who can access it. On messages you can configure messages and on home directory you can set the directory you want to use
0
Free NetCrunch network monitor licenses!

Only on Experts-Exchange: Sign-up for a free-trial and we'll send you your permanent license!

Here is what you get: 30 Nodes | Unlimited Sensors | No Time Restrictions | Absolutely FREE!

Act now. This offer ends July 14, 2017.

 

Author Comment

by:KP0596
ID: 34175026
Thanks for the info Moon, however what you call "normal FTP" is passive FTP.  Passive FTP is what you get when you install FTP through IIS.  If you do a packet sniff, you'll see that It uses a random port between 1024-5000.  I need to figure out how to disable passive FTP and enable active FTP.
0
 

Author Comment

by:KP0596
ID: 34175069
A workaround might be to hard-code passive FTP to use a single port.  But I haven't tested that yet. Any other solutions would be greatly appreciated.

cd c:\inetpub\adminscripts
adsutil.vbs set /MSFTPSVC/PassivePortRange "5001-5001"

Open in new window

0
 

Author Comment

by:KP0596
ID: 34192659
Microsoft KB is the Microsoft KB with my exact problem:

Passive Connections May Fail Through a NAT-Based Firewall to IIS 6.0 and older FTP Server.

Microsoft Support is the KB on how to configure PassivePortRange in IIS
0
 
LVL 43

Expert Comment

by:Davis McCarn
ID: 34195929
Follow these directions to setup the FTP service using port 21 and pay attention to the "virtual directories" section: http://www.brighthub.com/computing/windows-platform/articles/23839.aspx  ( I also set a secondary ip address on the server's nic (i.e. 192.168.0.102), bound the FTP service to that ip, and setup the port forwarding in the router to it so I could monitor and/or disable the FTP without affecting other functions )
0
 

Accepted Solution

by:
KP0596 earned 0 total points
ID: 34231175
It turns out FTP needs access to two or more simultaneous ports.  After setting the ports, I restarted IIS FTP.  FTP services would not start.  This was caused by a port usage conflict.  So I changed the port ranges and IIS FTP is now working.

 
C:\Inetpub\AdminScripts>adsutil.vbs set /MSFTPSVC/PassivePortRange "5501-5510"
PassivePortRange                : (STRING) "5601-5610"

C:\Inetpub\AdminScripts>adsutil.vbs get /MSFTPSVC/PassivePortRange
PassivePortRange                : (STRING) "5601-5610"

Open in new window

FTP.PNG
0
 

Author Comment

by:KP0596
ID: 34231187
*Correction, the code snippet above should read:
C:\Inetpub\AdminScripts>adsutil.vbs set /MSFTPSVC/PassivePortRange "5601-5610"
PassivePortRange                : (STRING) "5601-5610"

C:\Inetpub\AdminScripts>adsutil.vbs get /MSFTPSVC/PassivePortRange
PassivePortRange                : (STRING) "5601-5610"

Open in new window

0
 

Author Comment

by:KP0596
ID: 34231206
FYI: Passive FTP and Active FTP are controlled/set on the client side, not the server side.  Clients default to passive FTP, so enabling Active FTP must be done by the client.  
0
 

Author Closing Comment

by:KP0596
ID: 34272736
Information was provided by MS Enterprise Support.
0

Featured Post

Office 365 Training for Admins - 7 Day Trial

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When it comes to showing a 404 error page to your visitors, you do not want that generic page to show, and you especially do not want your hosting provider’s ad error page to show either. In this article, I will show you how to enable the custom 40…
As tax season makes its return, so does the increase in cyber crime and tax refund phishing that comes with it
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…
This tutorial will teach you the special effect of super speed similar to the fictional character Wally West aka "The Flash" After Shake : http://www.videocopilot.net/presets/after_shake/ All lightning effects with instructions : http://www.mediaf…

690 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question