Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 652
  • Last Modified:

wordpress -while installing wp ecommerce plugin got fatal error: out of memory

Fatal error: Out of memory (allocated 22282240) (tried to allocate 203248 bytes) in /home/craigowe/public_html/spitfire-designs/wp-admin/admin.php on line 93

I asked server support to increase memory which they say they did but I still see memory_limit      36M in my phpinfo page.

This is the error I get when trying to log on to my dashboard. any idea how to fix this?

(I'm in a shared server env. and don't have access to php.ini)
0
phillystyle123
Asked:
phillystyle123
  • 3
  • 3
  • 2
3 Solutions
 
DzynitCommented:
It's most likely that it will be a plugin conflict.
Before increasing memory any more - deactivate all your plugins except wp-ecom, then turn one by one back on to find which one is conflicting with wp-ecom.
0
 
armchangCommented:
0
 
phillystyle123Author Commented:
that sounds like a good approach, but i can't get into my admin

when i go here:
http://craigoweb.com/spitfire-designs/wp-admin/

i get this:
Fatal error: Out of memory (allocated 22282240) (tried to allocate 203248 bytes) in /home/craigowe/public_html/spitfire-designs/wp-admin/admin.php on line 93

can i do it in the db?
0
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

 
DzynitCommented:
I'm not seeing that error when going to your link. Are you also still seeing it? or did you make a change?
0
 
phillystyle123Author Commented:
you have to log in to get it - the error is all that shows - no dashboard screen, just the error
0
 
phillystyle123Author Commented:
what if i install my previous version of my wp db before i tried to activate the wpsc plug in-will that work?
0
 
DzynitCommented:
You have ftp don't you? Safer than working with the DB, just ftp into your plugin folder and rename the wp-ecom folder to something else. It will deactivate so you can get back into your admin area.
0
 
armchangCommented:
Actually, you can disable the plugins via database. You need to backup first the script using:

SELECT * FROM wp_options WHERE option_name = 'active_plugins';

then copy paste the result into a notepad. After that do this:

UPDATE wp_options SET option_value = '' WHERE option_name = 'active_plugins';

After that all plugins are disabled, you can then  go login again and solve it using the Panel.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 3
  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now